## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Before you begin</strong></td>
<td>xv</td>
</tr>
<tr>
<td>Welcome</td>
<td>xv</td>
</tr>
<tr>
<td>How to use this guide</td>
<td>xvii</td>
</tr>
<tr>
<td>Symbols and conventions</td>
<td>xvii</td>
</tr>
<tr>
<td>Related documentation</td>
<td>xvii</td>
</tr>
<tr>
<td><strong>Chapter 1 Getting Started</strong></td>
<td>1</td>
</tr>
<tr>
<td>Overview</td>
<td>1</td>
</tr>
<tr>
<td>Using PSpice Schematics</td>
<td>2</td>
</tr>
<tr>
<td>Example—Drawing a Schematic</td>
<td>4</td>
</tr>
<tr>
<td>Starting a New Design</td>
<td>6</td>
</tr>
<tr>
<td>Command Line Options</td>
<td>6</td>
</tr>
<tr>
<td>Checking Symbol Libraries Configuration</td>
<td>7</td>
</tr>
<tr>
<td>Selecting and Placing Parts</td>
<td>8</td>
</tr>
<tr>
<td>Drawing and Labeling Wires</td>
<td>11</td>
</tr>
<tr>
<td>Drawing and Labeling Buses</td>
<td>12</td>
</tr>
<tr>
<td>Changing Reference Designators and Part Values</td>
<td>14</td>
</tr>
<tr>
<td>Moving Parts, Wires, and Text</td>
<td>15</td>
</tr>
<tr>
<td>Placing Ports</td>
<td>16</td>
</tr>
<tr>
<td>Placing Power and Ground Symbols</td>
<td>17</td>
</tr>
<tr>
<td>Saving Your Work</td>
<td>18</td>
</tr>
<tr>
<td><strong>Chapter 2 Using Design Manager</strong></td>
<td>19</td>
</tr>
<tr>
<td>Overview</td>
<td>19</td>
</tr>
<tr>
<td>Understanding Design Manager</td>
<td>20</td>
</tr>
<tr>
<td>Managing Your Files in the Workspace</td>
<td>22</td>
</tr>
<tr>
<td>Design Manager Functions</td>
<td>23</td>
</tr>
<tr>
<td>Starting the Design Manager</td>
<td>25</td>
</tr>
<tr>
<td>Hints and Tips</td>
<td>25</td>
</tr>
<tr>
<td>Design Manager Help</td>
<td>25</td>
</tr>
<tr>
<td>Contents</td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td></td>
</tr>
<tr>
<td>Opening a File</td>
<td>79</td>
</tr>
<tr>
<td>Finding Parts</td>
<td>80</td>
</tr>
<tr>
<td>Getting Parts by Name</td>
<td>81</td>
</tr>
<tr>
<td>Searching for Parts in the Libraries</td>
<td>82</td>
</tr>
<tr>
<td>Placing and Editing Parts</td>
<td>85</td>
</tr>
<tr>
<td>Rotating and Flipping Parts</td>
<td>86</td>
</tr>
<tr>
<td>Editing Part Attributes</td>
<td>88</td>
</tr>
<tr>
<td>Global Editing of Attributes</td>
<td>93</td>
</tr>
<tr>
<td>Editing the Default Attributes of a Symbol</td>
<td>94</td>
</tr>
<tr>
<td>Repeating Part Placements</td>
<td>95</td>
</tr>
<tr>
<td>Automatically Assigning Reference Designators</td>
<td>97</td>
</tr>
<tr>
<td>Example—Using Auto-Repeat and Auto Naming</td>
<td>98</td>
</tr>
<tr>
<td>Replacing Parts</td>
<td>100</td>
</tr>
<tr>
<td>Placing Power and Ground Symbols</td>
<td>102</td>
</tr>
<tr>
<td>Creating Custom Power and Ground Symbols</td>
<td>103</td>
</tr>
<tr>
<td>Using Wires and Buses</td>
<td>104</td>
</tr>
<tr>
<td>Drawing and Labeling Wires</td>
<td>104</td>
</tr>
<tr>
<td>Drawing and Labeling Buses</td>
<td>106</td>
</tr>
<tr>
<td>Automatically Labeling Wires and Buses</td>
<td>108</td>
</tr>
<tr>
<td>Specifying Drawing Options</td>
<td>109</td>
</tr>
<tr>
<td>Using Ports</td>
<td>114</td>
</tr>
<tr>
<td>Selecting and Moving Objects and Attributes</td>
<td>116</td>
</tr>
<tr>
<td>Selecting</td>
<td>116</td>
</tr>
<tr>
<td>Moving</td>
<td>117</td>
</tr>
<tr>
<td>Searching for and Selecting Parts</td>
<td>117</td>
</tr>
<tr>
<td>Cutting, Copying, and Pasting</td>
<td>119</td>
</tr>
<tr>
<td>Creating and Editing Title Blocks</td>
<td>122</td>
</tr>
<tr>
<td>Editing Page Title</td>
<td>122</td>
</tr>
<tr>
<td>Entering Information into the Title Block</td>
<td>123</td>
</tr>
<tr>
<td>Creating a Custom Title Block</td>
<td>124</td>
</tr>
<tr>
<td>Adding Non-Electrical Information</td>
<td>126</td>
</tr>
<tr>
<td>Text</td>
<td>126</td>
</tr>
<tr>
<td>Graphics</td>
<td>130</td>
</tr>
<tr>
<td>Annotation Symbols</td>
<td>134</td>
</tr>
<tr>
<td>Moving Non-Electrical Information</td>
<td>135</td>
</tr>
<tr>
<td>Creating and Editing Multi-sheet Designs</td>
<td>136</td>
</tr>
<tr>
<td>Adding a Page to a Design</td>
<td>136</td>
</tr>
<tr>
<td>Creating Connections Between Pages</td>
<td>137</td>
</tr>
<tr>
<td>Viewing Multiple Pages</td>
<td>138</td>
</tr>
<tr>
<td>Cutting, Copying and Pasting Between Pages</td>
<td>138</td>
</tr>
<tr>
<td>Deleting a Page</td>
<td>139</td>
</tr>
</tbody>
</table>
Chapter 5 Using the Symbol Editor 147

Overview .................................................. 147
Components ................................................. 149
Symbols .................................................... 149
Packaging Information ................................. 149
Footprints .................................................. 150
Simulation Models ....................................... 150
Starting the Symbol Editor ......................... 151
Loading a Library for Editing ....................... 151
Saving your Changes .................................. 152
Returning to the Schematic Editor ................. 152
Starting Automatically ................................. 152
Symbol Editor Window ............................... 153
Refreshing the Screen ................................. 153
Menus ....................................................... 153
Toolbar ..................................................... 154
Title Bar .................................................... 156
Keyboard .................................................... 157
Changing Text Characteristics ...................... 158
Attribute Text ............................................ 158
Pin Name and Number ................................ 160
Free-Standing Text ..................................... 161
Changing Grid and Gravity ............................ 162
Grid On ..................................................... 162
Stay-on-Grid .............................................. 162
Snap-to-Grid .............................................. 163
Grid Spacing .............................................. 163
Gravity ...................................................... 164
Text Grid ................................................... 165
Zooming and Panning ................................. 166
Printing Symbols ........................................ 167

Chapter 6 Creating and Editing Symbols 169

Overview .................................................... 169
Creating New Symbols .................................. 171
Using the Symbol Wizard .............................. 171
Creating a Symbol by Copying Another Symbol .... 173
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Making a Copy of a Symbol</td>
<td>173</td>
</tr>
<tr>
<td>Importing a symbol definition</td>
<td>174</td>
</tr>
<tr>
<td>Using AKO Symbols</td>
<td>175</td>
</tr>
<tr>
<td>Drawing Symbol Graphics</td>
<td>178</td>
</tr>
<tr>
<td>Elements of a Symbol</td>
<td>178</td>
</tr>
<tr>
<td>Selecting</td>
<td>182</td>
</tr>
<tr>
<td>Filling Shapes</td>
<td>183</td>
</tr>
<tr>
<td>Ordering Drawing Objects</td>
<td>184</td>
</tr>
<tr>
<td>Rotating and Flipping Elements</td>
<td>185</td>
</tr>
<tr>
<td>Moving</td>
<td>187</td>
</tr>
<tr>
<td>Resizing</td>
<td>187</td>
</tr>
<tr>
<td>Editing Existing Symbols</td>
<td>188</td>
</tr>
<tr>
<td>Accessing Symbols</td>
<td>188</td>
</tr>
<tr>
<td>Cutting, Copying, and Pasting</td>
<td>189</td>
</tr>
<tr>
<td>Defining and Editing Pin Types</td>
<td>191</td>
</tr>
<tr>
<td>Specifying Pin Types</td>
<td>191</td>
</tr>
<tr>
<td>Defining and Editing Hidden Power and Ground Pins</td>
<td>194</td>
</tr>
<tr>
<td>Changing Symbol Origin and Bounding Box</td>
<td>195</td>
</tr>
<tr>
<td>Editing Symbol Attributes</td>
<td>197</td>
</tr>
<tr>
<td>Using Symbol Aliases</td>
<td>200</td>
</tr>
<tr>
<td>Specifying Part Packaging Information</td>
<td>201</td>
</tr>
<tr>
<td>Pin Assignment Lists</td>
<td>201</td>
</tr>
<tr>
<td>Packaging Definitions</td>
<td>202</td>
</tr>
<tr>
<td>Creating a New Package Definition</td>
<td>202</td>
</tr>
<tr>
<td>Copying a Package Definition</td>
<td>203</td>
</tr>
<tr>
<td>Editing a Package Definition</td>
<td>204</td>
</tr>
<tr>
<td>Deleting a Package Definition</td>
<td>211</td>
</tr>
<tr>
<td>Configuring Package Types</td>
<td>212</td>
</tr>
<tr>
<td>Configuring Custom Libraries</td>
<td>214</td>
</tr>
<tr>
<td>Example—Creating Symbols from Scratch</td>
<td>216</td>
</tr>
<tr>
<td>Diode Bridge Rectifier</td>
<td>216</td>
</tr>
</tbody>
</table>

**Chapter 7 Creating and Editing Hierarchical Designs**

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>225</td>
</tr>
<tr>
<td>Hierarchical Design Methods</td>
<td>227</td>
</tr>
<tr>
<td>Creating and Editing Hierarchical Blocks</td>
<td>228</td>
</tr>
<tr>
<td>Associating an Existing Schematic</td>
<td>232</td>
</tr>
<tr>
<td>Creating and Editing Hierarchical Symbols</td>
<td>233</td>
</tr>
<tr>
<td>Creating a Hierarchical Symbol</td>
<td>233</td>
</tr>
<tr>
<td>Converting Hierarchical Blocks to Symbols</td>
<td>235</td>
</tr>
<tr>
<td>Using Interface Ports</td>
<td>236</td>
</tr>
</tbody>
</table>
Setting Package Class Priorities .......................... 284
Generating a Bill of Materials Report ..................... 286
Printing and Saving the Report ........................... 287
Customizing the Format of the Report .................... 288
User Defined Component Information ..................... 289
Exporting to a Spreadsheet or Database Program ....... 290
Swapping Pins ................................................. 291
Interfacing to Board Layout Products .................... 292
Layout Mapping Files ........................................ 294
Back Annotation .............................................. 298

Appendix A  Exporting DXF Files 301
Overview ......................................................... 301
Exporting DXF Files ........................................... 302
Exporting from the Schematic Editor ..................... 303
Exporting in the Symbol Editor ............................ 304

Appendix B  Library Expansion and Compression Utility 305
Overview ......................................................... 305
Using the Library Utility ..................................... 306
Expanding Library Definitions into Text Files ............ 307
Compressing Definition Files into a Library .............. 307
Salvaging a Corrupted File .................................. 308
Reorganizing a Library File .................................. 308
.lst File Format ................................................ 308
Running LXCWin Using Command Line Options .......... 309

Appendix C  Advanced Netlisting Configuration Items 311
Overview ......................................................... 311
Specifying PSpice Node Name Netlisting Preferences .... 312
Specifying Board Layout Node Name Netlisting Preferences 313
Customizing EDIF Netlists ................................. 314

Appendix D  Attribute List 315
Overview ......................................................... 315

Appendix E  Symbol Libraries 321
Overview ......................................................... 321
Using Symbol Libraries ..................................... 322
## Figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Figure 1</td>
<td>Interaction of Sim Software Programs and Files</td>
<td>3</td>
</tr>
<tr>
<td>Figure 2</td>
<td>Opto-isolated, Addressable Serial-to-parallel Converter Circuit</td>
<td>5</td>
</tr>
<tr>
<td>Figure 3</td>
<td>Border Styles</td>
<td>50</td>
</tr>
<tr>
<td>Figure 4</td>
<td>Placing Resistors with Various Vertical and Horizontal Offsets</td>
<td>96</td>
</tr>
<tr>
<td>Figure 5</td>
<td>Auto Naming for Bus Labels</td>
<td>98</td>
</tr>
<tr>
<td>Figure 6</td>
<td>Orthogonal Wire Drawing</td>
<td>109</td>
</tr>
<tr>
<td>Figure 7</td>
<td>Rubberbanding with Orthogonal enabled</td>
<td>112</td>
</tr>
<tr>
<td>Figure 8</td>
<td>Rubberbanding with Orthogonal disabled</td>
<td>112</td>
</tr>
<tr>
<td>Figure 9</td>
<td>Rubberbanded path showing a potential connection</td>
<td>113</td>
</tr>
<tr>
<td>Figure 10</td>
<td>Off-page Port</td>
<td>114</td>
</tr>
<tr>
<td>Figure 11</td>
<td>Global Ports</td>
<td>114</td>
</tr>
<tr>
<td>Figure 12</td>
<td>Selection rectangle</td>
<td>116</td>
</tr>
<tr>
<td>Figure 13</td>
<td>Printing with Auto-Fit Enabled</td>
<td>142</td>
</tr>
<tr>
<td>Figure 14</td>
<td>Zoom Factor Set to 100% with Printer Configured in Portrait Mode</td>
<td>142</td>
</tr>
<tr>
<td>Figure 15</td>
<td>Zoom Factor Set to 200% with Printer Configured in Portrait Mode</td>
<td>143</td>
</tr>
<tr>
<td>Figure 16</td>
<td>User-definable Zoom Enabled in Portrait Mode</td>
<td>144</td>
</tr>
<tr>
<td>Figure 17</td>
<td>User-definable Zoom Enabled in Landscape Mode</td>
<td>145</td>
</tr>
<tr>
<td>Figure 18</td>
<td>Pin Types</td>
<td>191</td>
</tr>
<tr>
<td>Figure 19</td>
<td>Example of Diode Bridge Rectifier Symbol</td>
<td>217</td>
</tr>
<tr>
<td>Figure 20</td>
<td>Top-level Schematic Drawing for CMOS Inverter</td>
<td>244</td>
</tr>
<tr>
<td>Figure 21</td>
<td>Schematic of CMOS Inverter</td>
<td>248</td>
</tr>
<tr>
<td>Figure 22</td>
<td>A Working Schematic and Two Checkpoint Schematics</td>
<td>273</td>
</tr>
<tr>
<td>Figure 23</td>
<td>Entire Connector Symbol</td>
<td>278</td>
</tr>
<tr>
<td>Figure 24</td>
<td>Single Pin Symbol</td>
<td>278</td>
</tr>
<tr>
<td>Figure 25</td>
<td>Bill of Materials Report</td>
<td>286</td>
</tr>
</tbody>
</table>
Tables

Table 1  Remaining Parts to be Placed ................................................. 10
Table 2  Standard Schematics Toolbar ................................................. 33
Table 3  Drawing Toolbar ............................................................... 35
Table 4  Simulation Toolbar ............................................................. 36
Table 5  Annotation Graphics Toolbar ............................................... 38
Table 6  Schematic Editor Function Keys .......................................... 40
Table 7  Zoned Border Default Decimal Parameters ............................. 51
Table 8  Zoned Border Default Metric Parameters ............................... 51
Table 9  Attribute Text Characteristics .............................................. 92
Table 10 Symbol Editor Toolbar Buttons .......................................... 154
Table 11 Symbol Editor Function Keys ............................................. 157
Table 12 Display Characteristics ..................................................... 159
Table 13 Content Options .............................................................. 168
Table 14 Distinctions Between Connectors and Ports ............................ 277
Table 15 Supported Layout Packages and File Formats ....................... 292
Table 16 .lst File Format ............................................................... 308
Welcome

Orcad family products offer a total solution for your core design tasks: schematic- and VHDL-based design entry; FPGA and CPLD design synthesis; digital, analog, and mixed-signal simulation; and printed circuit board layout. What's more, Orcad family products are a suite of applications built around an engineer’s design flow—not just a collection of independently developed point tools. PSpice Schematics is just one element in our total solution design flow.

PSpice Schematics is a schematic capture front-end program with a direct interface to PSpice.

In one environment, you can do all of the following using PSpice Schematics:

- design and draw circuits
- simulate circuits using PSpice
- analyze simulation results using Probe
• graphically characterize simulation stimuli using the fully integrated PSpice Stimulus Editor, so stimulus definitions are automatically associated with the appropriate symbols

• graphically characterize simulation models using the fully integrated PSpice Model Editor utility, so model definitions are automatically associated with the appropriate symbols

• interface to PSpice Optimizer for analog circuit performance optimization

• interface to PCB programs for printed circuit board layout

PSpice Schematics is fully integrated with PSpice, giving you the flexibility to work through your circuit design in a consistent environment.
How to use this guide

This guide is designed so you can quickly find the information you need to use PSpice Schematics. To help you learn and use PSpice Schematics efficiently, this manual is separated into the following sections:

- Chapter 1 - Getting started
- Chapter 2 - Using Design Manager
- Chapter 3 - Using the schematic editor
- Chapter 4 - Creating and editing designs
- Chapter 5 - Using the Symbol Editor
- Chapter 6 - Creating and editing Symbols
- Chapter 7 - Creating and editing hierarchical designs
- Chapter 8 - Preparing your design for simulation
- Chapter 9 - Using Design Journal
- Chapter 10 - Preparing your design for board layout

Symbols and conventions

Our printed documentation uses a few special symbols and conventions.

<table>
<thead>
<tr>
<th>Notation</th>
<th>Examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Ctrl)+[R]</td>
<td>Press (Ctrl)+[R].</td>
<td>Means to hold down the [Ctrl] key while pressing [R].</td>
</tr>
<tr>
<td>(Alt), [F], [O]</td>
<td>From the File menu, choose Open (Alt), [F], [O]).</td>
<td>Means that you have two options. You can use the mouse to choose the Open command from the File menu, or you can press each of the keys in parentheses in order: first [Alt], then [F], then [O].</td>
</tr>
<tr>
<td>Monospace font</td>
<td>In the Part Name text box, type PARAM.</td>
<td>Text that you type is shown in monospace font. In the example, you type the characters [P], [A], [R], [A], and [M].</td>
</tr>
</tbody>
</table>
**Related documentation**

In addition to this guide, you can find technical product information in the online help, online books, and our technical web site, as well as in other books. The table below describes the types of technical documentation provided with PSpice Schematics.

<table>
<thead>
<tr>
<th>This documentation component . . .</th>
<th>Provides this . . .</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>This online guide—</strong></td>
<td>An online, searchable version of this guide, available when choosing Online Manuals from the Orcad family program group (on the Start menu).</td>
</tr>
<tr>
<td><em>PSpice Schematics User’s Guide</em></td>
<td>Comprehensive information for understanding and using the features available in PSpice Schematics. You can access help from the Help menu in PSpice Schematics, by choosing the Help button in a dialog box, or by pressing [F1]. Topics include:</td>
</tr>
<tr>
<td>Online help</td>
<td>• Explanations and instructions for common tasks.</td>
</tr>
<tr>
<td></td>
<td>• Descriptions of menu commands, dialog boxes, tools on the toolbar and tool palettes, and the status bar.</td>
</tr>
<tr>
<td></td>
<td>• Error messages and glossary terms.</td>
</tr>
<tr>
<td></td>
<td>• Reference information.</td>
</tr>
<tr>
<td></td>
<td>• Product support information. You can get context-sensitive help for a error message by placing your cursor in the error message line in the session log and pressing [F1].</td>
</tr>
<tr>
<td>This documentation component</td>
<td>Provides this...</td>
</tr>
<tr>
<td>------------------------------</td>
<td>------------------</td>
</tr>
<tr>
<td>Orcad family customer support at <a href="http://www.orcad.com/technical/technical.asp">www.orcad.com/technical/technical.asp</a></td>
<td>An Internet-based support service available to customers with current support options. A few of the technical solutions within the customer support area are:</td>
</tr>
<tr>
<td></td>
<td>• The Knowledge Base, which is a searchable database containing thousands of articles on topics ranging from schematic design entry and VHDL-based PLD design to PCB layout methodologies. It also contains answers to frequently asked questions.</td>
</tr>
<tr>
<td></td>
<td>• The Knowledge Exchange, which enables you to share information and ideas with other users and with our technical experts in a real-time online forum. You can submit issues or questions for open discussion, search the Knowledge Exchange for information, or send email to another participant for one-on-one communication. A list of new postings will appear each time you visit the Knowledge Exchange, providing you with a quick update of what's been discussed since your last visit.</td>
</tr>
<tr>
<td></td>
<td>• The Technical Library, which contains online customer support information that you can search through by category or product. You can find product manuals, product literature, technical notes, articles, samples, books, and other technical information. Additionally, technical information can be obtained through SourceLink, which is an online customer support information service for users of Cadence software other than Capture, Component Information System (CIS), Express, Layout, or PSpice.</td>
</tr>
<tr>
<td></td>
<td>• The Support Connection, which allows you to choose to either view and update existing incidents, or create new incidents. The information is delivered directly to us via our internal database. This service is only available to customers with current maintenance or Extended Support Options (ESOs) in the United States and Canada.</td>
</tr>
<tr>
<td></td>
<td>• The Live Connection, which enables you to open access to your computer to a Customer Support person, who can then view your actions on your computer monitor as you demonstrate the problem you’re having. Live Connection’s two-way transmission can also let you view the actions on the Customer Support person’s computer monitor, as he or she demonstrates a method or procedure to help you solve your problem. To participate in Live Connection, you need to contact a Customer Support person, in order to obtain a support number to grant you access to the Live Connection site, and to set up a time to “meet online” using Live Connection.</td>
</tr>
</tbody>
</table>
Overview

This chapter describes Schematics: what it is, what it can do, and how you can use it.

This chapter has the following sections:

Using Schematics on page 1-2 provides a broad overview and describes various functions.

Example—Drawing a Schematic on page 1-4 provides a step-by-step example of creating a schematic.
Using Schematics

Schematics is a schematic capture front-end program that provides a convenient system for:

- creating and managing circuit drawings.
- setting up and running simulations.
- evaluating simulation results using MicroSim Probe.
- creating netlists for external PCB layout packages.

An important prerequisite to building a schematic is availability of proper symbols for assembly. Schematics has extensive symbol libraries and a fully integrated symbol editor for creating your own symbols or modifying existing symbols.

The main functions of Schematics are:

- creating and editing designs
- creating and editing symbols
- creating and editing hierarchical designs
- preparing a design for simulation
- preparing a design for board layout

These primary functions are described in the following chapters.
Using Schematics

Figure 1

Interaction of Sim Software Programs and Files

- packages
- symbols
- models
- PCB Layout
- footprints
- layout netlist file
- netlist & packaging information
- PSpice Schematics
- Probe
- Probe data file
- simulation results
- simulation output file
- component description file
- Bill of Materials reports
- circuit file
- netlist & simulation directives
- symbol definitions
- package definitions
- PCB Layout footprints
- PSpice A/D
- simulation audit
- Probe markers
- component definitions
- symbol definitions
- bill of materials reports
- simulation output files
- audit

- package definitions
- netlist & packaging information
- Probe markers
- simulation results
- simulation output file
- package definitions
Example—Drawing a Schematic

The following example demonstrates the basic drawing features for drawing a schematic. It shows you how to:

- start the schematic editor and begin a new design.
- find out which libraries are configured for Schematics.
- place parts on a schematic.
- connect the part using wires and buses.
- label wires and buses.
- change reference designators and part values.
- move parts, wires and text.
- use ports on a schematic.
- place power and ground symbols on a schematic.
- save your design.

Follow this example to create the circuit shown in Figure 2.
Figure 2 Opto-isolated, Addressable Serial-to-parallel Converter Circuit
Starting a New Design

Start the schematic editor by double-clicking on the Schematics icon in the Orcad program group. An empty schematic page displays.

If you already have Schematics running with another schematic displayed, click the New File icon to start a new schematic.

Command Line Options

PSpice Schematics supports a number of command line options that enable you to customize the start-up mode. You can add one or more of these options to the Command Line text box of the Program Item Properties dialog box (File/Properties from within the Program Manager) for the Windows Schematics program icon.

The command line options are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-i &lt;filename.ini&gt;</td>
<td>activates Schematics using a specific file (specified by &lt;filename.ini&gt;) for configuration settings, rather than the default: pspice.ini</td>
</tr>
<tr>
<td>-sym</td>
<td>activates Schematics with a new Symbol Editor document window</td>
</tr>
<tr>
<td>&lt;filename&gt;</td>
<td>activates Schematics and loads the schematic file specified by &lt;filename.sch&gt;</td>
</tr>
</tbody>
</table>
Checking Symbol Libraries Configuration

When you installed Schematics, you selected a set of libraries to be installed. These are global libraries, which means the symbols contained in them are available to be used in any new or existing schematic.

Check to see that you have the correct symbol libraries configured for this example:

1. From the Options menu, select Editor Configuration.

2. Check that the following libraries are included in the Libraries list box:
   
   - 7400 [.slb,.plb]
   - analog [.slb,.plb]
   - opto [.slb,.plb]
   - port [.slb]
   - 1_SHOT [.slb]

Note: If you are using the evaluation version of Schematics, you will be using “eval.slb”.

Selecting and Placing Parts

1. From the Draw menu, select Get New Part to display the Part Browser dialog box.

2. There are several ways to select a part in the Part Browser dialog box:
   - If you know the name of the part, type the name in the Part Name text box.
   - Select the part name from the Full List of part names.
   - Click Libraries to view the Library Browser dialog box, select a library, and select the part name from that library’s list of parts.

3. Click Place to place the part (with the browser remaining open) or click Place & Close (to place the part and close the browser). If you leave the browser open, click the title bar of the dialog box and drag it to a new location.
Placing resistors R1 and R2

1. From the Draw menu, select Get New Part to display the Part Browser dialog box (shown on 1-8).
2. Type R in the Part Name text box.
3. Click Place & Close. The outline of the resistor becomes attached to the pointer.

   Note that as you move the pointer, the X and Y coordinates at the left of the Status Bar (bottom of the window) change. These coordinates show the location of the pointer from origin 0,0 (upper left corner) to the closest 0.01 inch (or closest mm if you are using a metric page size).
4. Press Ctrl+R to rotate the resistor before placing it.
5. Move the pointer to the 2.40, 1.80 coordinates (within a few hundredths of the inch is close enough) and click to place the resistor on the schematic. If the Stay-on-Grid option is enabled, parts are automatically placed on the nearest grid point.
6. Move the pointer to 2.40, 3.90 and click again to place the second resistor on the schematic.
7. Right-click to stop placing the part.

Placing resistors R3 through R6

You can quickly place resistors R3 through R6 using the Auto-Repeat function.

1. From the Options menu, select Auto-Repeat to display the Auto-Repeat dialog box.
   a. Set Horizontal Offset to 00.00 and Vertical Offset to -00.20.
   b. Select the Enable Auto-Repeat check box.
   c. Click OK.
2. From the Get Recent Part list box on the toolbar, select R.
3 Place the pointer in the approximate position for the placement of R3 and click to place the part.

4 Press \texttt{Space} three times to place three more resistors above the first.

**Placing resistors R7 through R10**

1 From the Get Recent Part list box on the toolbar, select R.

2 Press \texttt{Ctrl}+\texttt{R} to rotate the resistor before placing it.

3 Place four resistors in the approximate locations of R7, R8, R9, and R10.

4 Right-click to stop placing resistors.

**Placing the remaining parts on the schematic**

1 Click the Get New Part button.

2 In the Part Browser dialog box, select each part listed in Table 1 from the Part list box.

3 Place the part on the schematic in the approximate location shown in Figure 2.

### Table 1 Remaining Parts to be Placed

<table>
<thead>
<tr>
<th>Reference Designator</th>
<th>Part Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>C</td>
</tr>
<tr>
<td>U1</td>
<td>A4N25</td>
</tr>
<tr>
<td>U2</td>
<td>A4N25</td>
</tr>
<tr>
<td>U3</td>
<td>74164</td>
</tr>
<tr>
<td>U4</td>
<td>74164</td>
</tr>
<tr>
<td>U5</td>
<td>74174</td>
</tr>
<tr>
<td>U6</td>
<td>74174</td>
</tr>
<tr>
<td>U7</td>
<td>7485</td>
</tr>
</tbody>
</table>
Drawing and Labeling Wires

Draw the wire labeled dataclk to connect pin 8 (CLK) on U3 and pin 1 (A) on U8A.

Drawing the dataclk wire

1. Click the Draw Wire button. The pencil pointer indicates that you are ready to draw a wire.
2. Click pin 8 of U3 to begin the wire.
3. Following the illustration in Figure 2, click where you want each vertex of the wire. Each click ends a wire segment and starts a new one.
4. Click pin 1 of U8A. Notice that the wire is now ended where you clicked to place a pin. The pointer remains in the shape of a pencil and you are ready to start another wire.
5. Wire the rest of the schematic to the bus, except for the wires of the right sides of U5 and U6.
6. Right-click to stop drawing wires.

Labeling the dataclk wire

Label the wire connecting the CLK pin of U3 to the A pin of U8A.

1. Double-click any segment of the wire to display the Set Attribute Value dialog box.
2. Type dataclk in the LABEL text box.
3. Click OK.
Drawing and Labeling Buses

Draw the bus labeled DB[1-12].

Drawing the bus

1. Click the Draw Bus button. The pointer is now shaped like a pencil (as it was when you were drawing wires).
2. Click where you want to start the bus.
3. Click the pointer where you want to end the bus.
4. Right-click to stop drawing buses.

Labeling the bus

1. Double-click any segment of the bus to display the Set Attribute Value dialog box.
2. Type DB[1-12] in the LABEL text box.
3. Click OK.

Connecting wires to the bus

1. From the Options menu, select Auto-Repeat to display the Auto-Repeat dialog box.
   a. Set the Vertical Offset to 00.10.
   b. Ensure that Enable Auto-Repeat is enabled.
   c. Click OK.
2. Click the Draw Wire button and draw a wire from pin 2 of U5 to the bus.
3. Press Space five times to place five more wires.
4. Click the Draw Wire button and draw a wire from pin 2 of U6 to the bus.
5. Press Space five times to place five more wires.

You can use the Auto-Repeat function to place the wires that connect the pins to the bus because the wires will be the same length and fixed distances.

Buses must be labeled. Examples of legal bus names are:

- DB[0-12]
- DB[0:12]
- DB[0..12]
- DBO, DB1, CLK
**Labeling the wires connected to the bus**

You can use Auto-Naming to label a uniform collection of wires.

1. From the Options menu, select Auto-Naming to display the Auto Naming dialog box.
   a. In the Wire/Port Labels frame, select the Enable Auto-Increment check box.
   b. In the Label Template text box, type `DB1`, which is the label for the first wire in the series.
      Wires will be labeled incrementally from DB1 and up.
   c. Click OK.

2. Select the first (lower-most) wire to be labeled.

3. Press `Ctrl+E` to label the wire.

4. Repeat steps 2 and 3 for each wire segment, in the order they are to be labeled (from bottom to top).

**Note** Each wire connecting to a bus must be labeled with the name of one of the signals on the bus.
Changing Reference Designators and Part Values

Change part values and reference designators by double-clicking them and typing a new value in the dialog box.

**Changing U8A to U9B**

1. Double-click U8A to display the Edit Reference Designator dialog box.
2. Type U9 in the Package Reference Designator text box.
3. Type B in the Gate text box.
4. Click OK.

**Changing R9 from 1 kohm to 100 kohm**

1. Double-click 1k (next to resistor R9) to display the Set Attribute Value dialog box.
2. Change 1k to 100k.
3. Click OK.

Now, change the value of R10 to 100k and the values of R3 through R8 to 10k.

When you place a part on the schematic, the part is automatically assigned a reference designator and a gate (if it is a multi-part component). For instance, when you placed the 74123 part, it was assigned something like U8A (that is, reference designator U8 and gate A).

If you placed any of the components in an order other than the sequential order shown in Figure 2, use this feature now to change the reference designators to match the schematic in Figure 2.
Moving Parts, Wires, and Text

Move parts, wires, buses, and text by clicking to select them, and dragging them to a new location. To maintain connectivity when moving parts, wires, or buses, enable the rubberbanding option.

**Moving resistor R1 up one grid**

1. Click the resistor to select it.
2. Drag the resistor up one grid.
3. Place the resistor at the new location.

Part values, reference designators, and other text can be moved in the same way.

**Moving the value of R10**

1. Click the 100k value of the resistor.
   - The box outline around the value indicates that it is selected.
   - The box outline around the resistor shows that the resistor is the owner of the selected value.
2. Drag the value of the resistor to a new location.
   - The box representing the 100k value follows as you move the pointer.

For information on how to enable the rubberbanding option, see Rubberbanding on page 4-111.

The color of the selected resistor is the color specified for the Selection display layer in the Display Preferences dialog box (see Configuring Colors on page 3-63).
Placing Ports

Ports in Schematics identify signals that are inputs or outputs to a schematic. Place ports in the same way that you place other parts.

Placing the port

1. From the Draw menu, select Get New Part to display the Part Browser dialog box (shown on page 8).
2. Click Libraries to display the Library Browser dialog box.
3. In the Library list box, select port.slb.
4. In the Part list box, select GLOBAL (which is the name of a global port symbol).
5. Click OK.
6. In the Part Browser dialog box, click Place & Close.
7. Move the pointer to the location for the DAT port and click to place the part.
8. Right-click to stop placing ports.
Labeling the port

1. Double-click the port symbol to display the Set Attribute Value dialog box.
2. Type DAT in the LABEL text box.
3. Click OK.

Now place two more ports and label them CLK and RTN as shown in Figure 2.

Placing Power and Ground Symbols

Power and ground symbols are types of global port symbols in Schematics. The label on the port defines the name of the power supply.

Placing +5-volt power supplies

1. Type +5V in the Get Recent Part list box on the toolbar.
2. Press Enter to select the part.
3. Move the pointer to the location of the +5V symbol and click to place the symbol.
4. Move the pointer and click to place the other nine +5V symbols.
5. Right-click to stop placing parts.

All signals tied to power supplies of the same name are connected.
Placing ground symbols

1. In the Get Recent Part list box on the toolbar, type `EGND`.
2. Press `Enter` to select the part.
3. Move the pointer to the location of the ground symbol and click to place the symbol.
4. Move the pointer and click to place the other four ground symbols.
5. Right-click to stop placing parts.

Saving Your Work

Click the File Save button, or select Save (or Save As) from the File menu to save the schematic.

If this is a new design, you are prompted to enter a file name where the new schematic will be saved.
Using Design Manager

Overview

This chapter provides introductory information about the Design Manager.

This chapter has the following sections:

Understanding Design Manager on page 2-20 describes the purpose and uses for Design Manager.

Managing Your Files in the Workspace on page 2-22 explains what a workspace is and how to manage your files within it.

Design Manager Functions on page 2-23 describes Design Manager functions and activities.

Starting the Design Manager on page 2-25 describes how to start the Design Manager.

Design Manager Help on page 2-25 describes where to find Design Manager Help.
Understanding Design Manager

Design Manager allows you to browse, manage, archive, and restore your design files.

When you open a design file, Design Manager searches the Windows Explorer for the following information:

- the name of the top-level folder where the file is stored
- the names of all files within the top-level folder and its sub-folders
- the names of files in folders outside the top-level folder that are linked to files within the top-level folder

Design Manager gathers this information, arranges and displays it in categories that show the relationships of the files to one another. For instance, all PSpice Schematics .sch files are listed in the Design Entry Files category, while all simulation .dat and .out files are listed in the Simulation Results category. Hierarchical schematics are shown as child schematics to the parents.
Managing Your Files in the Workspace

Design Manager views a file’s top-level folder (as seen in Windows Explorer) as a workspace and assigns it the name of the top-level folder.

Although workspaces are actual folders, categories are not. Categories only display files found after Design Manager searches the top-level folder and its sub-folders, making it easy for you to identify and manage them. Dependent files (such as hierarchical sub-schematic and symbol library files) that are stored outside the workspace, show a reference to their location.

You can copy and move all files, or a selected sub-set, from one workspace to another workspace. This principle applies to deleting files as well. Because categories are for display purposes only, you cannot move or copy files from one category type to another category type.

Design Manager also provides cut, copy, paste, and delete operations at an individual file level, that work similar to the same functions in Windows Explorer.

When files are copied, moved, or saved to a workspace, Design Manager automatically arranges their display into the appropriate file-type categories. Windows Explorer (when opened or refreshed) reflects the action taken in the workspace.

Note To get the optimal use of Design Manager, it is recommended that only files related to one design be stored in one top-level folder, and therefore in one workspace. Also, because Design Manager can perform operations on a design file and all of its dependent files simultaneously, perform file management functions within Design Manager, rather than Windows Explorer.

Multiple workspaces, in their own windows, can be open simultaneously for browsing and file management activities.

Because categories are for display purposes only, you cannot move or copy files from one category type to another category type.
Design Manager Functions

The following describes Design Manager functions and activities:

General characteristics

• availability for use without other Orcad programs running
• automatic categorization of design-related files, sorted into file-type categories, within a workspace
• ability to have multiple workspaces, in their own windows, open simultaneously
• two methods (view by Category and view by Name) with which you can view and manage all files within a selected workspace, as well as external references to files outside the selected workspace

File management

• copy, move, and delete all files (or optionally a selected sub-set), from one workspace to another
• optionally cut, delete, copy, and archive all dependent files
• cut, delete, copy, and paste files as similarly done in Windows Explorer
• drag-and-drop functionality
• acceptance of files from Windows Explorer, through commands or drag-and-drop
• ability to create top-level folders in Windows Explorer from Design Manager
Archive and restore

- archive and restore to save a design and all of its references, package files for shipment to another location, save disk space, and localize externally referenced and shared files into a selected workspace
Starting the Design Manager

The Design Manager is automatically opened and minimized when you open PSpice Schematics. You can also open Design Manager to view and manage files without first opening Schematics.

Opening the Design Manager outside of Schematics

1. On the task bar, click the Start button.
2. Point to Programs.
3. Point to the Orcad folder.
4. Click Orcad Design Manager.

Design Manager opens with the Category view in effect.

Hints and Tips

- To get optimal use of Design Manager, place only files related to one design in one workspace.
- It is beneficial to perform file management functions within Design Manager, rather than Windows Explorer. Design Manager can perform operations on a design file and all of its dependent files simultaneously.

Design Manager Help

Refer to PSpice Schematics Help and Design Manager Help for procedures on how to use Design Manager.
Overview

This chapter provides background information about the schematic editor. To see specific step-by-step instructions for creating a design, see Chapter 4, Creating and Editing Designs.

This chapter has the following sections:

Components of a Design on page 3-29 introduces and explains the components of a design.

Main Window on page 3-32 describes the user interface to the schematic editor. This section describes the uses of menus, the toolbar and toolbar buttons, the status line and the keyboard.

Configuring PSpice Schematics on page 3-41 provides information on configuring the schematic editor to suit your requirements.

Controlling the Display in PSpice Schematics on page 3-60 describes how to control the display and printing of layers.
of your schematic, in addition to specifying colors and sizes.

*Zooming and Panning in Schematics on page 3-68* tells how to zoom in and out of the drawing, refresh the screen display, pan to various sections of the drawing and fit the drawing to the page.

*Using the Message Viewer on page 3-73* describes the Message Viewer that displays system messages and explains the various displays and controls.
Components of a Design

A schematic consists of:
- symbols
- attributes
- wires
- buses
- text items

Schematics can have either a flat or hierarchical structure, depending on the way you decide to implement your design.

Parts

Parts are electrical devices that make up a circuit, such as:
- resistors
- operational amplifiers
- diodes
- voltage sources
- digital gates

The graphical representation of a part is a symbol. Symbols are stored in symbol libraries.

PSpice Schematics uses two basic types of parts: primitive and hierarchical.

Primitive parts are at the lowest level and explicitly contain all of the information required by the netlister. Most symbols in the symbol libraries are primitive parts.

Hierarchical parts have the same appearance as primitive parts. The difference is that hierarchical parts represent one or more levels of schematics and primitive parts do not.

A hierarchical part is modified by pushing into it from within the schematic editor or symbol editor and editing the associated schematic.

A primitive part is modified by editing its graphics, pins, and attributes.
Symbols

Symbols are the graphical representation of parts, ports, and other schematic elements. They are grouped by functionality into symbol libraries. Each symbol contains a specific set of attributes that define the symbol. You can edit these attributes as well as create new attributes. Symbols can share similar attributes and graphics. Hierarchical symbols represent schematics and are the mechanism that you use to create hierarchical designs.

Ports

Ports are symbols that form connecting points leading into or out of the schematic page. Ports provide connectivity between schematic pages and between levels of hierarchy. They play an important role in determining names of electrical nets.

Attributes

Parts, ports, wires (nets), buses, and most other symbols have associated attributes. An attribute consists of a name and an associated value. Attributes are used for Bill of Materials reports, and simulation and layout netlists.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>PKGTYPE</td>
<td>RC05</td>
</tr>
<tr>
<td>VALUE</td>
<td>1K</td>
</tr>
</tbody>
</table>

Annotations

Text, graphics, and annotation symbols are used to show non-electrical information on the schematic, such as comments and tables. Annotation symbols primarily consist of text and graphics. Title blocks and page borders are considered annotations. For more information on adding annotations to your schematic, see Adding Non-Electrical Information on page 4-126.
Connections

Parts and ports contain one or more pins where connections are made. Electrical connections are formed by wire and bus segments joining pins and other wire and bus segments. Connections are also formed by attaching pins directly to pins. PSpice Schematics represents each such electrical connection by a junction. Junctions are made visible when three or more connected items converge at the junction. Junctions are created and removed automatically.

Some parts have hidden pins. Hidden pins are most often used for power and ground connections to digital parts. Hidden pins are not connected by wires and buses, but rather through an attribute that names the net, which they belong (the \texttt{PIN(<pinname>)=<netname>} attribute) to.
Main Window

When you start PSpice Schematics, a schematic editor window opens and displays a single schematic page. You have the option of opening additional schematic editor windows. Use these windows to:

- display different schematics.
- display different portions of a single schematic page.
- display different pages of the same schematic.
- display different levels of hierarchy from the same schematic.
- display a separate symbol editor window.

Menus

The display and operation of the menus and submenus in PSpice Schematics follows a standard Windows layout and operation.
Toolbars

Toolbar buttons provide shortcuts for performing common actions. All toolbars are dockable, so they may be moved to any location on the schematic.

Standard Schematics

The Standard Schematics toolbar provides shortcuts to standard Windows commands.

Table 2  Standard Schematics Toolbar

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Function</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>New File</td>
<td>opens a new schematic file</td>
<td>4-79</td>
</tr>
<tr>
<td></td>
<td>Open File</td>
<td>opens an existing schematic file</td>
<td>4-79</td>
</tr>
<tr>
<td></td>
<td>Save File</td>
<td>saves a schematic file</td>
<td>4-14</td>
</tr>
<tr>
<td></td>
<td>Print (immediate)</td>
<td>prints the active schematic</td>
<td>4-14</td>
</tr>
<tr>
<td></td>
<td>Cut</td>
<td>deletes a selected object and copies it to the clipboard</td>
<td>4-11</td>
</tr>
<tr>
<td></td>
<td>Copy</td>
<td>copies a selected object to the clipboard</td>
<td>4-11</td>
</tr>
<tr>
<td></td>
<td>Paste</td>
<td>pastes the most recently cut or copied object from the clipboard</td>
<td>4-11</td>
</tr>
<tr>
<td></td>
<td>Undo</td>
<td>undoes the previous action</td>
<td>4-12</td>
</tr>
<tr>
<td></td>
<td>Redo</td>
<td>redoes what was just undone</td>
<td>4-12</td>
</tr>
</tbody>
</table>

To “dock” toolbars:
1. Click anywhere on the toolbar (except on the buttons).
2. Drag it to the desired location in the schematic window or on your desktop.

The next time you open Schematics, the toolbars will be where you last placed them.

To display toolbars:
1. From the View menu, select Toolbars.
2. Select or clear the check box for each toolbar to enable or disable its display.
3. Click Close and the selected toolbars will display.
Table 2  Standard Schematics Toolbar

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Function</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Redraw</td>
<td>refreshes the active schematic</td>
<td>3-41</td>
</tr>
<tr>
<td></td>
<td></td>
<td>page screen display</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Zoom In</td>
<td>views a smaller area of schematic</td>
<td>3-68</td>
</tr>
<tr>
<td></td>
<td>Zoom Out</td>
<td>views a larger area of schematic</td>
<td>3-69</td>
</tr>
<tr>
<td></td>
<td>Zoom Area</td>
<td>views a selected area of schematic</td>
<td>3-68</td>
</tr>
<tr>
<td></td>
<td>Zoom to Fit Page</td>
<td>fits the view to show all items</td>
<td>3-70</td>
</tr>
<tr>
<td></td>
<td></td>
<td>on the page</td>
<td></td>
</tr>
</tbody>
</table>
Drawing

The Drawing toolbar provides shortcuts for drawing and editing items on your schematic.

Table 3  Drawing Toolbar

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Function</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Draw Wire</td>
<td>enables drawing of wires on the schematic</td>
<td>4-10</td>
</tr>
<tr>
<td></td>
<td>Draw Bus</td>
<td>enables the drawing of buses on the schematic</td>
<td>4-10</td>
</tr>
<tr>
<td></td>
<td>Draw Block</td>
<td>enables the placing of blocks on the schematic</td>
<td>7-22</td>
</tr>
<tr>
<td></td>
<td>Get New Part</td>
<td>displays Part Browser dialog box for selecting parts for placement</td>
<td>4-82</td>
</tr>
<tr>
<td></td>
<td>Get Recent Part</td>
<td>drop-down list box to select and place a recent part without having to open the part browser</td>
<td>4-85</td>
</tr>
<tr>
<td></td>
<td>Edit Attributes</td>
<td>edits the attributes of selected objects</td>
<td>4-93</td>
</tr>
<tr>
<td></td>
<td>Edit Symbol</td>
<td>opens the symbol editor for the selected symbol</td>
<td>5-15</td>
</tr>
</tbody>
</table>

Note  You can also type the name of the part directly into the text box.
Simulation

The Simulation toolbar provides shortcuts for setting up analyses, running a simulation, and viewing results.

Refer to the Viewing Results on the Schematic chapter of your PSpice A/D User’s Guide for further information on simulation in Schematics.

Table 4  Simulation Toolbar

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Function</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Analysis Setup</td>
<td>sets up simulation analyses for the active schematic</td>
<td>8-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>60</td>
</tr>
<tr>
<td></td>
<td>Simulation</td>
<td>starts a simulation of the current schematic</td>
<td>8-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>66</td>
</tr>
<tr>
<td></td>
<td>Marker Color</td>
<td>drop-down list box to change marker colors on an instance basis</td>
<td>*</td>
</tr>
<tr>
<td></td>
<td>Voltage/Level</td>
<td>enables placing of voltage/level markers on the schematic</td>
<td>*</td>
</tr>
<tr>
<td></td>
<td>Marker</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Current Marker</td>
<td>enables placing of current markers on the schematic</td>
<td>*</td>
</tr>
</tbody>
</table>
### Table 4  Simulation Toolbar

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Function</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Enable Bias Voltage Display</td>
<td>toggles the display of bias voltage</td>
<td>*</td>
</tr>
<tr>
<td></td>
<td>Show/Hide Voltage on Selected Net(s)</td>
<td>toggles the display of voltages for selected wires</td>
<td>*</td>
</tr>
<tr>
<td></td>
<td>Enable Bias Current Display</td>
<td>toggles the display of bias current</td>
<td>*</td>
</tr>
<tr>
<td></td>
<td>Show/Hide Currents on Selected Part(s)</td>
<td>toggles the display of currents for selected device pins</td>
<td>*</td>
</tr>
</tbody>
</table>

* Refer to the Viewing Results on the Schematic chapter in your PSpice user’s guide for information about how to use these toolbar buttons.
Annotation Graphics

The Annotation Graphics toolbar provides shortcuts for drawing or inserting non-electrical information onto your schematic.

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Function</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Draw Arc</td>
<td>draws an arc shape on the page</td>
<td>6-17</td>
</tr>
<tr>
<td></td>
<td>Draw Box</td>
<td>draws a box on the page</td>
<td>6-17</td>
</tr>
<tr>
<td></td>
<td>Draw Circle</td>
<td>draws a circle on the page</td>
<td>6-17</td>
</tr>
<tr>
<td></td>
<td>Draw Polyline</td>
<td>draws a polyline on the page</td>
<td>6-17</td>
</tr>
<tr>
<td></td>
<td>Draw Text</td>
<td>places of a single line of text on the page</td>
<td>4-12</td>
</tr>
<tr>
<td></td>
<td>Draw Text Box</td>
<td>places multiple lines of text on the schematic</td>
<td>4-12</td>
</tr>
<tr>
<td></td>
<td>Insert Picture</td>
<td>places a bitmap (.bmp, .dib) or Windows metafile (.wmf) on the page</td>
<td>4-13</td>
</tr>
</tbody>
</table>
Status Bar

The status bar is located at the bottom of the schematic editor window and provides the following:

- X and Y coordinates of the pointer.
  
  Use the Display Options selection under the Options menu to toggle display of X and Y coordinates.

- A message area that provides:
  
  - a brief description of the function that will be performed if you click the toolbar button at the present pointer location.
  
  - a brief description of the function to be performed. The description will display by selecting the menu item at the present pointer location.
  
  - prompts and warning messages that only appear when it is necessary for you to take a specific action.
    
    If anything must be done by the user or if there is a warning, the prompt will display in the status bar.

- the name of the function to be performed when you use the Repeat command (the name of the function will display when you use the Repeat function).

Use the Status Bar selection from the View menu to enable or disable the status bar.

Refreshing the Screen

To refresh the screen, click the Redraw button on the toolbar.

Keyboard

Table 6 lists the function keys in the schematic editor that permit you to enable or disable specific commands.
Table 6  Schematic Editor Function Keys

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
<th>Menu</th>
<th>Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Online Help</td>
<td>Help</td>
<td>Help</td>
</tr>
<tr>
<td>F2</td>
<td>Move to lower level in the schematic hierarchy</td>
<td>Navigate</td>
<td>Push</td>
</tr>
<tr>
<td>F3</td>
<td>Move up one level in the schematic hierarchy</td>
<td>Navigate</td>
<td>Pop</td>
</tr>
<tr>
<td>F4</td>
<td>Text stay-on-grid</td>
<td>Options</td>
<td>Display Options</td>
</tr>
<tr>
<td>F5</td>
<td>Orthogonal</td>
<td>Options</td>
<td>Display Options</td>
</tr>
<tr>
<td>F6</td>
<td>Stay-on-grid</td>
<td>Options</td>
<td>Display Options</td>
</tr>
<tr>
<td>F7</td>
<td>Auto-increment</td>
<td>Options</td>
<td>Auto-Naming</td>
</tr>
<tr>
<td>F8</td>
<td>Auto-repeat</td>
<td>Options</td>
<td>Auto-Repeat</td>
</tr>
<tr>
<td>F9</td>
<td>Rubberbanding</td>
<td>Options</td>
<td>Display Options</td>
</tr>
<tr>
<td>F10</td>
<td>View errors, warnings, and messages</td>
<td>File</td>
<td>View Messages</td>
</tr>
<tr>
<td>F11</td>
<td>Start the simulator</td>
<td>Analysis</td>
<td>Simulate</td>
</tr>
<tr>
<td>F12</td>
<td>Start MicroSim Probe</td>
<td>Analysis</td>
<td>Run Probe</td>
</tr>
</tbody>
</table>

Function keys [F4] through [F9] are toggle keys. Pressing the key enables the feature, and pressing [Shift] plus the key disables the feature.
Configuring PSpice Schematics

The following list summarizes the different types of options you can configure in PSpice Schematics. Customizing configurable options allows you to use PSpice Schematics in the way that best suits your needs and requirements.

**Library settings**
- changes the set of configured symbol libraries

**Page settings**
- sets the page size for your schematic
- specifies other page settings such as paper size, pin spacing, and borders

**Display options and preferences**
- changes the grid and gravity settings of the schematic editor
- sets the time interval between automatic saves of your schematics
- changes the font used for displaying and printing text on your schematics
- determines which elements of a schematic are to be displayed and printed
- changes the colors used for drawing and displaying objects

**Application settings**
- specifies the number of items in the Get Recent Part list box on the toolbar
- changes where to find the .exe files for programs that interface with PSpice Schematics and which initialization file to use other than the installed default initialization file (pspice.ini)
- specifies the use of a different text editor
Configuring Symbol Libraries

There are two major elements that work together in Schematics that let you place symbols into your design:

- symbol libraries
- library search list

Symbol libraries are located in library directories. The library search list is in the Part Browser and the Editor Configuration dialog box under the Options menu.

It is important to remember that libraries and the search list have two distinct functions. You can create a symbol library, but if the library name is *not* in the library search list, it is *not* available to the design for placing symbols. Conversely, you can inadvertently create an error condition by having a library name in the search list, for a library that doesn’t exist.

Configuring a symbol library is adding a library name to the library search list.

**Note** When adding a symbol library to the library search list, placement in the list is important. If more than one library contains the same symbol name, Schematics uses only the first one it encounters.

You must ensure the library actually exists in the location specified during the configuration procedure.

A library name must be in the library search list to be available for placing its symbols.
Types of Libraries

Schematics recognizes two types of libraries:

<table>
<thead>
<tr>
<th>This library...</th>
<th>Is available...</th>
</tr>
</thead>
<tbody>
<tr>
<td>global</td>
<td>to all schematic designs. They are listed in the <code>pspice.ini</code> file and are automatically loaded into the library search list for every design. Global libraries appear in the library search list with an asterisk (*) preceding the library name.</td>
</tr>
<tr>
<td>local</td>
<td>to designs within which they are saved. Schematics always places local library names at the top of the library search list. Local libraries are always searched first.</td>
</tr>
</tbody>
</table>

Default Library Directory

Schematics includes a default library directory where all the symbol libraries (.slb) you selected during installation reside. It is not required to configure these libraries. They are already configured in the search list as global libraries. However, if you prefer, you can:

- change the order in which libraries appear in the search list, thereby changing the order in which they are searched
- remove library names from the search list (without deleting the libraries)
- add new libraries
- delete libraries
- reconfigure libraries from global to local

Note: To maintain the integrity of your default symbols, we recommend making a copy of the default symbol libraries. If you use the symbol editor to make changes to a default symbol, it will overwrite the default symbol if you save using the default file name. Also, if you import symbol files into the default library and an imported file has the same name as the default file, the imported file will overwrite the default file.
User-Defined Symbol Libraries

You can create global and local symbol libraries, and add them to the default directory or to another directory of your choice. Once created, you can perform all the same actions as listed in Default Library Directory on page 3-43.

Note When adding a symbol library to the library search list, placement in the list is important. If more than one library contains the same symbol name, Schematics uses only the first one it encounters.

If you add local library names to the library search list, Schematics places them before global library names, because they are searched first. You can control their placement within a group of local library names, but you cannot integrate them into the global names.

Adding a library

1. From the Options menu, select Editor Configuration to display the Editor Configuration dialog box.

2. Click Library Settings to display the Library Settings dialog box.
3 In the list of libraries, select the location for the new library.

A new global library will be added directly above the library you select. A new local library will be placed above the first global library name in the list.

4 If the library you are adding is a symbol library, select the Symbol check box. If the library you are adding has an associated package library, select the Package check box.

5 In the Library Name text box, type the name of the library.

Do not type a file name extension if the library you are using is listed in the dialog box; the file name extension is appended automatically.

6 Click Add* for a global library, or click Add Local for a local library.

If you are adding a global library, Schematics writes the library name to the pspice.ini file so it is available to all schematic designs.

7 Click OK to exit the Library Settings dialog box.

8 In the Editor Configuration dialog box, click OK.
Removing Library Names

If you no longer need a library name in the list of configured libraries, you can remove it from the list of configured libraries.

Removing a library name

1. From the Options menu, select Editor Configuration to display the Editor Configuration dialog box (shown on 3-44).
2. Click Library Settings to display the Library Settings dialog box (shown on 3-45).
3. In the list of libraries, select the library name that you want to remove.
   The selected library name is displayed in the Library Name text box.
4. Click Delete.
5. Click OK to exit the Library Settings dialog box.
6. In the Editor Configuration dialog box, click OK.

Correcting Library Names

If you type a library name incorrectly, you can change the name as it appears in the list of configured libraries.

Correcting a library name

1. From the Options menu, select Editor Configuration to display the Editor Configuration dialog box (shown on 3-44).
2. Click Library Settings to display the Library Settings dialog box (shown on 3-45).
3. In the list of libraries, select the library that you want to change.
   The name of the selected library displays in the Library Name text box.
4. In the Library Name text box, type a new name for the library.
Do not type a file name extension; the file name extension is appended automatically.

5 Click Change.

6 Click OK to exit the Library Setting dialog box.

7 In the Editor Configuration dialog box, click OK.

**Changing the Search Order**

The way that PSpice Schematics searches libraries for a symbol follows the order in which the libraries are configured in the list. You can change the position of a library in the list.

**Changing the position of the library in the list**

1 From the Options menu, click Editor Configuration to display the Editor Configuration dialog box (shown on 3-44).

2 Click Library Settings to display the Library Settings dialog box (shown on 3-45).

3 In the list of libraries, select the library name that you want to move.

   The name of the selected library displays in the Library Name text box.

4 Click Delete.

5 In the list of libraries, select the name above which the repositioned name will be inserted.

6 In the Library Name text box, type the name of the library you want to reposition.

   Do not type a file name extension; the file name extension is appended automatically.

7 If the library is a symbol library, select the Symbol check box. If the library has an associated package library, select the Package check box.

8 Click Add* for a global library or click Add Local for a local library.
The repositioned library name is inserted above the selected name.

9  Click OK to exit the Library Setting dialog box.

10 In the Editor Configuration dialog box, click OK.

**Changing the Search Path**

PSpice Schematics looks for a library according to the path(s) specified by the Library Path in the Editor Configuration dialog box.

**Changing the library search path**

1  From the Options menu, select Editor Configuration to display the Editor Configuration dialog box.

```
```

2  Type a new path or add to the existing path in the Library Path text box.

Specify multiple directories by separating them with a semicolon:

c:\msim\lib

3  Click OK.
Changing Page Size

PSpice Schematics supports standard page sizes A through E and A0 through A4. It also allows you to specify a user defined page size.

Changing the page size

1. From the Options menu, click Page Size to display the Page Size dialog box.

   ![Page Size dialog box]

   - From the Options menu, click Page Size to display the Page Size dialog box.

2. Click the appropriate button to select a pre-defined page size, or indicate a User Defined Size by typing the page dimensions in the Horiz: and Vert: text boxes.

3. Click OK to change the page size of the currently active page and to establish the default page size for all later pages.
Changing Page Settings

For all page sizes, you can change the border style, the drawing area, and the pin-to-pin spacing.

Border Style

Schematics provides two border styles: zoned and outline. Figure 3 illustrates the two styles.

Note  If you are using zoned borders, make sure the Display check box for the Page Boundary layer in the Display Preferences dialog box is enabled (see Controlling the Display in PSpice Schematics on page 3-60).

Note  Drawing areas for the zoned and outline border types are the same size, as shown in Figure 3.

Figure 3  Border Styles

You can configure a zoned border for all decimal and metric page sizes, including custom sizes (see Changing the border style on page 3-52.)

The following table lists the default decimal page sizes and their configurations.
The following table lists the default metric page sizes and their configurations.

**Table 7  Zoned Border Default Decimal Parameters**

<table>
<thead>
<tr>
<th>Type</th>
<th>Dimension*</th>
<th>Vertical Zones</th>
<th>Vertical Margin</th>
<th>Horizontal Zones</th>
<th>Horizontal Margin</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>8.5 x 11</td>
<td>2</td>
<td>.25</td>
<td>2</td>
<td>.38</td>
</tr>
<tr>
<td>B</td>
<td>11 x 17</td>
<td>2</td>
<td>.62</td>
<td>4</td>
<td>.38</td>
</tr>
<tr>
<td>C</td>
<td>17 x 22</td>
<td>4</td>
<td>.5</td>
<td>4</td>
<td>.75</td>
</tr>
<tr>
<td>D</td>
<td>22 x 34</td>
<td>4</td>
<td>1.0</td>
<td>8</td>
<td>.5</td>
</tr>
<tr>
<td>E</td>
<td>34 x 44</td>
<td>8</td>
<td>.5</td>
<td>8</td>
<td>1.0</td>
</tr>
</tbody>
</table>

* in inches

**Table 8  Zoned Border Default Metric Parameters**

<table>
<thead>
<tr>
<th>Type</th>
<th>Dimension*</th>
<th>Vertical Zones</th>
<th>Vertical Margin</th>
<th>Horizontal Zones</th>
<th>Horizontal Margin</th>
</tr>
</thead>
<tbody>
<tr>
<td>A4</td>
<td>210 x 297</td>
<td>2</td>
<td>6.35</td>
<td>2</td>
<td>9.65</td>
</tr>
<tr>
<td>A3</td>
<td>297 x 420</td>
<td>2</td>
<td>15.75</td>
<td>4</td>
<td>9.65</td>
</tr>
<tr>
<td>A2</td>
<td>420 x 594</td>
<td>4</td>
<td>12.7</td>
<td>4</td>
<td>19.5</td>
</tr>
<tr>
<td>A1</td>
<td>594 x 841</td>
<td>4</td>
<td>25.4</td>
<td>8</td>
<td>12.7</td>
</tr>
<tr>
<td>A0</td>
<td>841 x 1189</td>
<td>8</td>
<td>12.7</td>
<td>8</td>
<td>25.4</td>
</tr>
</tbody>
</table>

* in millimeters

**Note**  If your design doesn’t require a zoned border, Outline Border will display the page with fewer details.
**Chapter 3    Using the Schematic Editor**

**Changing the border style**

You can specify which border style to use through the Editor Configuration dialog box. The current drawing and all subsequent new drawings use the style you select.

1. From the Options menu, select Editor Configuration to display the Editor Configuration dialog box.

2. Click Page Settings to display the Page Settings dialog box.

3. Select the page size for which you want to set the border style.

You can select either style for each page size.
4 Select the Outline or Zoned border style.

<table>
<thead>
<tr>
<th>For style...</th>
<th>Do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outline</td>
<td><strong>1</strong> In the Borders frame, click the Outline button. <strong>2</strong> Click OK to accept the Outline border and exit the Page Settings dialog box.</td>
</tr>
<tr>
<td>Zoned</td>
<td><strong>1</strong> In the Borders frame, click the Zoned button. <strong>2</strong> Type the number of zones for each axis. <strong>3</strong> Type the margin sizes for each axis. <strong>4</strong> Select letters or numbers for zone designators in each plane. <strong>5</strong> Select Ascending or Descending (in reference to the upper-left corner of the page), in each plane. <strong>6</strong> Click OK to accept the Zoned border and exit the Page Settings dialog box.</td>
</tr>
</tbody>
</table>

**Note** Line widths for the page boundary are specified in the Display Preferences dialog box. See [Setting the default graphics properties through Display Preferences on page 4-132](#) for more information.
Drawing Area

Changing the drawing area size

1. From the Options menu, select Editor Configuration to display the Editor Configuration dialog box (shown on 3-52).
2. Click Page Settings to display the Page Settings dialog box.
3. In the Width and Height text boxes, type the drawing area dimensions for the page size.
4. Click OK to exit the Page Settings dialog box.
5. In the Editor Configuration dialog box, click OK.

Note: Drawing areas for zoned and outline border types are the same size, (see Figure 3 on page 3-50).
**Pin-to-Pin Spacing**

You can scale symbols so they will appear larger or smaller on the schematic. You do this by changing the pin-to-pin spacing for a given page size.

**Changing the pin-to-pin spacing**

1. From the Options menu, select Editor Configuration to display the Editor Configuration dialog box (shown on 3-52).
2. Click Page Settings to display the Page Settings dialog box (shown on 3-54).
3. In the Pin-to-Pin Spacing text box, type a new value.
4. Click OK.

**Changing Grid and Gravity**

The grid and gravity functions of PSpice Schematics ease your drawing tasks and can help make your schematic more precise.

**Grid On**

When Grid On is enabled, the grid is displayed in the drawing area of the schematic editor window.

**Enabling or disabling the grid display**

1. From the Options menu, select Display Options.
2. Select or clear the Grid On check box to enable or disable the grid display.
3. Click OK.
Stay-on-Grid

Stay-on-grid controls the method of object placement. When Stay-on-Grid is enabled, the objects are forced onto grid when placed. We recommend that you enable this so that electrical connections are made correctly.

Enabling or disabling stay-on-grid

1. From the Options menu, select Display Options.
2. Select or clear the Stay-on-Grid check box to enable or disable Stay-on-Grid.
3. Click OK.

Snap-to-Grid

Snap-to-grid controls the movement of the object while being moved for placement when Stay-on-Grid is enabled. If Snap-to-Grid and Stay-on-Grid are both enabled, movement during object placement is in increments equal to the current grid spacing. If Snap-to-Grid is not selected, the object moves smoothly.

Enabling or disabling snap-to-grid

1. From the Options menu, select Display Options.
2. Select or clear the Snap-to-Grid check box to enable or disable snap-to-grid.
3. Click OK.

Note: The Stay-on-Grid command must be enabled for the Snap-to-Grid command to be effective.
Snap-to-Pin
Snap-to-pin, when enabled, causes the endpoint of a wire or bus segment to snap to the nearest pin if one is found inside the radius defined by the Gravity setting.

Enabling or disabling snap-to-pin
1. From the Options menu, select Display Options.
2. Select or clear the Snap-to-Pin check box to enable or disable snap-to-pin.
3. Click OK.

Grid Spacing
Grid Spacing defines the horizontal and vertical grid spacing on your drawing area. The default spacing is 10 units. This corresponds to (and displays as) 0.10 inches for US-standard page sizes, and 2.5 millimeters for metric page sizes. The minimum grid spacing allowed is 0.01 inch, or .25 millimeters.

Specifying grid spacing
1. From the Options menu, select Display Options.
2. In the Grid Spacing frame, type the grid spacing value.
3. Click OK.

Gravity
The gravity setting specifies how close an object must be to a pin to snap to it. Gravity is only functional when snap-to-pin is enabled.

Specifying gravity
1. From the Options menu, select Display Options.
2. In the Snap-to-Pin frame, type the snap-to-pin gravity value.
3. Click OK.
**Text Grid**

Text Grid allows you to set the grid spacing for text separately from the drawing grid spacing. The text grid is usually set to some smaller percentage of the drawing grid. This allows you to align text between drawing grid points.

**Enabling text grid and specifying text grid size**

1. From the Options menu, select Display Options.
2. In the Text Grid frame, select the Stay-on-Grid check box to enable the text grid.
3. In the Grid Size text box, type the text grid spacing value.
4. Click OK.

**Setting the Autosave Interval**

The autosave interval specifies the time interval, in minutes, which PSpice Schematics automatically saves any modified schematics or libraries.

**Setting the Autosave interval**

1. From the Options menu, select Editor Configuration to display the Editor Configuration dialog box.
2. In the Autosave interval box, type the number of minutes for the autosave interval.
3. Click OK.
When Autosave is enabled, PSpice Schematics creates a temporary file with the same name as the active working file, and a file name extension ending in ‘v’ (for example, “.scv,” “.slv,” “.plv”). If you have a power outage or system failure, you can retrieve your work from these files.

The temporary files are deleted each time a schematic or library is successfully closed or saved. When you open a file, PSpice Schematics compares the saved file to the autosave file, if one is present. If the autosave file is more recent than the requested file, PSpice Schematics provides a warning and allows you to restore the file as the active schematic or library.

While an autosave is in progress, a message appears in the status line and the hourglass symbol displays in place of the pointer. Wait until the autosave is finished before continuing.

**Disabling Autosave**

1. From the Options menu, select Editor Configuration to display the Editor Configuration dialog box (shown on 3-48).
2. In the Autosave interval text box, type 0 (zero).
3. Click OK.
Controlling the Display in PSpice Schematics

PSpice Schematics allows you to define what elements of a design you want to display and print. This means you can set different display properties for each element of your schematic. In the Display Preferences dialog box, the default colors, styles, fonts, and sizes of each display layer are established.

You can either display or not display (and print or not print) the following:

<table>
<thead>
<tr>
<th>Annotation Graphics</th>
<th>Attribute Text</th>
<th>Buses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hidden Pins</td>
<td>Junctions</td>
<td>Labels</td>
</tr>
<tr>
<td>Markers and Viewpoints</td>
<td>Page Boundary</td>
<td>Part Names</td>
</tr>
<tr>
<td>Pin Names</td>
<td>Pin Numbers</td>
<td>Ports</td>
</tr>
<tr>
<td>Reference Designators</td>
<td>Simulation Currents</td>
<td>Simulation Voltages</td>
</tr>
<tr>
<td>Stimulus</td>
<td>Symbol Text</td>
<td>Symbols</td>
</tr>
<tr>
<td>Text</td>
<td>Text Box</td>
<td>Title and Border</td>
</tr>
<tr>
<td>User-specified text</td>
<td>Wires</td>
<td></td>
</tr>
</tbody>
</table>
Displaying or printing default properties

1. From the Options menu, select Display Preferences to display the Display Preferences dialog box.

2. From the Display Layers list, select the appropriate display layer (or layers).

3. Click the General tab.

4. Select or clear the Display check box to enable or disable display of the selected layers.

5. Select or clear the Print check box to enable or disable printing of the selected layers.

6. Click Apply to apply the changes and keep the dialog box displayed for further changes, or click OK to apply the changes and close the dialog box.

Options Menu

To select more than one layer consecutively:

1. Hold down \(\text{Shift}\).

2. Click the first desired layer in the list and the last.

Every layer in between will be selected.

To select more than one layer non-consecutively:

1. Hold down \(\text{Ctrl}\).

2. Click each desired layer.
Changing Fonts

To change the default fonts PSpice Schematics uses to display and print text, use the Display Preferences dialog box.

Selecting a font

1. From the Options menu, select Display Preferences to display the Display Preferences dialog box.

2. Select one or more layers from the Display Layers list.

3. Click the Text tab.

4. Click Browse to display the Font dialog box.

If you are rotating text objects, use TrueType fonts to prevent the display from becoming distorted.
5 Select a font and size from their corresponding list boxes and click OK.

A sample of the selected font is shown in the Sample box.

6 Enter a size in either inches or millimeters, or accept the system default for the selected font.

7 Select a color from the Color list box.

8 Click Apply to apply the changes and keep the dialog box displayed for further changes, or click OK to apply the changes and close the dialog box.

Configuring Colors

The colors for all layers in Schematics are configured in the Display Preferences dialog box. The colors you specify become the defaults, however, they may be changed as often as necessary.

Configuring Colors in your Schematic

1 From the Options menu, select Display Preferences to display the Display Preferences dialog box (shown on page 3-62).

2 Select one or more layers from the Display Layers list.

3 Click the tab that applies to the layers you have selected.

For example, if you want to change a text color, select the layer, click the Text tab, and select the appropriate display settings.

4 Select a color from the Color drop-down list.

5 Click Apply to apply the changes and keep the dialog box open for further changes, or click OK to apply the changes and close the dialog box.
Changing Application Settings

You have the option to change the location of the .exe files of the programs that Schematics interfaces with. You can also configure a different text editor (besides WordPad) and specify an initialization file other than the installed default initialization file.

Changing where to find programs

1. From the Options menu, select Editor Configuration to display the Editor Configuration dialog box.

2. Click App Settings to display the App Settings dialog box.
Controlling the Display in PSpice Schematics

The Simulate Command frame shows the path that PSpice Schematics uses to run MicroSim PSpice A/D.

3 To change the path name, type a new path name in the Command text box.

4 Similarly, to change any of the other command lines, click to select the command in the Other Commands list box and type a new path name in the Command text box.

5 Click OK to exit the App Settings dialog box.

6 In the Editor Configuration dialog box, click OK.

Changing the configuration file

A configuration file other than the default pspice.ini file can be used for any of the programs that Schematics interfaces with.

1 From the Options menu, select Editor Configuration to display the Editor Configuration dialog box (shown on 3-65).

2 Click App Settings to display the App Settings dialog box (shown on 3-65).

3 In the Configuration File frame, select Other.

Note The Simulate Command frame will show either PSpice or PSpice A/D, depending on the package that you have purchased. If you are using a network licensed version that has both PSpice and PSpice A/D available, you can choose which simulator you want to use.
4 Type the file name of the configuration file in the text box.
5 Click OK to exit the App Setting dialog box.
6 In the Editor Configuration dialog box, click OK.

**Specifying a different text editor**

Editing text in PSpice Schematics is done through the WordPad program. You have the option to specify a different text editor.

1 From the Options menu, select Editor Configuration to display the Editor Configuration dialog box (shown on 3-65).
2 Click App Settings to display the App Settings dialog box (shown on 3-65).
3 In the Other Commands box, select Text Editor.
4 Type a new path name in the Command text box to specify the path and name of the text editor you want to use.
5 Click OK to exit the App Settings dialog box.
6 In the Editor Configuration dialog box, click OK.
Changing the Get Recent Part List Size

The Get Recent Part list box on the toolbar contains a scroll-down list of recently placed parts. The default length of this list is ten items.

To change the length of the list, use a text editor to edit the MRPLISTSIZE item in the [SCHEMATICS] section of the pspice.ini file.

MRPLISTSIZE=<length of list>
Zooming and Panning in Schematics

Zooming

When working on a design, you can zoom in (enlarge the view) or zoom out (reduce the view) to view a larger or smaller portion of the schematic window. Zooming in reduces the area viewed and enlarges the objects viewed. Zooming out increases the area viewed and reduces the size of the objects viewed.

Zooming in

1. From the View menu, select In.
2. Move the pointer to the desired center of the zoom action and click.

Zooming in about the center of the window

1. Click the Zoom In button.
   The amount of magnification is determined by the Zoom Scale Factor (see Setting Zoom Parameters on page 3-69).

Zooming in on a selected area of the page

1. Click the Zoom Area button, or select Area from the View menu.
2. Drag a selection rectangle to select the desired display area.

Zooming out

1. From the View menu, select Out.
2. Move the pointer to the desired center of the zoom action and click.
Zooming out about the center of the window

1. Click the Zoom Out button.

   The amount of reduction is determined by the Zoom Scale Factor (see Setting Zoom Parameters on page 3-69).

Zooming out to view the full schematic page

1. From the View menu, select Entire Page.

Setting Zoom Parameters

Setting scale factor and fit

The Zoom parameters tailor how the work space will be magnified or reduced when you make selections from the View menu, or click any of the zoom buttons.

1. From the Options menu, select Pan & Zoom to display the Pan & Zoom dialog box.

2. In the Scale Factor text box, type a value.

   This value defines the factor by which the screen is magnified or reduced when you select Zoom In or Zoom Out. A Scale Factor of 2 will double (or halve) the size of objects viewed.

3. In the Fit text box, type a value.
This value defines the percentage of the work space to be filled with the complete schematic when you select View Fit. Type a decimal value between 50 and 100. A typical value is 90.

4 Click OK.

**Fitting to a Page**

All of the parts, wires and text within the active window (excluding the title block) are displayed by fitting the view to the page.

**Fitting the view to the page**

1 Click the Zoom to Fit Page button, or select Fit from the View menu.

**Panning**

Panning allows you to select a new window centering point. The current zoom scale remains the same. When you select the new center point, the schematic is panned until the selected point is in the center of the window.

**Panning to a new center**

1 From the View menu, select Pan—New Center.

2 Move the pointer to the desired window center and click.
Automatic Panning

If Auto Pan is enabled, the pointer turns to a solid black arrow when you move it to the edge of the window. If you leave the arrow at the edge of the window for a few moments, the view pans in the direction of the arrow. You can pan up, down, left, and right using this method.

Enabling Automatic Panning

1. From the Options menu, select Pan & Zoom to display the Pan & Zoom dialog box.

2. In the Auto Pan frame, select the Enable check box.

3. Click OK.

Setting hot zone size

The Hot Zone Size determines the width of the zone where the pointer has to rest to trigger the Auto Pan function.

1. From the Options menu, click Pan & Zoom to display the Pan & Zoom dialog box.

2. In the Hot Zone Size text box, type a value.

Values must be in the range from 1 to 10. If the value is set to 1 (default value), the hot zone is 1% of the dimensions of the screen.

3. Click OK.

When panning, click the right mouse button to pan immediately, rather than waiting for the pan time to elapse.
**Setting Auto Pan sensitivity**

The Auto Pan sensitivity setting determines how long the pointer must remain on the window border before the panning takes place.

1. From the Options menu, click Pan & Zoom to display the Pan & Zoom dialog box (shown on page 3-71).

2. In the Auto Pan frame, type a value in the Sensitivity text box.

   The value in the text box is the time delay in milliseconds. The default is 1000 milliseconds.

3. Click OK.

**Setting Pan Coarse Delta and Fine Delta**

The Pan parameters determine the degree of movement of the work space when you use the scroll bars.

1. From the Options menu, click Pan & Zoom to display the Pan & Zoom dialog box (shown on page 3-71).

2. In the Coarse Delta text box, type a value.

   The value in the text box is the degree of movement of the design when you click in a scroll bar on either side of the slider. The value must be between 1 and 50 and represents a percentage of the visible work space.

3. In the Fine Delta text box, type a value.

   Fine Delta defines the percentage of movement of the design when you pan by clicking on one of the scroll bar arrows. The value must be between 1 and 5 and represents a percentage of the visible work space.

4. Click OK.
Using the Message Viewer

The Message Viewer displays text describing a condition, status or other information concerning the operation of PSpice Schematics.

The Message Viewer appears when any condition generates a message that requires you to be informed. For example, warnings and error messages that occur during netlisting will appear in the Message Viewer.

If you have more than one design open and close one of the open designs, the messages pertaining to the design you close no longer display. When you close the last design, the Message Viewer closes. Also, the message viewer closes whenever Schematics is closed or when you explicitly close it.
Another way to view online Help is:
1. Right-click in the message area to display a menu.
   - Help On...
   - Find In Design...
   - Additional Info...
2. Click Help On to view a context-sensitive Help message.

Another way to locate the message source:
1. Right-click the message line to display a menu.
   - Help On...
   - Find In Design...
   - Additional Info...
2. Click Find In Design.

Online Help

The Message Viewer has an online Help feature that allows you to view a help message directly relating to the currently selected message.

To view a context-sensitive Help message:
1. In the message viewer window, select the message.
2. Press [F1].

Locating the Source of a Message

Many messages displayed in the Message Viewer contain a hypertext link that points to the source of the message. This allows you to go to the location in the design that caused the message to be generated.

To locate the source of a message, double-click the message in the Message Viewer window.

Indicated Severity

Each message is preceded by a marker. The color of the marker indicates the severity of the message.
Table 1:

<table>
<thead>
<tr>
<th>Color</th>
<th>Indication</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue</td>
<td>Informational message. No user action is required.</td>
</tr>
<tr>
<td>Yellow</td>
<td>Warning message. May require some user action.</td>
</tr>
<tr>
<td>Red</td>
<td>Error message. Must be corrected before continuing.</td>
</tr>
<tr>
<td>Black</td>
<td>Fatal error message. Indicates a non-recoverable error condition.</td>
</tr>
</tbody>
</table>
Additional Information

Some messages contain additional text. That is, the message contains several lines of information while only one line displays. Lines containing additional information are indicated by a plus sign in the severity marker preceding the message text.

When the Message Viewer contains any messages with additional information, the More Info button on the toolbar is active.

1. Click either the plus sign in the line of text or the More Info button to display the Additional Info dialog box.

Another way to view additional information:

1. Right-click the message line to display a menu.
2. Click Additional Info to display the Additional Info dialog box.

2. Click OK to dismiss the dialog box.

Closing the Message Viewer

To close the Message Viewer, do one of the following:

- From the File menu, select Exit.
- In the upper right corner of the window, click the Close button.
Creating and Editing Designs

Overview

This chapter contains the step-by-step procedures for creating, editing, and printing a schematic, which includes:

Starting the Schematic Editor on page 4-79 describes how to start the schematic editor and how to open a new or existing file.

Finding Parts on page 4-80 describes how to find parts by name or description, and by searching the symbol libraries.

Placing and Editing Parts on page 4-85 describes the detailed steps for placing parts, changing the orientation of parts prior to placing them, editing part attributes, placing multiple instances of a part, and automatically assigning reference designators.

Placing Power and Ground Symbols on page 4-102 describes how to place and edit power and ground symbols.
Using Wires and Buses on page 4-104 describes drawing and labeling wires and buses, in addition to describing the drawing options that affect the placement of wires and buses.

Using Ports on page 4-114 describes the use of off-page and global ports.

Selecting and Moving Objects and Attributes on page 4-116 describes how to select and move parts, wires, and attributes.

Creating and Editing Title Blocks on page 4-122 describes how to create and edit the title block on your schematic.

Adding Non-Electrical Information on page 4-126 describes how to create and edit annotation items (non-electrical information).

Creating and Editing Multi-sheet Designs on page 4-136 describes how to create and edit multi-sheet designs.

Printing Your Design on page 4-140 describes how to print your design.

Closing the Schematic Editor on page 4-146 describes how to save a schematic and how to close the schematic editor.
Starting the Schematic Editor

Start the schematic editor by double-clicking on the Schematics icon in the Orcad program group. An empty schematic page appears.

If you already have Schematics running with another schematic open, click the New File button to start a new schematic.

Opening a File

To open a new file, click the New File button. An empty schematic page appears.

To open an existing file and display the schematic for editing, click the Open File button. Previously opened schematics remain open until closed.

To close files or to close the schematic editor, see Closing the Schematic Editor on page 4-146.
Finding Parts

Parts represent electrical devices such as resistors, operational amplifiers, diodes, voltage sources, and digital gates that comprise the circuit diagram.

The graphical representation of a part is a symbol stored in a symbol library.

For those parts with a simulation model available, the model definition is stored in a model library.

For parts applicable to PCB layout, the package definition is stored in the package library.

You can use symbols supplied with PSpice Schematics, or you can create your own symbols and store them in user-defined symbol libraries. You can select a symbol from a library by name or by browsing the list of available parts.

The available parts are only those contained in configured libraries. If you have a library of parts and they are not available, you need to add the library to the list of configured libraries. Refer to Configuring Symbol Libraries on page 3-42.

Simulation Checklist

When you are drawing a design for simulation, keep the following in mind:

- The symbols that you place must have corresponding simulation models associated with them.
- The design will need sources of stimulus.
- For any part that has an associated simulation model, unmodeled pins are indicated by a broken pin.
Getting Parts by Name

The Get Recent Part list box on the toolbar provides a list of the most recently used parts. You can also type a name in the Get Recent Part list box to select a part.

Selecting a part by name

1. In the Get Recent Part list box, type the name of the part you want to place.
2. Press Enter.
3. Move the outline of the selected symbol to any location on the schematic and click to place the part.
4. Right-click to stop placing parts.

Placing a previously selected part

After you select a part for placement, the part name is listed in the Get Recent Part list on the toolbar and can easily be recalled.

1. Click the Get Recent Part list arrow.
   A scrollable list appears containing the names of the last ten parts that have been placed.
2. Click the name of the part you want to place.
3. Move the outline of the selected symbol to any location on the schematic and click to place the part.
4. Right-click to stop placing parts.
Chapter 4 Creating and Editing Designs

Searching for Parts in the Libraries

Symbol libraries contain symbols for many parts. There are three methods for selecting parts from libraries:

- Search for the part by name.
- Search for the part by description.
- Browse through the symbol libraries.

Each of these methods are described below.

Selecting a part by name

1. From the Draw menu, select Get New Part to display one of the Part Browser dialog boxes.

2. Type the name of the part in the Part Name text box, or select the part name from the list of available parts at the left side of the dialog box.

3. Click Place to place the part (with the browser remaining open) or click Place & Close (to place the part and close the browser).

Note: One of two Part Browser dialog boxes may appear: the Part Browser Advanced or the Part Browser Basic. If the Part Browser Basic dialog box appears, click Advanced to display the Part Browser Advanced dialog box. If the Part Browser Advanced dialog box appears, click Basic to display the Part Browser Basic dialog box. The steps to find a part by name are the same in either dialog box.

When typing a part name or a description, you can use the "*" and "?" wildcard characters.

An "*" is a wildcard that matches zero or more characters. For example, 74LS1* matches 74LS10, 74LS107A, and 74LS197.

A "?" is a wildcard that matches any single character. For example, 74LS1? matches 74LS10 but not 74LS107A.
4 Move the outline of the selected symbol to any location on the schematic and click to place the part.

5 Right-click to stop placing parts.

Selecting a part by description

1 Click the Get New Part button to display the Part Browser dialog box (see 4-82).

Note You may display one of two Part Browser dialog boxes: the Part Browser Advanced or the Part Browser Basic. If the Part Browser Basic dialog box appears, click Advanced to display the Part Browser Advanced dialog box. You can only use the Part Browser Advanced dialog box to search for a part by description.

2 In the Description Search text box, type a description of the part.

3 Click the arrow and select one of the options in the list:
   • Create New Part List—creates a new (sub)list of parts in the parts list.
   • Add to Part List—adds to the set of parts.
   • Search within Part List—restricts the search to the (partial) list of parts.

4 Click Search.

The number of items found in the search is shown beneath the parts list.

The search function searches all configured symbol libraries for parts whose descriptions match the description entered. When the search is complete, all parts with matching descriptions are shown in the partial list at the left of the dialog box.

5 Select the part from the parts list.

Preview a part symbol by clicking the part name in the parts list.

6 Click Place to place the part (with the browser remaining open), or click Place & Close (to place the part and close the browser).
Chapter 4  Creating and Editing Designs

7 Move the outline of the selected symbol to any location on the schematic and click to place the part.

8 Right-click to stop placing parts.

**Browsing symbol libraries to select a part**

1 Click the Get New Part button to display the Part Browser dialog box (see 4-82).

**Note**  One of two Part Browser dialog boxes may appear: the Part Browser Advanced and the Part Browser Basic. If the Part Browser Basic dialog box appears, click Advanced to display the Part Browser Advanced dialog box. If the Part Browser Advanced dialog box appears, click Basic to display the Part Browser Basic dialog box. The steps in finding a part by browsing symbol libraries are the same with either dialog box.

2 Click Libraries to display the Library Browser dialog box (see 3-45).

Use the Library Browser dialog box to select a library and view a list of parts contained in each library.

When you select a part, the part name appears in the Part Name text box in the Part Browser dialog box and the part is selected for placing.

3 Click OK.

4 Click Place to place the part (with the browser remaining open) or click Place & Close (to place the part and close the browser).

**Note**  Appendix E, Symbol Libraries, contains a list of symbol libraries supplied with PSpice Schematics and device types.

5 Move the outline of the selected symbol to any location on the schematic and click to place the part.

6 Right-click to stop placing parts.
Placing and Editing Parts

After you have selected a part, you can place one or more instances of the part on the schematic. When the part is selected, an outline of the selected part appears attached to the pointer.

Placing a symbol on the schematic

1. Click the Get New Part button to select the part from a symbol library.
2. Move the symbol outline to the location you want to place the symbol and click.

   Place as many instances of the symbol as you want by moving to another location and clicking again. Each time you point and click, another instance of the part is placed on the page.

Stopping placement

To stop placing a symbol, do one of the following:

- Double-click to place the last instance of the symbol.
- Right-click to stop placing the symbol without placing an additional symbol.

The outline changes back to a pointer.

If you type C in the Part Name text box to select a capacitor, you will see an outline of the capacitor symbol attached to the pointer (as shown below).

See also Repeating Part Placements on page 4-95 and Global Editing of Attributes on page 4-93.
Rotating and Flipping Parts

In PSpice Schematics, you can rotate and flip (mirror) parts or entire areas of a schematic. A rotated part is rotated 90° counter-clockwise. A flipped part is mirrored about the Y axis.

Rotating and flipping can occur during one of the following:

- while dragging (before placement)
- after placement

Rotating Parts

Rotating a part before placing it

1. Select a part to be placed.
2. Press \( \text{Ctrl} + R \) to rotate it while still in the drag mode.

   The image rotates 90° counter-clockwise. Each time you press \( \text{Ctrl} + R \), the image will rotate 90° counter-clockwise.

Rotating an already placed part

1. Select the part.
2. Press \( \text{Ctrl} + R \) to rotate it 90° counter-clockwise.

Rotating an area of the schematic

1. Drag the pointer to select and outline the area to be rotated.
2. Press \( \text{Ctrl} + R \) to rotate the area.

   The selected area rotates 90° counter-clockwise about the center point of the selected area.
Flipping Parts

Flipping a part before placing it

1. Select the part to be placed.
2. Press Ctrl+F to flip it.
   The symbol outline is a mirror image of the original image. Each time you press Ctrl+F, the image will flip about the vertical axis.

Flipping an already placed part

1. Select the part.
2. Press Ctrl+F to flip it.

Flipping an area of the schematic

1. Drag the mouse to select and outline the area to be flipped.
2. Press Ctrl+F to flip the area about its vertical axis.
Chapter 4  Creating and Editing Designs

Editing Part Attributes

Parts, ports, wires (nets), buses and most other symbols have associated attributes. An attribute consists of a name and an associated value. (See Attributes on page 3-30.)

You can create new attributes or edit existing attributes of a part on the schematic. These functions are performed in the Attribute Editing dialog box.

Editing Attributes

Editing an attribute

1. Double-click the part to display the Attribute Editing dialog box.

2. In the list of attributes and values, select the attribute to be edited.

   The attribute name appears in the Name text box and the current value in the Value text box.

3. Edit the value in the Value text box.

4. Click Save Attr.

5. Click OK.

An attribute with an asterisk (*) next to it indicates that the attribute cannot be changed or deleted in the schematic editor because the attribute was made an intrinsic property when the symbol was created. These attributes can only be modified in the symbol editor.

Note: You can quickly change the value of a displayed attribute, such as a resistor value, by double-clicking it.

Note: If you double-click when selecting the attribute, the pointer is placed on the current value in the Value text box.
The letter a indicates that the attribute has been annotated as a result of back annotation or has been assigned by the packager.

Any changes you make to the part attributes are made to the individual part instance you selected. The original part contained in the symbol library remains unchanged.

Attribute names can contain any alphanumeric characters (A–Z, 0–9) and the underscore character. Attributes cannot be self-referencing.

The two check boxes at the bottom of the Edit Attribute dialog box enable you to control whether or not non-changeable or system defined attributes are included in the display.

System defined attributes have reserved attribute names. PSpice Schematics uses these attributes for specific purposes, primarily during netlisting and packaging. See Appendix D, Attribute List for a complete list and explanations of attributes. System defined attributes are as follows:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Attribute</th>
</tr>
</thead>
<tbody>
<tr>
<td>BIASVALUE</td>
<td>PAGESIZE</td>
</tr>
<tr>
<td>COMPONENT</td>
<td>PAGETITLE</td>
</tr>
<tr>
<td>COLOR</td>
<td>PART</td>
</tr>
<tr>
<td>ERC</td>
<td>PKGREF</td>
</tr>
<tr>
<td>FAMILY</td>
<td>PKGTYPE</td>
</tr>
<tr>
<td>FLOAT</td>
<td>PLMODEL</td>
</tr>
<tr>
<td>GATE</td>
<td>PROBEVAR</td>
</tr>
<tr>
<td>GATETYPE</td>
<td>REFDES</td>
</tr>
<tr>
<td>IMPL</td>
<td>SIMULATIONONLY</td>
</tr>
<tr>
<td>LABEL</td>
<td>SOURCE</td>
</tr>
<tr>
<td>MARKERTYPE</td>
<td>STIMTYPE</td>
</tr>
<tr>
<td>MODEL</td>
<td>STIMULUS</td>
</tr>
<tr>
<td>NODE</td>
<td>SWAP</td>
</tr>
<tr>
<td>PAGECOUNT</td>
<td>TAG</td>
</tr>
<tr>
<td>PAGENO</td>
<td>TEMPLATE</td>
</tr>
</tbody>
</table>
Adding Attributes

Adding a new attribute

1. Double-click the part to display the Attribute Editing dialog box (see 4-88).
2. Double-click in the Name text box and type the new attribute name.
3. Press $F$ and type the new attribute value in the Value text box.
4. Click Save Attr.
5. Click OK.

The new attribute and its value apply only to the part instance you are editing on the current schematic. The attribute and value are saved only with the schematic; they are not saved in the symbol library.

Deleting Attributes

Deleting an attribute

1. Double-click the part to display the Attribute Editing dialog box (see 4-88).
2. Select the attribute to delete.
3. Click Delete.
4. Click OK.

Note You cannot delete non-changeable or system-defined attributes.

Changing the Display of Attributes

You can change how specific attributes appear on the schematic.

Displaying attributes

1. Double-click the part to display the Attribute Editing dialog box (see 4-88).
2. Select the attribute whose display you want to enable (or disable).

Note You cannot change the display of non-changeable attributes.
Placing and Editing Parts

3 Click Change Display to display the Change Attribute dialog box.

![Change Attribute dialog box]

4 Select one of the option buttons in the What to Display frame.
   
   With many attributes such as the package reference and reference designator, only the value displays. With others, such as package type, neither the name nor the value displays.

5 Click OK to close the Change Attribute dialog box.

6 In the Attribute Editing dialog box, click OK.

Changing other display characteristics of the attributes of a part instance

1 Double-click the part to display the Attribute Editing dialog box (see 4-88).

2 Select the attribute whose display characteristics you want to change.

3 Click Change Display to display the Change Attribute dialog box.

   The name of the attribute and the current attribute value are displayed.
4 Select or type a value for any of the Display Characteristics.

You can change any of the characteristics as described in Table 9.

5 Click OK to close the Change Attribute dialog box.

6 Click OK to close the Attribute Editing dialog box.

This procedure only changes the display characteristics for the attributes of the one instance of this part on the current schematic. To change display characteristics for the attributes of a part for every instance placed on every schematic, you have to change the global characteristics of the symbol. See Editing the Default Attributes of a Symbol on page 4-94.

Table 9 Attribute Text Characteristics

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orient:</td>
<td>Enables you to position the text horizontally, vertically, upside down, or down in relation to the defining point of the text string.</td>
</tr>
<tr>
<td>Layer:</td>
<td>Specifies a text display level as defined by the Set Display Level function under the Options menu. Defaults to Attribute Text Layer. You can specify a user-defined layer.</td>
</tr>
<tr>
<td>Size:</td>
<td>Determines the size of the text of a displayed text item. The size is expressed as a percentage of the default size (the default size is the font size for the selected layer).</td>
</tr>
<tr>
<td>Hjust:</td>
<td>Sets the horizontal justification for the placement of text items (left, center, or right).</td>
</tr>
<tr>
<td>Vjust:</td>
<td>Sets the vertical justification for placing text items (top, normal, or bottom).</td>
</tr>
</tbody>
</table>
Global Editing of Attributes

PSpice Schematics allows you to change an attribute on multiple parts at the same time.

Assigning the same attribute value to multiple parts

1. Select more than one part, or select an area of the drawing enclosing the parts.
2. Select the Edit Attributes button.
   A confirmation dialog box appears asking if you want to globally edit attributes of all selected items.
3. Click Yes to display the Global Edit Attributes dialog box.
4. In the Attribute Name text box, type the name of the attribute.
5. In the Value text box, type a value for the attribute.
6. Click OK.
   The named attribute is changed to the specified value for all selected parts having that attribute.

Note: Click Browse to view a list of attributes for the selected items. If the value of an attribute is the same for all selected items, the value appears. Otherwise, no value appears.
Editing the Default Attributes of a Symbol

When placing parts, you might want to change the value of an attribute for all parts of a certain type, such as a resistor. For example, you might want to change the default value for all resistors being placed from a value of 1 Kohm to 10 Kohm.

Changing the default value of a resistor

1. Select a resistor symbol on the schematic.
2. Click the Edit Symbol button to display the resistor symbol in the symbol editor window.
   Note the name of the symbol library analog.slb in the title bar of the symbol editor window.
3. Click the New File button to display a new (blank) symbol editor window.
4. Select Copy from the Part menu to display the Copy Part dialog box.
5. Click Select Lib to display the Open dialog box.
6. Select Analog.slb from the scroll list.
7. Click Open.
8. Double-click R in the Part list.
9. From the File menu, select Close.
   The prompt “Save changes to part R?” will appear.
10. Click Yes.
   You are prompted for a library file name.
11 Type a name in the File Name text box.
12 Click Save.
   You are prompted to add the library to the list of configured libraries.
13 Click Yes.

Repeating Part Placements

If you are placing parts in line with each other and evenly spaced, use the Auto-Repeat function.

Automatically repeating part placements

Before selecting the part for placement, enable the Auto-Repeat function and set the offset spacing.

1 From the Options menu, select Auto-Repeat to display the Auto-Repeat dialog box.
2 Select the Enable Auto-Repeat check box.
3 Specify a horizontal and vertical offset for the part placements.
   Figure 4 illustrates parts that are placed at various vertical and horizontal offsets.

By default, the Enable Auto-Repeat check box is disabled, the Horizontal Offset spacing is set to 00.00, and the Vertical Offset is set to 00.10.
Chapter 4  Creating and Editing Designs

4 Select the part from the symbol library.

5 Place the first instance of the part.

6 Press Space once to place each subsequent instance of the same part.

Manually repeating part placements

1 If Auto-Repeat is not enabled, press Space to repeat the last action.

   If the last action was placing a part, pressing Space changes the pointer to the symbol outline of the last part placed.

2 Move the symbol outline to any location on the schematic and click to place the part.

3 To stop placing the part, do one of the following:
   - Double-click to place the last instance of the part.

Note Use F8 and Shift F8 to enable and disable Auto-Repeat, respectively. If you do not need to change the offsets, this is a convenient way to quickly place arrays of parts and wires.

Figure 4 Placing Resistors with Various Vertical and Horizontal Offsets
• Right-click to stop placing the part without placing an additional part.

The outline changes back to a pointer.

Automatically Assigning Reference Designators

The Auto Naming function is useful for assigning reference designators to parts as they are placed. The default starting reference designator number is 1. When placing resistors, the first one placed is R1, the second R2, and so on. You can set the starting reference designator to any number, depending on the way you package or organize your design.

Enabling Auto Naming of reference designators

1. From the Options menu, select Auto Naming to display the Auto Naming dialog box.
2. Select the Enable Auto Naming check box.
3. Type a starting designator number if you want the numbering to start at a number other than one.
4. Click OK.
Example — Using Auto-Repeat and Auto Naming

Use the following procedure to create part of the drawing shown in Figure 5 using the Auto-Repeat and Auto Naming functions.

Placing the bus and part

1. Click the Draw Bus button.
2. Move the pencil-shaped pointer to the location of one end of the first bus segment. Click to start drawing the bus.
3. Click at each vertex of the bus. Double-click at the end of the bus.
4. Type 74273 in the Get Recent Part list box on the toolbar.
5. Press Enter.
6. Move the outline pointer to the location of U1 and double-click to place a single instance of the 74273 part.

Figure 5 Auto Naming for Bus Labels


Drawing the first wire segment connecting the part to the bus

1. Click the Draw Wire button.
2. Move the pencil-shaped pointer to a point on the bus where wire segment A[0] attaches to the bus. Click to start drawing the wire.
3. Move to pin D1 on U1 and double-click.

Using Auto-Repeat to create the remaining wire segments

1. Enable Auto-Repeat (see Automatically repeating part placements on page 4-95).
2. Set the horizontal offset to 00.00 and the vertical offset to 00.10.
3. Press Space seven times to draw seven additional wire segments.

Using Auto Naming to quickly label the wire segments

1. From the Options menu, select Auto Naming to display the Auto Naming dialog box.
2. In the Wire/Port Labels frame, select the Enable Auto-Increment check box.
3. Type A[0] in the Label Template text box.
4. Click OK.
5. Select the first wire to be labeled.
6. From the Edit menu, select Label to label the wire.
7. To label each of the remaining wire segments:
   a. Select the wire.
   b. Press Space.
Replacing Parts

A single part on a schematic may be replaced easily. In addition, all parts of a given type on a page, or all pages of a multi-page design may be replaced. Instead of having to delete one part, find another in a library, and place the new part, you can replace the old with the new in one operation.

Replacing a single part

1. Select the part to be replaced.
2. From the Edit menu, select Replace to display the Replace Part dialog box.
   
   Note that Target Part is unavailable because you have already selected a part and don’t need to specify one in the dialog box.
3. In the Replacement text box, type the name of the replacement part.
4. If you want the attribute values of the part being replaced applied to the replacement parts, select the Keep Attribute Values check box.
5. Click OK.
   The selected part is replaced.

Replacing multiple parts in a selected set

1. Select the group of parts to be replaced. (See Selecting more than one object on page 4-116.)
2. From the Edit menu, select Replace to display the Replace Part dialog box.
3. In the Replacement text box, type the name of the replacement parts.
4. If you want the attribute values of the parts being replaced applied to the replacement parts, select the Keep Attribute Values check box.
5. Click OK.
   All of the selected parts are replaced.
Replacing all parts of the same name

1. From the Edit menu, select Replace to display the Replace Part dialog box.

2. In the Target Part text box, type the name of the parts to be replaced.

3. In the Replacement text box, type the name of the replacement parts.

4. If you want the attribute values of the parts being replaced applied to the replacement parts, select the Keep Attribute Values check box.

5. Click the Current Page Only option button to replace all target parts on the current schematic page or click the All Pages option button to replace all target parts on all pages of a multi-page design.

6. Click OK.

All of the named target parts are replaced.
Placing Power and Ground Symbols

In PSpice Schematics, power and ground symbols are a type of global port symbol. The label on the port defines the name of the power supply.

Placing Power and Ground Symbols

Placing a symbol on the schematic

1. From the Draw menu, select the Get New Part button (see Finding Parts on page 4-80) to select a port symbol from the part browser.
2. Move the outline pointer to where you want the part located and click.

To place several instances, point and click at each additional location.

Stopping part placement

To stop placing the symbol, do one of the following:

- Double-click to place the last instance of the symbol.
- Right-click to stop placing the symbol without placing an additional symbol.

The outline changes back to a pointer.
Creating Custom Power and Ground Symbols

Because power and ground symbols are just like any other symbols, you can use the symbol editor to create your own custom power and ground symbols.

See Drawing Symbol Graphics on page 6-178.
Using Wires and Buses

Parts and ports contain one or more pins to which connections can be made. Electrical connections are formed by joining pins of parts and ports with wires and buses.

A junction dot appears where three items are joined.

Drawing and Labeling Wires

Drawing a wire

1. Click the Draw Wire button to change the pointer to a pencil shape.
2. Click to start the wire.
3. Click at each vertex of the wire.
4. Click a pin, another wire or a bus to end the wire (or double-click to end at any point).

If you end the wire on a pin, another wire, or a bus and do not double-click, draw-wire mode remains active, which allows you to start and draw additional wires.

5. To stop drawing the wire, do one of the following:
   - Double-click to place the last segment of the wire.
   - Right-click to stop drawing the wire without drawing an additional segment.

The outline changes back to a pointer.

Adding a wire segment

If a wire segment meets the end of another wire segment, they become part of the same wire, without a junction being created. This principle also applies to bus segments.
If a wire segment is added so its end-point intersects another wire segment (at a point other than its end-points), a junction is created and the original wire is split into two segments. All three segments become part of the same wire.

You can place a label on selected wires, bus segments, or ports. Wire and bus segments may have multiple labels.

**Labeling a wire**

You can assign labels to wires for clarity. Labels are not required except on wires that are connected to buses.

1. Double-click the wire segment that you want to label, which will display the Set Attribute Value dialog box.
2. Type the label in the LABEL text box.
3. Click OK.

**Editing a wire label**

Use the following procedure to edit existing labels.

1. Double-click the wire (or the label) to display the Set Attribute Value dialog box with the existing label displayed in the LABEL text box.
2. Edit the existing label or delete it and type in a new label.

**Rewiring**

The Rewire function reroutes a selected wire or bus segment without disconnecting its end points. The results of rewiring depend on the Rubberbanding setting (see Rubberbanding on page 4-111).

1. From the Draw menu, select Rewire to change the pointer to a cross symbol.

---

*Note* A wire connected to a bus must be labeled with one of the signals on the bus.

By default, wires with the same label are not treated as connected. If you want to connect them, you must connect each wire to an off-page port with the same label.

To change the default:

1. Select Restricted Operations from the Options menu.
2. Select the Connectivity Via Wire Labels check box.
3. Click OK.
2 Click the wire segment that you want to change.
3 Click to place a vertex.
4 Double-click to place the last vertex and stop rewiring.

**Drawing and Labeling Buses**

The connectivity of buses and bus segments in PSpice Schematics is controlled by labeling. The rules of connectivity are:

- A bus label specifies the signals it carries and the order of the signals.
- A bus can connect to another bus only if one is a subset of the other (such as A[0-31] and A[16-31]).
- A bus electrically connects to a pin of a part or port if the pin name indicates the same number of signals. Connection is in the order specified; for example, a bus labeled A[31-0] connected to a port labeled Addr[32-63] will electrically connect A[31] with Addr[32], A[30], with Addr[33], and so on.
- For a wire to be connected to a bus, the wire must be labeled with one of the signals on the bus.
- Valid syntax for labeling a bus is:
  
  - CLK[0-15]
  - CLK[0:15]
  - CLK[0..15]
  - CLK[0-3, 12-15]
  - CLK1, CLK2, data1, data2, input,...

  In the latter form, each and every signal in the bus must be included in the series. The signals are separated by commas.
**Drawing a bus**

1. Click the Draw Bus button to change the pointer to a pencil shape.
2. Click to start the bus.
3. Click at each vertex of the bus.
4. Right-click to end the bus and change the pencil back to a pointer.

**Labeling a bus**

1. Double-click the bus segment to display the Set Attribute Value dialog box (see 4-105).
2. Type the label in the LABEL text box.
3. Click OK.

**Editing a bus label**

1. Double-click the bus (or the label) to display the Set Attribute Value dialog box (see 4-105) and the existing label in the LABEL text box.
2. Edit the existing label or delete it and type in a new label.

**Connecting wires to buses**

1. Draw a wire so that it ends on the bus.
2. Label the wire with one of the signals on the bus. For example, you can label the wire DB[12] or DB12 if the bus is labeled DB[0:16].

**Splitting buses**

Connecting a bus segment to the middle of another bus segment creates a junction. The bus segments become part of the same bus unless labeled differently. This allows sub-buses to be taken off a main bus, for example A[0-7] from A[0-31].

1. Draw a bus segment and end it on the main bus.
Label the bus segment with a subset of the signals on the main bus.

For example, you can label the bus segment DB[0:8] if the main bus is labeled DB[0:16].

Automatically Labeling Wires and Buses

Use the Auto Naming function to set up the labeling of wires and ports. The syntax specified in the Label Template text box allows you to name a uniform collection of wires.

**Naming a collection of wires connected to a bus**

1. From the Options menu, select Auto Naming to display the Auto Naming dialog box.
2. In the Wire/Port Labels frame, select the Enable Auto-Increment check box.
3. In the Label Template text box, type the label for the first wire in the series, for example, CLK[0]. Wires will be labeled incrementally in the order selected, as CLK[0], CLK[1], CLK[2], and so on.
4. Click OK.
5. Select the first wire to be labeled.
6. From the Edit menu, select Label to label the wire.
7. To label each of the remaining wires in the series:
   a. Select the wire.
   b. Press `Space`. 
Specifying Drawing Options

Several options aid in drawing wires and buses and in placing parts.

- The Orthogonal option constrains wires and buses to vertical and horizontal lines.
- The Snap-to-Grid option keeps parts, wires, and buses aligned to grid lines.
- The Snap-to-Pin option constrains wire and bus placements to the nearest pin.
- The Rubberband option maintains connectivity between parts when they are moved.

Orthogonality

Orthogonal allows wires and buses to be drawn only as horizontal and vertical lines.

Figure 6 illustrates two resistors connected by a wire drawn with Orthogonal enabled. The wire was drawn by clicking at the bottom of R1 and moving directly to R2 and clicking again. The wire was drawn by vertical and horizontal lines even though the movement of the pointer was diagonal.

![Figure 6 Orthogonal Wire Drawing](image)
Enabling orthogonal drawing

1. From the Options menu, select Display Options.
2. In the Options frame, select or clear the Orthogonal check box to enable or disable orthogonality.
3. Click OK.

Snap-to-Grid

Snap-to-grid controls the movement of the object while being moved for placement when Stay-on-Grid is enabled. If Snap-to-Grid and Stay-on-Grid are both enabled, movement during object placement is in increments equal to the current grid spacing. If Snap-to-Grid is not selected, the object moves smoothly.

Enabling snap-to-grid

1. From the Options menu, select Display Options.
2. In the Options frame, select or clear the Snap-to-Grid check box to enable or disable snap-to-grid.
3. Click OK.

Snap-to-Pin

Snap-to-pin, when enabled, causes the end-point of a wire or bus segment to snap to the nearest pin if one is found inside the radius defined by the Gravity setting.

Enabling snap-to-pin

1. From the Options menu, select Display Options.
2. In the Options frame, select or clear the Snap-to-Pin check box to enable (or disable) snap-to-pin.
3. Click OK.
Gravity

Gravity specifies how close an object must be to a pin to snap to it. Gravity is only functional when snap-to-pin is enabled.

Specifying gravity

1. From the Options menu, select Display Options (shown on page 4-110).
2. In the Snap-to-Pin frame, in the Gravity box, type the snap-to-pin gravity value.
3. Click OK.

Grid Spacing

Grid Spacing defines the horizontal and vertical grid spacing on your drawing area. The default spacing is 10 units. This corresponds to 0.10 inches for US-standard page sizes, and 2.5 millimeters for metric page sizes. The minimum grid spacing allowed is 0.01 inch, or .25 millimeters.

Specifying grid spacing

1. From the Options menu, select Display Options.
2. In the Grid Spacing frame, type the grid spacing value (shown on page 4-110).
3. Click OK.

Rubberbanding

Rubberbanding makes it easier to rearrange your schematic for new parts and clean up the schematic when necessary. You can move one or more selected objects to a new location while maintaining connectivity.

Results vary according to whether Orthogonal is enabled or disabled. Figure 7 illustrates a rubberbanding move with Orthogonal enabled, while Figure 8 shows the same move with Orthogonal disabled.

Gravity is only functional when snap-to-pin is enabled.
Chapter 4  Creating and Editing Designs

Figure 7  Rubberbanding with Orthogonal enabled

Figure 8  Rubberbanding with Orthogonal disabled
While you are moving an object (whether orthogonal is enabled or disabled), an X appears where a new connection will be made if the object is placed, and the pointer changes to a caution sign (see Figure 9 below). If you continue to move the object (away from the connection), the X disappears and the pointer returns to normal.

New connections are formed when:

- a pin, wire, or bus is placed on another pin, wire, or bus
- the path of a wire or bus crosses over a pin, wire segment endpoint, or bus segment endpoint

Figure 9 shows a path with a potential new connection.

Figure 9 Rubberbanded path showing a potential connection

Enabling Rubberbanding

1. From the Options menu, select Display Options.
2. In the Display Options dialog box (see 4-110):
   a. Select the Rubberband check box.  
   b. Select the Orthogonal check box, if you want rubberbanding to be orthogonal.  

3. Click OK.
Using Ports

Signals can be connected without using wires or buses by connecting them to global or off-page ports and labeling the ports with the same name.

Off-Page Ports

Off-page ports connect to other off-page ports with the same name on the same page or on other pages within the same schematic. If you are working on a schematic and you need to connect signals between pages, use off-page ports.

Global Ports

Global ports connect to other global ports of the same name anywhere in the schematic hierarchy.

The symbol library port.slb contains several port symbols. You can also create your own port symbols using the symbol editor.

A third type of port, interface port provides connections between the pins of a hierarchical block or symbol and the underlying schematic. Refer to Chapter 7, Creating and Editing Hierarchical Designs, the section on Using Interface Ports on page 7-236.
Placing a global port

1. Click the Get New Part button to display a Part Browser dialog box, (see 4-82).
2. Click Libraries to display the Library Browser dialog box (see 3-45).
3. In the Library list, select port.slb.
4. In the Part list, double-click GLOBAL.
5. Click Place to place the global port, or click Place & Close to close the dialog box and place the global port.

Labeling a global port

1. Double-click the port to display the Set Attribute Value dialog box (see 4-105).
2. Type the label in the LABEL text box.
3. Click OK.

Note: A quick way to place the global port is to type “global” in the Get Recent Part list box on the toolbar.
Selecting and Moving Objects and Attributes

Before performing any operation on a schematic object, you have to select the object. You can make multiple selections or select whole areas of the schematic.

After you select an object, you can move, copy, delete, edit, cut, and paste that object.

Selecting

Selecting an object (a part, wire, or bus on the schematic)

1. Point to the object with the pointer and click to select it.

The object color change (the default is red) indicates it is selected.

After the object is selected, you are ready to perform an action. Selecting a new object causes the selection of any previously selected objects to be cancelled.

Selecting more than one object

1. Hold down Ctrl and Shift while selecting multiple objects individually.

The objects change color to indicate they are selected.

Selecting all objects within a given area of your schematic

1. Draw a selection rectangle around the group of objects you want to select.

Only objects entirely contained within the box are selected.

Selecting an object attribute

1. Point to the attribute and click.
A rectangle is drawn around the attribute; a selection rectangle also appears around the object that the attribute belongs to.

De-selecting selected objects

1. Click to select an object other than the selected object, or click in a blank area of the schematic.

Moving

Moving an object

1. Select an object (or group of objects).
2. Click the pointer on the object, or in the area designated by the selection rectangle.
3. Drag the selection to the desired location.
4. Release the mouse button to place the object.

Searching for and Selecting Parts

In a large design, you may have to find an object to select it. To save you time, PSpice Schematics allows you to search for objects and specify search criteria. It then selects objects located in the search.

Use the Find command from the Edit menu to search for an object. You can search for parts, wires and buses that contain attributes.
Finding a part

1. From the Edit menu, select Find to display the Find dialog box.

2. Specify the search criteria:
   a. Type an attribute name in the Name text box.
   b. Type the attribute value in the Value text box.
   c. Click Add Criterion to add the search criteria to the Additional Criteria text box.
   d. Repeat steps a through c as many times as necessary to add more search criteria.

3. Click the Current Page Only button to search only on the current page, or click the All Pages button to search all pages in a multi-page design.

4. Click the Select All button to have all items meeting the search criteria selected, or click the Select Next button to have only the next item meeting the search criteria selected.

5. Click OK to begin the search.
   The status line indicates the number of items found and selected.
Cutting, Copying, and Pasting

PSpice Schematics provides several editing features that allow you to cut, copy, paste, copy to clipboard, delete, and undelete selected objects. All of these functions are available under the Edit menu. Most can be accessed from the keyboard.

The cut, copy, copy to clipboard, and delete functions only apply when an object is selected. To learn how to select single and multiple objects as well as objects within a given area, see Selecting on page 4-116.

Cutting

Cut deletes the selected object (or group of objects) from the schematic and copies it to the clipboard for use with the Paste function. The clipboard retains only the object last cut.

**Cutting a selected object**

1. Select an object to cut.
2. From the Edit menu, select Cut.

Copying

The Copy function makes a copy of the selected object for pasting. The selected object remains on the schematic and a copy is placed to the clipboard.

**Copying a selected object**

1. Select the object to copy.
2. From the Edit menu, select Copy.

Pasting

Paste places one or more copies of the last object stored in the buffer (from a Cut or Copy operation) onto the schematic.
Pasting an object

1. From the Edit menu, select Paste to change the pointer to the shape of the object last cut or copied.
2. Click to place the object at the current pointer location.

Continue moving the pointer to various locations and clicking to place additional copies of the object. Right-click to stop pasting.

Deleting

Delete removes an object. A deleted object cannot be copied or pasted.

Deleting a selected object

1. Select an object to delete.
2. Press Delete.

The object is placed in the recycle bin and can only be recovered with the undo function (see Undo/Redo on page 4-120).

Undo/Redo

Undo reverses changes made such as placing parts, changing attributes, moving objects, or drawing wires and buses. Redo will re-do what was just undone. There is no limit to how many steps can be undone or redone. However, Undo/Redo information is only stored for changes to the schematic since the last time the file was saved.

To undo/redo what was just done

1. From the Edit menu, select Undo or Redo.

Note: Undo/Redo does not apply to operations that do not change the page content. For example, panning and zooming, editing a library or a symbol, creating a netlist, or adding, creating, or copying a page.
Copying to the Clipboard

The Copy to Clipboard function copies objects within a selection rectangle to the Microsoft Windows Clipboard for use in other Windows programs. Electrical or connectivity information is not copied to the clipboard. This function is useful if you want to make a copy of your schematic to include in another type of file, such as a word processor file.

If the grid is enabled, the grid dots are copied to the clipboard along with the schematic. If you don’t want the grid dots copied, disable the grid before copying. See Grid On on page 3-55.

Copying an area of the schematic to the Windows Clipboard

1. Using a selection rectangle, select the area to be copied.
2. From the Edit Menu, select Copy to Clipboard.
   The area is copied to the Windows Clipboard. The copied area remains unchanged on the schematic.

Importing a schematic into Microsoft Word

Before selecting the area to be copied, disable the grid. If the grid is enabled, the grid dots will be copied into the Microsoft Word document.

1. From the Options menu, select Display Options.
2. In the Display Options dialog box (see 4-110), clear the Grid On check box to disable the grid.
3. Copy an area of the schematic to the clipboard, as explained in Copying an area of the schematic to the Windows Clipboard on page 4-121.
4. In Microsoft Word, insert a frame where you want the schematic to be placed.
5. Press Ctrl+V to paste the contents of the clipboard.
Creating and Editing Title Blocks

Each new schematic is created with a title block in the lower-right corner of the page. The title block is treated as an annotation symbol and each text field is an attribute. As such, you can edit the attributes of the title block much the same as you would the attributes of other objects. You can type information into the title block in the default format, or you can create a custom title block.

Editing Page Title

The page title, when specified, appears in the title block.

Changing the page title

1. From the Navigate menu, select Edit Page Info to display the Page Info dialog box.
2. Type a page title in the Page Title text box.
   The Simulation Only check box, when enabled, (displays a check mark), indicates the entire page is to be ignored for purposes other than simulation (for instance, it will be ignored for PCB layout).
3. Click OK.
Entering Information into the Title Block

Entering information into the existing title block can be done in one of two ways: (1) by editing the attributes of the title block, in which case you can type information into any, or all fields of the title block, or (2) by editing an individual attribute of the title block.

Entering information into multiple attributes of the title block

1. Select the title block, then select Attributes from the Edit menu to display the Attribute Editing dialog box.

You can also double-click the title block to display the Attribute Editing dialog box.

2. In the attribute list, double-click the attribute.

3. Type the information in the Value text box.

4. Click Save Attr.

5. Select another attribute or click OK.
Editing one attribute of the title block

1. Double-click the attribute of the title block to display the Set Attribute Value dialog box.

   ![Set Attribute Value dialog box]

2. Type or correct the information in the text box.

3. Click OK.

Creating a Custom Title Block

Because the title block is treated as a symbol, you can use the symbol editor to create your own custom title block or edit the existing title block to suit your requirements. See Chapter 6, "Creating and Editing Symbols."

Instead of creating a title block each time you start a new schematic, you can copy the TITLEBLK symbol from the “special.slb” symbol library to your own custom symbol library and modify it to suit your needs. You must configure your custom symbol library into the library search list for your custom title block symbol to be available for use.
Using a Custom Title Block Symbol

After you have created a custom title block, you have to specify that block in order to use it in the current schematic.

Specifying a new title block symbol

1. From the Options menu, select Editor Configuration to display the Editor Configuration dialog box (see 3-44).
2. In the Title Block Symbol text box, type the name of the title block symbol.
3. Click OK.
Adding Non-Electrical Information

Non-electrical information such as comments, tables, and graphics can be added to the schematic.

There are three types of non-electrical information:

- **text**—multiple lines or a single line, such as comments or instructions
- **graphics**—lines, circles, and arcs
- **annotation symbols**

Text

**Multiple Line Text Editing**

With the multiple line text option, you can enter text at any location on the schematic by creating an editable, resizable text box. This is the best way to add more than one line of text to a schematic. The text properties can be changed to specify the font, color, point size, and frame of the text box.

**Drawing the text box**

1. From the Edit menu, select Draw Text Box to change the pointer to a pencil shape.
2. Click the pointer at a location on the schematic and do the following:
   a. Move the pointer down and to the right.
   b. Click to set the lower-right corner of the text box.
3. Type the text.

The text will wrap as it is entered, however, you must resize the text box to view text that flows beyond its bottom boundary.
Resizing the text box

1. Select the text box to display its handles.
2. Click one of the handles and drag to resize the text box.

Editing Text

1. Click inside the text box to modify or add text.

Single Line Text Editing

With the single line text option, you can continuously type text on one line. This is a quick way to enter text onto a schematic, and is especially useful if the amount of text is minimal. In the schematic editor, once the text has been placed, it may be edited and the text box may be resized.

Adding a single line of text

1. From the Draw menu, select Text to display the Add Text dialog box.

![Add Text dialog box]

2. Type the text in the text box.
3. Click OK.
   
   An outline box follows the pointer that indicates the outline of the text string.

4. Move the outline to the desired location and click to place the text.
   
   The outline box remains on the screen. You can click to place the same text string in several locations.

5. To stop placing the text string, do one of the following:
   
   - Double-click to place the last instance of the text.

To rotate the box, select it and press \( \text{Ctrl}+\text{R} \). (See Rotating Parts on page 4-86.)

Note: The text will automatically wrap within the box as it is entered.
• Right-click to stop placing the text string without placing an additional one.
  The outline changes back to a pointer.

**Resizing the text box**

1. Select the text to display the text box handles.
2. Click one of the handles and drag to resize the box to the size needed.

**Editing text**

1. Click inside the box to edit or enter more text.

**Changing the Properties of the Text**

There are two ways to change text properties in PSpice Schematics:

- changing properties on an instance basis through the Text Properties dialog box
- setting the defaults for all annotation text in the Display Preferences dialog box (see *Controlling the Display in PSpice Schematics* on page 3-60 for further explanation)

**Changing the text properties on an instance basis through Text Properties**

1. Select the text or text box whose properties you want to change.
2. From the Edit menu, select Text Properties to display the Text Properties dialog box.

*Note* The text will automatically wrap within the box as it is entered.

To rotate the box, select it and press **Ctrl+R**. (See *Rotating Parts on page 4-86.*

You can also double-click the frame of the text box to display the Text Properties dialog box.
3 Select the appropriate properties for the text selected.

**Note** In addition to changing the text properties, you can change the properties of the text box itself in the Frame area.

4 Click OK.

**Setting the default text properties through Display Preferences**

1 From the Options menu, select Display Preferences to display the Display Preferences dialog box.

2 Select one or more text layers from the Display Layers list (see 3-61 for how to select more than one layer).

If you decide you don’t want to apply the changes you have made, click the Restore Defaults button to restore the settings selected in the Display Preferences dialog box. The Restore Defaults button works at any time before closing the dialog box or after re-entering it.
3 Click the Text tab.

4 Select the appropriate properties.

5 Click Apply to apply the changes immediately and keep the dialog box open for further changes, or click OK to apply the changes and close the dialog box.

Note Changes made in the Display Preferences dialog box become the default settings for all schematics, but may be changed at any time.

The Annotation Graphics toolbar is available for placing graphics on your schematic.

Graphics

Adding Graphics

Graphics can be added directly onto your schematic.

Adding annotation graphics

1 From the Draw menu, select arc, box, circle, or polyline.

See Editing Existing Symbols on page 6-188 for a description of the available graphics and how to create them.
Resizing annotation graphics

1. Select the object to display its handles.
2. Click one of the handles and drag to resize the object.

Changing Graphics Properties

There are two ways to change the graphics properties in PSpice Schematics:

- changing properties can be changed on an instance basis through the Graphics Properties dialog box
- setting the defaults for all annotation graphics properties in the Display Preferences dialog box (see Controlling the Display in PSpice Schematics on page 3-60 for further explanation)

Changing the graphics properties on an instance basis through Graphics Properties

1. Select one or more objects whose properties you want to change.
2. From the Edit menu, select Graphics Properties to display the Graphics Properties dialog box.
3. Select the appropriate properties for the objects selected.
4. Click OK.

An arrow will display when you drag the pointer over a handle to indicate that it may be resized.

You can also double-click the object or group of objects to display the Graphics Properties dialog box.

If you decide you don’t want to apply the changes you have made, click the Restore Defaults button to restore the settings selected in the Display Preferences dialog box. The Restore Defaults button works at any time before closing the dialog box or after re-entering it.
Chapter 4    Creating and Editing Designs

Setting the default graphics properties through Display Preferences

1. From the Options menu, select Display Preferences to display the Display Preferences dialog box (shown on 4-129).

2. From the Display Layers list, select the Annotation Graphics layer.

3. Click the Graphics tab.

4. Select the appropriate properties.

5. Click Apply to apply the change immediately and keep the dialog box open for further changes, or click OK to apply the changes and close the dialog box.

Note: Changes made in the Display Preferences dialog box become the default settings for all schematics, but may be changed at any time.
Importing Bitmaps and Metafiles

You can import bitmap (.bmp, .dib), Windows metafiles (.wmf), or enhanced metafiles (.emf) onto the schematic.

Importing a graphic

1. From the Draw menu, select Insert Picture to display the Open dialog box.

2. Select the file type: Bitmaps or Metafiles.

3. Select a file from the window or type the path of the file location in the File Name text box.
   
   For example:
   
   `c:\graphics\tron.bmp`
   
   where c: is your local drive

4. Click Open and a rectangle the size of the graphic will appear attached to the pointer.

5. Click to place it.

Resizing an imported graphic

1. Select the graphic to display its corner handles.

2. Drag one of the handles to resize the graphic to the appropriate size.
   
   The graphic will size proportionally.

Note  All imported graphics are imported by reference. If you move files that have been imported by reference, PSpice Schematics will not be able to locate the files to display them.

Note  If you need to move the graphic to another location on the schematic, select it and move it as you would any other object.
Annotation Symbols

Creating annotation symbols and adding them to a custom library allows you to easily use them in other designs.

Creating annotation symbols

1. From the Edit menu, select Symbol to start the symbol editor.
2. From the File menu, select Open.
   Select the existing library where the annotation symbol will be saved.
3. From the Part menu, select New to display the Definition dialog box.
   a. Type a name for the symbol in the Part Name text box.
   b. From the Type list, select Annotation.
   c. Click OK.
4. Use the symbol editor to add graphics to the symbol. (See Drawing Symbol Graphics on page 6-178.)
   Note Because annotation symbols are non-electrical, do not use pins.
5. From the Part menu, select Attributes to display the Attributes dialog box.
a  Add any attributes to contain custom information for later use.

b  Click OK.

6  From the File menu, select Save.

Moving Non-Electrical Information

**Moving text, graphics, and annotation symbols**

1  Select the object.

2  Place the pointer on the edge of the object and the annotation movement cursor becomes attached to the pointer.

3  Drag and place the object at the desired location on the page.
Creating and Editing Multi-sheet Designs

A schematic can contain one or more pages. As a schematic grows beyond a single page, ports are used to establish connectivity. Off-page ports provide connectivity between pages of the same schematic. Global ports provide connectivity across schematic pages to other global ports of the same name, anywhere in the schematic hierarchy. Off-page and global ports are named the same as the nets that they are connected to.

The Navigate menu allows you to move between pages in multi-sheet designs and provides the means to create new pages, copy pages from other schematics, delete pages, and give each page a title.

Adding a Page to a Design

There are two ways to add additional pages to your schematic: (1) creating a new page, or (2) copying a page from the current schematic or another schematic.

Creating a new page

1. From the Navigate menu, select Create Page to display the Create Page dialog box.
2. Type a title for the new page in the Page Title text box.
3. You can accept the next sequential number as the page number for the new page or type in a different number.
4. Click OK to add the new page.
Copying a page

1. From the Navigate menu, select Copy Page to display the Copy Page dialog box.

2. Select the schematic file from the Directory list.

3. Select a page number, if the page to be copied is part of a multi-page schematic.

4. Click OK to add the page to the current schematic after the current page and renumber all further pages.

Creating Connections Between Pages

Use off-page ports to create connections between pages. Off-page ports can either be labeled or unlabeled. If an off-page port is unlabeled, it must be connected to a labeled wire or bus.

Connecting a signal between pages

1. Place an off-page port (OFFPAGE) on one schematic page.

2. Connect a labeled wire or a bus signal to the off-page port.

3. Repeat steps 1 and 2, using the same signal name, on the other schematic pages.
Viewing Multiple Pages

To view pages in a multi-page design, use the Previous Page, Next Page, and Select Page selections under the Navigate menu.

Viewing the previous page
1. From the Navigate menu, select Previous Page.

Viewing the next page
1. From the Navigate menu, select Next Page.

Viewing a particular page
1. From the Navigate menu, select the Select Page option.
2. Double-click the desired page number and title.
3. Click OK.

Viewing multiple pages at the same time
1. From the Windows menu, select New.
2. From the Navigate menu, select Previous Page, Next Page, or Select Page.

Cutting, Copying and Pasting Between Pages

Cutting and pasting or copying from one page to another in a multi-page design is done in almost the same manner as on a single sheet design. See Cutting, Copying, and Pasting on page 4-119.

1. Cut or copy the object.
2. Navigate to the page where the object is to be placed (see Viewing Multiple Pages on page 4-138).
3. Paste the object.
Deleting a Page

To delete a page from a multi-page design, use Delete Page under the Navigate menu.

Deleting a page

1. Navigate to the page you want to delete.
2. From the Navigate menu, select Delete Page to display a Delete Page confirmation dialog box.
3. Click OK to delete the page.
Printing Your Design

Printing options allow you to print one or more pages, or a selected area of a schematic.

Printing the current page of the current schematic

1. Click the Print button.
   The page is immediately sent to the current (default) printer.

Printing a selected area of the current page

1. Select an area of the schematic. (See Selecting on page 4-116.)
2. Click the Print button.
   The selected area is immediately sent to the current (default) printer.

Printing selectively

1. From the File menu, select Print to display the Print dialog box.
2. Select the appropriate pages from the Pages list, or click Select All to print all of the pages of the current schematic.
3 Select one of the scaling options. See Scaling on page 4-141.

4 Select an Orientation of either Landscape or Portrait.
   Most schematics are in landscape format. Landscape is the schematic editor default format.

5 Click OK.

**Scaling**

Scaling options allow you to control the size of the printout.

**Auto-Fit**

Auto-fit scales the size of the page to print one schematic page per sheet of printer paper. For example, if the schematic page (set through the Page Size selection in the Options menu) is B-size and your printer paper is A-size, Auto-fit automatically sets a zoom factor of 50% so that the B-size drawing fits on the A-size paper as Example 1 of Figure 13 shows. If the orientation is set to Portrait, as in Example 2, the zoom factor would be automatically set to a smaller percentage to fit the entire schematic on the page.
User-Definable Zoom Factor

User-definable zoom factor allows you to set a custom zoom factor. For example, with the zoom factor set at 100%, a B-size schematic will print on two A-size sheets of paper when the printer is configured in portrait mode, as shown in Figure 14.
With the zoom factor set to 200%, a B-size drawing will print on eight sheets of paper as shown in Figure 15. Doubling the zoom factor quadruples the number of printer pages needed to print a schematic.

![Figure 15: Zoom Factor Set to 200% with Printer Configured in Portrait Mode](image)

With user-definable zoom enabled, the printer configured in portrait mode and a 100% zoom factor, as shown in Figure 16:

- An A-size schematic will print on two sheets of A-size paper.
- A B-size schematic will print on two sheets of A-size paper.
In landscape mode, using a 100% zoom factor, as shown in Figure 17:

- An A-size schematic will print on one sheet of A-size paper.
- A B-size drawing will print on four sheets of A-size paper.
Figure 17  User-definable Zoom Enabled in Landscape Mode
Closing the Schematic Editor

You can close the schematic editor, thereby closing all open schematics. You can also close an open schematic without exiting the schematic editor.

Closing the schematic editor

To exit the schematic editor and close all currently open schematics, do one of the following:

• From the File menu, select Exit.
• In the upper-right corner of the schematic editor window, click the Close button.

You will be prompted to save any unsaved open schematics.

Closing a schematic

To close a schematic without closing the schematic editor:

• Select Close from the File menu.
• In the upper-right corner of the design window, click the Close button.

If the current schematic has not been saved, you will be prompted to save it.
Using the Symbol Editor

Overview

The symbol editor enables you to do the following tasks:

- create and edit symbols for use in the schematic editor
- edit existing libraries
- create new libraries

This chapter provides background information about the symbol editor, which includes:

Starting the Symbol Editor on page 5-151 describes procedures for starting and closing the symbol editor.

Symbol Editor Window on page 5-153 describes the use of menus, the Toolbar and toolbar buttons, the status line and the keyboard.
Changing Text Characteristics on page 5-158 describes procedures for changing the text characteristics of attribute text, pin name and number display, and free-standing text.

Changing Grid and Gravity on page 5-162 describes enabling and disabling grid, setting grid spacing, setting gravity and using text grid.

Zooming and Panning on page 5-166 references the zoom and pan features of the symbol editor.

Printing Symbols on page 5-167 describes how to print the symbols created with the symbol editor.
Components

A component or device has several aspects associated with it:

- **symbol**—the graphical representation used in drawing schematics
- **packaging information**—defines the names of the package types (footprints) in which the component is available, the pin number assignments for those package types, and the number of gates (for multi-gate components)
- **footprint**—used for board layout
- **simulation model**—if the component can be simulated with PSpice A/D

Symbols

Symbols are created and modified with the symbol editor, and are stored in symbol libraries (.slb). Symbols consist of graphics, pins (for electrical symbols), and attributes.

Packaging Information

Packaging information for a component is closely related to the symbol but is kept separately in a package definition. Package definitions are stored in package libraries (.plb). The association of the symbol and the packaging definition is by name. Generally, you will create a symbol with a given name and a package definition with the same name. If you use the Symbol Creation Wizard in PSpice Schematics to create symbols, it will automatically create a package definition for you.
Package definitions are created and modified with the PSpice Schematics symbol editor.

**Footprints**

The footprint for a component is the definition of its mechanical outline, pad pattern, identifiers, and physical extent (boundary). The package definition for a symbol defines the names of the footprints (package types) in which it is available. For each footprint, the package definition defines the physical pin number assignments for the pins. When a symbol is placed on a schematic, the PKGTYPE attribute defines the name of the footprint to be used in the layout.

**Simulation Models**

If a component can be simulated, it will have an associated simulation model. The MODEL attribute on a symbol defines the name of the simulation model. Simulation models are stored in model libraries (.lib). You can create new simulation models with Parts or with a text editor. Refer to the *Creating Models* chapter in your PSpice user’s guide.
Starting the Symbol Editor

Starting the symbol editor

In the schematic editor, click the Edit Symbol button to create a new symbol editor document window if one does not already exist.

If you already have a symbol editor window open, you will be prompted to save any unsaved changes to the active symbol. You can only have one symbol editor window open at a time.

When you save the symbol library, any open schematics are updated with the changes made in the symbol editor.

Loading a Library for Editing

To edit or create symbols or package definitions in an existing library, you must first load the library for editing. You can also create a new library to contain the symbols or package definitions that you create.

Opening an existing library

1. Click the Open File button on the toolbar.
2. Type the name of the library in the Open dialog box.
3. Click OK.

Creating a new library

1. Click the New File button on the toolbar.
2. You are prompted to name the library when you save the first symbol.

Any symbol or package definition you create will be saved in the new library.

A quick way to edit a symbol for a part used on a schematic:
1. Click the part on the schematic to select it.
2. Click the Edit Symbol button on the toolbar.

The symbol editor is started, the library containing the symbol is loaded, and the symbol is displayed for editing.
Saving your Changes

To save newly created symbols or changes to existing symbols:

1. Click the File Save button on the toolbar.

If the library is not configured for use in the schematic editor, you will be asked if you want to configure the library. Answer YES to make the symbols in the library available for use in PSpice Schematics.

If the library is already configured, any schematics using symbols you have changed will be updated to use the new symbol.

Returning to the Schematic Editor

To return to the schematic editor and keep the symbol editor window open for additional symbol editing, do one of the following:

- minimize the symbol editor window
- click in the schematic editor window
- select the schematic editor window from the Window menu

When you are finished with the symbol editor, close the symbol editor window by clicking the Close button in the upper-right corner, or select Close from the File menu.

Starting Automatically

If you are going to use the symbol editor more than the schematic editor, you can have the symbol editor start automatically when you start PSpice Schematics. Add the -sym option to the Command Line in the Windows Program Item Properties dialog box for the PSpice Schematics icon. For example:

```
C:\OrCAD\psched.exe -sym
```
Symbol Editor Window

When you start the symbol editor, the symbol editor window displays.

Note  You can only open one symbol editor window at a time and you can only edit one symbol at a time.

Refreshing the Screen

To clean up and refresh the screen, click the Redraw button on the toolbar.

Menus

There are a series of menus from which you can select the function you want to perform.

The display and operation of the menus and submenus follow the standard Windows layout and operation.
PSpice Schematics provides different menus for the schematic editor and for the symbol editor. The menus change as you change active windows.

**Toolbar**

Toolbar buttons provide shortcuts for performing common actions.

To enable or disable the Toolbar display:

1. From the View menu, select Toolbar.

   A check mark next to the Toolbar menu item indicates that the toolbar is displayed.

<table>
<thead>
<tr>
<th>Table 10</th>
<th>Symbol Editor Toolbar Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Buttons</strong></td>
<td><strong>Name</strong></td>
</tr>
<tr>
<td>![New File icon]</td>
<td>New File</td>
</tr>
<tr>
<td>![Open File icon]</td>
<td>Open File</td>
</tr>
<tr>
<td>![Save File icon]</td>
<td>Save File</td>
</tr>
<tr>
<td>![Zoom In icon]</td>
<td>Zoom In</td>
</tr>
<tr>
<td>![Zoom Out icon]</td>
<td>Zoom Out</td>
</tr>
<tr>
<td>![Zoom Area icon]</td>
<td>Zoom Area</td>
</tr>
<tr>
<td>![Zoom to Fit Symbol icon]</td>
<td>Zoom to Fit Symbol</td>
</tr>
<tr>
<td>![Draw Arc icon]</td>
<td>Draw Arc</td>
</tr>
<tr>
<td>![Draw Box icon]</td>
<td>Draw Box</td>
</tr>
</tbody>
</table>
## Table 10  Symbol Editor Toolbar Buttons

<table>
<thead>
<tr>
<th>Buttons</th>
<th>Name</th>
<th>Function</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Draw Circle</td>
<td>draws a circle on the symbol</td>
<td>6-1</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Draw Polyline</td>
<td>draws a polyline or line on the symbol</td>
<td>6-1</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Place Pins</td>
<td>places pins on the symbol</td>
<td>6-1</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Draw Text</td>
<td>places a text string on the symbol</td>
<td>6-1</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Insert Picture</td>
<td>imports a bitmap (.bmp, .dib) or Windows metafiles (.wmf, .emf)</td>
<td>4-1</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Edit Attributes</td>
<td>edit the attributes of a symbol</td>
<td>6-2</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Get New Part</td>
<td>gets a symbol from a symbol library for editing</td>
<td>6-1</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>New Symbol</td>
<td>starts the Symbol Wizard</td>
<td>6-1</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Redraw</td>
<td>refreshes the symbol editor screen display</td>
<td>5-1</td>
</tr>
</tbody>
</table>
Title Bar

The symbol editor window title bar displays the name of the symbol library and the symbol currently being edited. For example:

[C:\ORCAD\LIB\PORT.SLB:GLOBAL]

When you open a symbol editor window and have not specified a symbol for editing, the title bar displays:

<new>:<new>

This indicates you are editing a new symbol in a new library.
Keyboard

Table 11 lists the function keys you can use instead of menu selections to enable or disable certain functions. For those functions that toggle, pressing the function key enables the feature, and pressing \( \text{Shift} \) plus the function key disables the feature.

**Table 11  Symbol Editor Function Keys**

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
<th>Menu</th>
<th>Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Help</td>
<td>Help</td>
<td></td>
</tr>
<tr>
<td>F2</td>
<td>grid on</td>
<td>Options</td>
<td>Display Options</td>
</tr>
<tr>
<td>F4</td>
<td>text stay-on-grid</td>
<td>Options</td>
<td>Display Options</td>
</tr>
<tr>
<td>F5</td>
<td>auto-scroll</td>
<td>Options</td>
<td>Pan &amp; Zoom</td>
</tr>
<tr>
<td>F6</td>
<td>stay-on-grid</td>
<td>Options</td>
<td>Display Options</td>
</tr>
<tr>
<td>F8</td>
<td>auto-repeat</td>
<td>Options</td>
<td>Auto-Repeat</td>
</tr>
<tr>
<td>F10</td>
<td>current errors</td>
<td>File</td>
<td>Current Errors</td>
</tr>
</tbody>
</table>

Function keys F2, F4, F5, F6, and F8 are toggle keys. Pressing the key enables the feature, and pressing \( \text{Shift} \) plus the key disables the feature.
Changing Text Characteristics

For any text placed on your symbol, such as free standing text, pin names, attribute names, and values, there are options to set the desired text size, orientation, horizontal justification, and vertical justification.

Attribute Text

You can change the text characteristics of any attributes of the symbol. The text characteristic changes you make are only applied to the attribute that you are currently editing.

Changing attribute text characteristics

1 Double-click the text to display the Change Attribute dialog box.

Change any of the characteristics of the text in the Display Characteristics frame of the dialog box, as shown in Table 12.

2 Click OK.
Table 12  Display Characteristics

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orient:</td>
<td>Enables you to position the text horizontally, vertically, upside down, or down in relation to the defining point of the text string.</td>
</tr>
<tr>
<td>Layer:</td>
<td>Specifies a text display level as defined by the Set Display Level function under the Options menu. Defaults to Attribute Text Layer. You can specify a user defined layer.</td>
</tr>
<tr>
<td>Size:</td>
<td>Determines the size of the text of a displayed text item. The size is expressed as a percentage of the default size (the default size is the font size for the selected layer).</td>
</tr>
<tr>
<td>Hjust:</td>
<td>Sets the horizontal justification for the placement of text items (left, center, or right).</td>
</tr>
<tr>
<td>Vjust:</td>
<td>Sets the vertical justification for placing text items (top, normal, or bottom).</td>
</tr>
</tbody>
</table>
Pin Name and Number

Changing pin name text characteristics

1. Double-click the pin name or pin number to display the Change Pin dialog box.

2. Change any of the text characteristics as shown in Table 12.

3. Click OK.

Changing pin number text characteristics

1. Double-click the pin name or pin number to display the Change Pin dialog box.

2. Click Edit Attributes to display the Attributes dialog box.
3 Click to select an item in the list.
   Change any of the characteristics of the text in the Display Characteristics frame of the dialog box, as shown in Table 12.
4 Click OK.
5 In the Change Pin dialog box, click OK.

Free-Standing Text

You can change the text characteristics of any of the free-standing text that you have placed on the symbol. The changes you make are only applied to the text item you are currently editing.

Changing free-standing text characteristics

1 Double-click the text to display the Change Text dialog box.

   ![Change Text dialog box]

   Change the orientation, justification or size, as shown in Table 12 on 5-159.
2 Click OK.
Changing Grid and Gravity

The grid and gravity functions of PSpice Schematics eases your drawing tasks and can help make your schematic more precise.

Grid On

When Grid On is enabled, the grid is displayed in the drawing area of the schematic editor window.

Enabling or disabling the grid display

1. Select Display Options from the Options menu to display the Display Options dialog box.
2. Select or clear the Grid On check box to enable or disable the grid display.
   A check mark in the check box indicates that the grid is enabled.
3. Click OK.

Stay-on-Grid

Stay-on-grid controls the method of object placement. When Stay-on-Grid is enabled, the objects are forced onto grid when placed. We recommend that you enable this so that electrical connections are made correctly.

Enabling or disabling stay-on-grid

1. Select Display Options from the Options menu.
2. Select or clear the Stay-on-Grid check box to enable or disable Stay-on-Grid.
3. Click OK.
Snap-to-Grid

Snap-to-grid controls the movement of the object while being moved for placement. If Snap-to-Grid and Stay-on-Grid are both enabled, movement during object placement is in increments equal to the current grid spacing. If Snap-to-Grid or Stay-on-Grid is not selected, the object moves smoothly.

Enabling or disabling snap-to-grid

1. From the Options menu, select Display Options.
2. Select or clear the Snap-to-Grid check box to enable or disable snap-to-grid.
3. Click OK.

Grid Spacing

Grid Spacing defines the horizontal and vertical grid spacing on your drawing area. The default spacing is 10 units. This corresponds to (and displays as) 0.10 inches for US-standard page sizes, and 2.5 millimeters for metric page sizes. The minimum grid spacing allowed is 0.01 inch, or .25 millimeters.

Specifying grid spacing

1. From the Options menu, select Display Options.
2. In the Grid Spacing text box, type the grid spacing value.
3. Click OK.

The Stay-on-Grid command must be enabled for the Snap-to-Grid command to be effective.
Gravity

The gravity setting determines how close the pointer must be to an object for the object to be selected when you click the pointer. The default is .03 inches (or .75mm).

Specifying gravity

1. From the Options menu, select Display Options.
2. In the Gravity text box, type the snap-to-pin gravity value.
3. Click OK.
Text Grid allows you to set the grid spacing for text separately from the normal grid spacing. The text grid is usually set to some smaller percentage of the regular drawing grid. This allows you to align text along smaller increments of the regular grid.

**Enabling text grid and specifying text grid size**

1. From the Options menu, select Display Options.
2. Select the Text Stay-on-Grid check box to enable the text grid.
   - A check mark in the check box indicates that the text grid is ON.
3. Type the text grid spacing value in the Spacing text box.
4. Click OK.
Zooming and Panning

The zoom and pan features in the symbol editor are the same as they are in the schematic editor. Refer to Zooming and Panning in Schematics on page 3-68.
Printing Symbols

Printing a symbol

1. From the File menu, select Print to display the Print dialog box.

2. To select the part or parts to be printed, do the following:
   a. Select the Current Symbol Only check box to print the symbol being edited.
   b. Select one or more parts from the Parts list.
   c. Click Select All Parts to print all parts in the open library.

3. In the Content Options frame, select the check box to enable printing. The Content Options are described in Table 13.

4. Select one of the Scaling options.
   - Auto-fit expands the symbol to full page size.
   - User-definable enables you to specify the zoom factor for the size of the symbol.

5. Select an Orientation: Landscape or Portrait.

6. Click OK.
### Table 13  **Content Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Symbol Image</td>
<td>specifies printing the graphics of the selected symbol</td>
</tr>
<tr>
<td>Attributes</td>
<td>specifies printing the attributes and the attribute values of the selected symbol</td>
</tr>
<tr>
<td>Symbol Data</td>
<td>specifies printing the description, type, Bbox dimensions, and origin position of the selected symbol</td>
</tr>
<tr>
<td>Pin Data</td>
<td>specifies printing the pin data of the selected symbol</td>
</tr>
</tbody>
</table>
Creating and Editing Symbols

Overview
This chapter describes how to use the symbol editor to copy, create and edit symbols, which includes:

Creating New Symbols on page 6-171 describes the four essential methods of creating a new symbol.

Drawing Symbol Graphics on page 6-178 describes the assortment of drawing tools provided for creating and editing a symbol.

Editing Existing Symbols on page 6-188 describes the editing features for defining and editing pins, and for defining and editing packaging definitions.

Editing Symbol Attributes on page 6-197 describes how to add and edit the properties of a symbol.

Using Symbol Aliases on page 6-200 describes how to give a symbol an alternate name.

Specifying Part Packaging Information on page 6-201 describes procedures for defining packaging information.
Configuring Custom Libraries on page 6-214 describes the procedure for making a custom library available in PSpice Schematics.
Creating New Symbols

Following are the four methods for creating a new symbol:

1. Using the Symbol Wizard.
   - Use the wizard to create symbols from scratch. The wizard guides you through the steps for creating a symbol and also creates packaging information for the symbol.
   - Use the wizard to create symbols automatically for existing models.

2. Making a copy of an existing symbol under another name and modifying the copy.

3. Importing a symbol definition exported by another PSpice Schematics user.

4. Creating an A Kind Of (AKO) symbol, which is a reference of any existing symbol.

Using the Symbol Wizard

The Symbol Wizard helps you to create new symbols. Following are some of the features and benefits of using the Symbol Wizard:

- Eases the creation of symbols by guiding you through each step of the process
- Provides simple point-and-click dialog boxes
- Provides feedback as you make decisions
- Avoids using complicated mouse or keyboard interactions
- Enables you to navigate through the symbol creation process by backing up to repeat a step and moving forward

If you are creating a symbol for an existing simulation model, refer to the Creating Symbols for Models chapter in your PSpice user’s guide.
When you start the Symbol Wizard you are taken through a progression of screens, which provide you with information, ask you questions, and present you with choices, based on your selection in the first screen (shown below).

**Starting the Symbol Wizard**

1. From the Part menu, select Symbol Wizard.
2. Follow the instructions that appear on the screen.

*Note: Symbol names cannot contain spaces.*
Creating a Symbol by Copying Another Symbol

An easy way to create a symbol is to make a copy of a similar symbol and modify the copy.

Making a Copy of a Symbol

Copying a symbol from another library

1. From the Part menu, select Copy to display the Copy Part dialog box.

2. Click Select Lib in the Open dialog box, and select a library.

   PSpice Schematics lists all of the library parts in the Parts box.

3. Type the name of the part to be copied in the Existing Part Name text box, or select it from the Part list.

4. Type a new name for the part in the New Part Name text box.

5. Click OK.

   You can now edit the symbol. Saving the symbol places it in the current library.

Creating a new symbol in a different library

1. From the Part menu, select Save to Library.

2. Type the name of the library (.slb) where the symbol is to be saved.
## Importing a symbol definition

Import enables you to import a symbol that has been previously exported (see Exporting a symbol on page 6-174) and incorporate it into a symbol library file.

### Importing a symbol

1. From the Part menu, select Import to display the Import dialog box.

2. In the File Name text box, type the name of the file to be imported, or select the file name from the file selection list.

3. In the Part Name text box, type the name to be given to the imported symbol.

4. Click OK.

### Exporting a symbol

Export allows you to write a symbol definition from the open symbol library to a text file, enabling you to transfer symbols from one library to another, or from one platform to another, without having to transfer the entire symbol library.

1. From the Part menu, select Export to display the Export Parts dialog box.
In the Part Name text box, enter the name of the symbol to be exported, or select it from the list.

In the File Name text box, enter the name of the file to which the part definition is to be written.

Click OK.

Using AKO Symbols

Some of the Orcad symbol libraries are made up of a few base symbols and several AKO (A Kind Of) symbols. In the bipolar.slb symbol library, for example, the qnpn and qpnp symbols are base symbols. All other symbols reference one of these two base symbols.

A base symbol must be contained in the same library as the AKO symbols that reference it. Base symbols do not, however, have to be displayed in the Part Browser.

If you copy an AKO symbol from another library (see Creating a Symbol by Copying Another Symbol on page 6-173), you must also copy its base symbol.

Creating a base symbol in a custom symbol library

From the Part menu in the symbol editor, select New.
2 Enter a name for the part in the Part Name text box (TestCase, for example).

3 Enter a description of the part in the Description text box.

4 Leave the AKO Name text box blank, and select Do not display in the Part Browser check box.

5 Click OK.

**Saving the symbol to a library**

1 From the File menu, select Save.

2 In the File Name text box, type the name of the library.

3 Click OK.

4 In the Configure dialog box, answer Yes to “Add to list of PSpice Schematics configured libraries?”

Now you can draw a symbol using the procedures given in **Drawing Symbol Graphics on page 6-178** and **Defining and Editing Pin Types on page 6-191**.

You have defined this to be a base symbol by leaving the AKO Name text box blank and selecting the Do not display in the Part Browser check box.

After you have created the base symbol, you can create other symbols that reference the base symbol (that is, AKO symbols).
Creating New Symbols

**Creating an AKO symbol**

1. From the Part menu in the symbol editor, select New.
2. In the Part Name text box, type a name for the part.
3. In the Description text box, type a description of the part.
4. In the AKO Name text box, type the name of the base symbol (or example, AKO Test).
5. Click OK.

The symbol graphics of the base symbol display in the symbol editor window.

Select Save from the File menu to save the custom symbol library.
Chapter 6    Creating and Editing Symbols

Drawing Symbol Graphics

There are several graphics tools available for drawing symbols. With these tools you can draw circles, lines, arcs, and boxes. You can also place pins and text on your symbol. The default properties of the individual display layers, such as colors, line width, and style are set in the Display Preferences dialog box. See Controlling the Display in PSpice Schematics on page 3-60 or Adding Non-Electrical Information on page 4-126 for information on how to change display properties.

Elements of a Symbol

A symbol consists of various elements, such as arcs, boxes, lines, circles, polylines, text, and pins placed in specific locations.

Arc

Drawing an arc

1. Click the Draw Arc button to change the pointer to a pencil shape.
2. Click to establish an end-point for the arc.
3. Click again to establish the other end-point for the arc. A straight dotted line connects the two end-points.
4. Move the pointer out from the last end point, and the dotted line becomes an arc. When the arc reaches the desired shape, click to fix the arc at that location.

Box

Drawing a box

1. Click the Draw Box button to change the pointer to a pencil shape.
2 Click at the location for the upper-left corner of the box.
3 Move the pointer down and to the right.
   A dotted box outline follows the pointer.
4 Click to set the lower-right corner of the box.

**Circle**

**Drawing a circle**
1 Click the Draw Circle button to change the pointer to a pencil shape.
2 Click the location of the center of the circle.
3 Move outward from the center of the circle.
   A dotted circle outline follows the pointer.
4 Click when the diameter reaches the size you want.

**Polyline**

A polyline is one object, regardless of the number of vertices it contains. It can be manipulated using editing functions such as move, cut, copy, and delete. A polyline may also be resized by clicking on any of its handles and stretching it to a new size.

**Drawing a polyline**
1 Click the Draw Polyline button to change the pointer to a pencil shape.
2 Click to establish the beginning point of the polyline.
   As you move the pointer, a dotted line outlines the shape.
3 Click to place as many vertices as needed.
4 Double-click to establish the end point of the polyline, or right-click at any point to stop drawing.
Adding arrowheads to polylines

1. Select one or more polylines.
2. From the Edit menu, select Graphics Properties.
3. Select the appropriate arrowhead properties.
4. Click OK.

Pins

Adding pins to a symbol

1. Click the Place Pins button to change the pointer to a pin outline.
2. Move the pin outline to the desired location and click to place the pin.
   A small ‘x’ appears on one end marking the connectivity point of the pin.
3. Click at each location to place additional pins.
4. Do one of the following:
   - Double-click to place the last pin.
   - Right-click to stop placing pins without placing an additional pin.

Text

Adding text

1. Click the Draw Text button to display the Add Text dialog box.
2. Type the text in the text box.
3. Click OK.
An outline box follows the pointer that indicates the outline of the text string.

4 Move the outline to the desired location and click to place the text.

   The outline box remains on the screen. You can click to place the same text string in several locations.

5 To stop placing the text string, do one of the following:
   • Double-click to place the last instance of the text.
   • Right-click to stop placing the text string without placing an additional one.

Editing a text string or changing text characteristics

1 Double-click the text string to display the Change Text dialog box.

2 Make the desired changes to the text and its characteristics.

   Instructions for setting text characteristics are included in the previous chapter. See Changing Text Characteristics on page 5-158.

3 Click OK.

Picture

You can import bitmap (.bmp, .dib), Windows metafiles (.wmf), or enhanced metafiles (.emf) into a symbol while working in the symbol editor.

Importing a graphic

1 From the Graphics menu, select Insert Picture to display the Open dialog box.

See Importing Bitmaps and Metafiles on page 4-133 for further instruction regarding importing bitmaps and metafiles.
Selecting

Selecting an element of a drawing

1. Click to select the element.
   The object color (the default is set in the Display Preferences dialog box) indicates it is selected.

2. Move or edit the object as necessary.
   Selecting a new object causes any previously selected items to be unselected.

Selecting more than one element

1. Hold down \texttt{Shift} while selecting the elements.
   The selected elements change color.

Selecting all elements within a given area of the drawing

1. Select the area by dragging the pointer across the desired area.
   A selection rectangle appears to indicate the selection boundary. Only items entirely contained within the boundary are selected.
Filling Shapes

Shapes that have been drawn using either the schematic editor or the symbol editor may be filled with color. In the symbol editor you can fill circles, rectangles, and polylines. Use the Graphics Properties dialog box to change properties on an instance basis, but use the Display Preferences dialog box to set the defaults of those properties (see Changing Graphics Properties on page 4-131).

Filling a shape after it has been drawn

1. Select one or more shapes to fill.
2. From the Edit menu, select Graphics Properties. You can also double-click shapes to display the Graphics Properties dialog box.
3. Select a color, width, and line style for the frame of the graphic.
   
   Note: Polylines do not have to be closed to be filled.
4. Select a color to fill the shape with.
5. Click OK.

If you decide you don't want to apply the changes you have made, click the Restore Defaults button to restore the settings selected in the Display Preferences dialog box. The Restore Defaults button works at any time before closing the dialog box or after re-entering it.
Ordering Drawing Objects

When you draw or paste an object in the symbol editor, PSpice Schematics places it in front of all other objects on the page or in a graphics frame. If the object is filled, it can obscure other objects. You can control how objects overlap by putting them in front or in back of other objects.

Moving objects in back of other objects

1. Select the object you want to place behind another object.
2. From the Edit menu, select Send to Back, which will place the object behind the other object.

Moving objects in front of other objects

1. Select the object you want to place in front of another object.
2. From the Edit menu, select Bring to Front, which will place the object in front of the other object.
Rotating and Flipping Elements

In the symbol editor, you can rotate and flip (mirror) elements currently being drawn, elements already drawn, and entire areas of a drawing. A rotated element is rotated 90° counter-clockwise. A flipped element is mirrored about the Y-axis.

Rotating and flipping must occur during one of the following:

- while dragging (before placement)
- after placement

Rotating Elements

Rotating an element before placing it

1. Select an element to be placed.
2. Press `Ctrl`+`R` to rotate it while still in the drag mode.
   The image rotates 90° counter-clockwise. Each time you press `Ctrl`+`R`, the image will rotate 90° counter-clockwise.

Rotating an already placed element

1. Select the element.
2. Press `Ctrl`+`R` to rotate it 90° counter-clockwise.

Rotating an area of the drawing

1. Drag the pointer to select and outline the area to be rotated.
2. Press `Ctrl`+`R` to rotate the area.
   The selected area rotates 90° counter-clockwise about the center point of the selected area.
Flipping Elements

Flipping an element before placing it on the drawing
1. Press \( \text{Ctrl} + \text{F} \) to flip the element, while still in the drag mode.

Flipping an already placed element
1. Select the element.
2. Press \( \text{Ctrl} + \text{F} \) to flip it.

Flipping an area of the drawing
1. Drag the mouse to select and outline the area to be flipped.
2. Press \( \text{Ctrl} + \text{F} \) to flip the area about its vertical axis.
Moving

Moving an object

1. Select an object (or group of objects).
2. Place the pointer on the edge of the object or selected area and the annotation movement cursor becomes attached to the pointer.
3. Drag and place the object at the desired location on the page.

Resizing

Objects that have already been drawn can be resized by using the appropriate handles.

Resizing an object

1. Select the object that you want to resize.
2. Click one of the handles and drag to resize the object.

An arrow will display when you drag the pointer over a handle to indicate that it may be resized.
Editing Existing Symbols

To edit an existing symbol, you must first load the library that the symbol is stored in. After the symbol is loaded, it can be edited by using all of the common editing functions that are available. To edit packaging information for a symbol, see Editing a Package Definition on page 6-204.

Accessing Symbols

Loading a symbol library
1. Click the File Open button on the toolbar.
2. Type a library name in the Open dialog box.
3. Click OK.

Selecting a part for editing
1. From the Part menu, select Get to display the Get dialog box.

2. Select a part from the list.
3. Click Edit.
Cutting, Copying, and Pasting

The symbol editor has editing functions to cut, copy, paste, repeat, delete, and undelete selected objects. These functions are available under the Edit menu, or can be accessed with keyboard shortcuts.

The cut, copy, and delete functions apply only to selected objects. See Selecting on page 6-182 to learn how to select single and multiple objects as well as objects within a given area.

Cutting

Cut deletes the selected object (or group of objects) from the drawing and copies it to a buffer for use with the Paste function. Only the last objects cut are retained.

Cutting a selected object

1. Select the object to cut.
2. From the Edit menu, select Cut.

Copying

Copy makes a copy of the selected object for pasting. The selected object remains on the schematic and a copy is placed in the buffer.

Copying a selected object

1. Select the object to copy.
2. From the Edit menu, select Copy.
Pasting

Paste places one or more copies of the last object stored in the buffer (from a cut or copy operation) onto the drawing.

Pasting an object

1. From the Edit menu, select Paste to change the pointer to the shape of the object that was last cut or copied.
2. Click to place the object on the schematic.
   Continue moving the pointer to various locations and clicking to place additional copies of the object.
3. To stop pasting the object, do one of the following:
   • Double-click to paste the last instance of the object.
   • Right-click to stop pasting without pasting another object.

With Auto-Repeat enabled, use Space to place repeated copies of items from the buffer without using the Paste function.

Deleting

Delete removes an object (or set of objects). A deleted object cannot be copied or pasted.

Deleting a selected object

1. Select the object to delete.
2. Press Delete.
Defining and Editing Pin Types

Pins establish the input and output terminals for symbols. For a pin you can:

- select the type of graphic to display.
- specify a pin name.
- specify a pin number.
- choose to display the name, the number, or both.

Specifying Pin Types

Figure 18 shows the twelve types of pins that you can place using PSpice Schematics.

![Pin Types Diagram]

Figure 18 Pin Types

Selecting a default pin type

Note To specify the default pin type, do not select a specific pin when performing the following procedure. If a pin is selected, the pin type will only apply to that pin.

1 From the Edit menu, select Pin Type to display the Pin Type dialog box.
2 Click the appropriate option to select the pin type.
3 Click OK.

Shortcut: press \text{T}
Changing the type of a placed pin

1. Select the pin and from the Edit menu, select Change.

2. In the Type list box, select a pin type.

3. Click OK.

The change is only in effect for the selected pin.

Changing the pin name

As you placed pins, default names were assigned.

To change the name of a pin, do the following:

1. Double-click the pin or pin name.

2. In the Change Pin dialog box, type the pin name in the Pin Name text box.

3. Click OK.

Note  Pin names MUST be unique.

Changing the pin number

As you placed pins, default pin numbers were assigned.

To change the pin number for a pin, do the following:

1. Double-click the pin or pin number of the displayed pin to display the Change Pin dialog box.

2. In the Pin text box, type the pin number.

3. Click OK.
Displaying the pin name

By default, pins you place on symbols will have their pin names displayed.

To disable pin names, do the following:

1. Double-click the pin or pin name to display the Change Pin dialog box.
2. Select the Display Name check box to disable the name display.
3. Click OK.

Displaying the pin number

By default, pins you place on symbols will have their pin numbers displayed.

To disable pin numbers, do the following:

1. Double-click the pin or pin number to display the Change Pin dialog box.
2. Click the Edit Attributes button to display the Edit Attributes dialog box.
3. Select the PIN= entry in the list.
4. In the What to Display frame, select None to disable the pin number display.
5. Click Save Attr.
6. Click OK.
7. In the Change Pin dialog box, click OK.
Defining and Editing Hidden Power and Ground Pins

With the symbol editor, you can set a pin to be invisible. If you set the visibility off, you must supply the name of a connecting net (typically a global net like $G_{DPWR}$ or $G_{DGND}$) for the pin in the Net text box. The net is recorded as a symbol attribute (not a pin attribute). The \texttt{IPIN(<pinname>)=<net name>} attribute conveys the net name.

If $G_{<net names>}$ are used for simulation reasons (this is the case in the supplied Orcad libraries), they can be mapped to a more conventional menu for printed circuit board purposes through the .xnt files. For a specific printed circuit board layout editor, there is a \texttt{<toolname>.xnt} file that will convert a schematic net name into a different one.

\textbf{Note} \hspace{1em} \textit{It is possible to map two distinct schematic net names into the same PCB net name, shorting the two together.}

\textbf{Defining a hidden pin}

1. Double-click the pin to display the Change Pin dialog box.
2. Select the Hidden check box.
3. In the Net text box, type the name of the net to which the hidden pin is to be connected.
4. Click OK.
Changing Symbol Origin and Bounding Box

The origin is designated for placing a part, and is the point the part is rotated around. By default, the origin is at (0,0). It is maintained as a point of reference on the schematic.

The bounding box defines the selection area of the symbol when placed on a schematic. After drawing a symbol, all of the elements of the symbol must be enclosed in the bounding box.

**Origin**

By default, part symbols in the symbol libraries have the origin on the point of connection, on the upper-left pin. You can move the origin to any point on the symbol.

*Note* When creating a symbol from scratch, the origin is placed in the upper-left corner of the bounding box. You can move it to a location of your choice after creating the symbol.

If you change the origin of a symbol in the symbol editor (thus changing the location of the symbol graphics relative to that point), the symbol graphics relocate accordingly in the schematic editor whenever you edit previously created schematics.

**Editing a part origin**

1. From the Graphics menu, select Origin to change the pointer to a pencil shape.

2. Move the pointer to the point on the object where you want to place the origin and double-click to fix the origin at that point.
Bounding Box

The bounding box is the rectangular dotted line surrounding the symbol. When you click a part from within the schematic editor, the area in which you can click and have that part be selected, is defined by the bounding box of the symbol.

Resizing the bounding box

1. From the Graphics menu, select Bbox to change the pointer to a pencil shape.
2. Click to begin sizing the bounding box.
3. Move the pointer down and to the right. A dotted box outline follows the pointer.
4. Click at the location of the lower-right corner of the bounding box.

- All pins must be contained within the bounding box for proper connections to be made in the schematic editor.
- Hidden pins, like those found on digital parts, do not have to be, and in most cases are not, contained within the bounding box.
- Attributes do not need to be contained within the bounding box.
Editing Symbol Attributes

You can add attributes (properties) to a symbol. When you add an attribute, you specify a name and a default value. This value can be changed when the symbol is used on a schematic. You can specify whether or not to display the attribute.

There are two attributes that are automatically added to symbols that are created.

- The REFDES attribute, whose default value is U?, specifies the reference designator pattern to use in the schematic editor.
- The PART attribute displays the symbol’s name.

**Note**  
When the symbol is placed on the schematic, PSpice Schematics automatically fills in the value of the PART attribute to be the name you used to place the symbol. For example, if the symbol has several aliases, it fills in the alias that you used. Therefore, you can assign a value in the symbol editor and use it to place the text on the symbol, but when the symbol is used, the value will be reassigned.

**Adding an attribute**

1. From the Part menu, select Attributes to display the Attributes dialog box.
2 In the Name text box, type the name of the attribute.

3 Optionally, type in the default value in the Value text box.

4 By default, the attribute Value only displays on the symbol. To disable any display, select None in the What to Display frame.

5 By default, the attribute value can be changed in the schematic editor on an instance-by-instance basis. To prevent changes to the attribute value, clear the Changeable in Schematic check box to disable this function.

6 By default, attributes that are displayed do not have their text rotated if the symbol is rotated on the schematic (to make it more readable). To have it rotate with the symbol, select the Keep relative rotation check box.

7 Click Save Attr.

8 Click OK.
Editing a displayed attribute

1. Double-click the displayed attribute.

To edit an undisplayed attribute, or to make multiple changes, click the Edit Attributes button on the toolbar.
Chapter 6  Creating and Editing Symbols

Using Symbol Aliases

A symbol has a name. It can also have one or more aliases associated with it. Aliases are alternative names that the device represented by the part are known by. For example, you can have a symbol named 74AC269, which has as one of its aliases HD74AC269P.

When defining an alias, keep in mind that the aliased device will share the same graphics, pins and attributes as the primary symbol. When you place it on the schematic, however, it is treated as a separate part type. The name displayed on the schematic is that of the alias. Each alias requires its own packaging information.

Adding an alias for a symbol

1. From the Part menu, select Definition to display the Definition dialog box.

   ![Definition dialog box]

2. Type the name of the alias in the Alias list text box.
3. Click Add.
4. Click OK.

The PART attribute you define on a symbol will have its value filled in when you place it on the schematic. The name that you call it up with will get filled in as the PART attribute’s value.
Specifying Part Packaging Information

If you are going to use a symbol for PCB layout, you will need to specify package or device information.

Package information consists of:

- the number of gates per package
- a list of package types (footprints) where the device is available
- one or more pin assignment lists
- functionally equivalent pins that can be swapped in layout

Package information is used by PSpice Schematics to package together gates and to generate layout netlists.

Pin Assignment Lists

A pin assignment list is a list of physical pin number assignments for each package type in which a device is available. Because a device may be available in several package types (DIP14, LCC20, and so on), and each may have different pin number assignments, a single package definition can contain more than one pin assignment list. Each pin assignment list is associated with a list of package types (footprints) that the pin number assignments are valid for.
Packaging Definitions

Packaging information is kept in a package definition, separate from the symbol definition. Both are maintained using the symbol editor. By default, the name of the package definition for a symbol corresponds to the symbol name. This can be overridden by explicitly adding a \texttt{COMPONENT} attribute to the symbol. Such an attribute is generally used for devices that have non-standard part names such as BJT's, those with names that begin with a 'Q,' or for those with more than one type of gate.

Package definitions are stored in package libraries. These libraries typically have the same name as the corresponding symbol libraries, but a different extension (".plb"). Package libraries are similar to symbol libraries in that they must be configured into the schematic editor's list of libraries.

With the Packaging menu in the symbol editor, you can create and edit package definitions.

\textbf{Creating a New Package Definition}

You can quickly create a package definition for an existing symbol.

\textbf{Creating a package definition for an existing symbol}

1. Load the symbol in the symbol editor.
2. From the Packaging menu, select Edit.
3. Click OK to start the Package Wizard.
4. Follow the instructions on the screen.

\textbf{Creating a package definition from scratch}

1. From the Packaging menu, select New to start the Package Wizard.
2. Follow the instructions on the screen.
Copying a Package Definition

With the Copy function in the Packaging menu, you can create a new package definition from an existing one. It is the same as the Copy function under the Parts menu, the definition may be copied from the active library or a different library. See “Making a Copy of a Symbol” on page 173.

Copying a package definition

1. From the Packaging menu, select Copy to display the Copy Package Definition dialog box.

2. Type the name of the package to be copied in the Existing Pkg Name text box. To select a package definition from another library, click Select Lib and select a library from the File Open dialog box.

3. Type a new name for the package in the New Pkg Name text box.

4. Click OK.
Chapter 6  Creating and Editing Symbols

Editing a Package Definition

You can edit a package definition for the active symbol or for any package definition in the open package library.

Editing the package definition for the active symbol

1. From the Package menu, select Edit to display the Package definition dialog box.
   The options within the dialog box are discussed in the following sections.
2. When you are finished with the dialog box, click OK.

Editing a package definition in the open package library

1. From the Packaging menu, select Get to display the Get Package Definition dialog box.
2. Type the name of the package in the Pkg Name text box or click a name from the list.
3. Click Edit to display the Package Definition dialog box with the values for the requested package listed.
   The options within the dialog box are discussed in the following sections.
4. When you are finished with the Package Definition dialog box, click OK.

Editing Package Types

When you are editing a package definition, you can specify the package types in which a component is available. The package type name defines the footprint name to be used in layout.

Adding a package type for a component

To add a new package type to the list of available package types for the component:

1. From the Packaging menu, select Edit to display the Package Definition dialog box with the values for the symbols listed.
Specifying Part Packaging Information

2. Click Edit Package Types to display the Edit Package Types dialog box.

3. In the Package Types per Pin Assignment text box, type the name of the package (for example, DIP14) or select a type from the Configured Package Types scroll list.

4. Click Add.

5. Click OK.

6. In the Package Definition dialog box, click OK.

Note: The Configured Package Types List is a list of commonly used package types; it is not an exhaustive list.

If there are multiple package types with the same pin-outs, you can type them all on the same line, separating them with commas (for example, DIP14, SO14). Otherwise, repeat steps 3 and 4 for each package type.
Chapter 6  Creating and Editing Symbols

Specifying physical pin numbers

For each package type (or group of package types that share the same pin-out) the physical pin numbers for each pin must be defined. The Pin Assignments frame in the Package Definition dialog box shows the pin numbers assigned for each logical pin on the symbol (for the active package type).

Note The pin name must match that used in the symbol. If the pin name does not match that used on the symbol, or you need to make a change, perform the following procedure.

Editing pin numbers

1. From the Packaging menu, select Edit to display the Package Definition dialog box (shown on 6-205).
2. In the Package Types list, select the package type to be edited.
3. Click Edit Pins to display the Pin Assignments dialog box.

4. In the list in the lower left of the dialog box, click the pin you want to edit.
   The pin name and pin number appear in the boxes directly above the list.

   Note Pin numbers can be alphanumeric.

5. Make your changes in the Pin Name and Pin No. text boxes.
6. Click Save Assignment.
Any changes you make to a pin assignment are not in effect until you select Save Assignment. If you make a change to a pin and then select another pin from the list without saving, the changes are not implemented.

7 When you are finished editing pins, click OK.

8 In the Package Definition dialog box, click OK.

**Specifying Information for Multi-gate Components**

**Defining the number of gates and their gate names**

1 From the Packaging menu, select Edit to display the Package Definition dialog box (see 6-205).

2 Click Edit Gate Types to display the Edit Gate Types dialog box.

Parts that have the same gates have only one type of gate (gate 1 by default). By defining the names of each gate, you also define the number of gates.

3 Select the entry in the list labeled 1.

4 In the Gates text box, type the names of the gates separated by commas (for example, A,B,C,D).

5 Click Change.

6 Click OK.

7 In the Package Definition dialog box, click OK.
After you have defined the names of the gates, you must define pin numbers for each pin in each gate.

Defining pin number assignments
1. From the Packaging menu, select Edit to display the Package Definition dialog box (see 6-205).
2. Click Edit Pins to display the Pin Assignments dialog box (see 6-206).
3. In the Pin No. text box, type a pin number for each pin for each gate defined in the previous procedure.
4. Click Save Assignment.
5. Click OK.
6. In the Package Definition dialog box, click OK.

Defining shared power and ground pins
1. From the Packaging menu, select Edit to display the Package Definition dialog box (see 6-205).
2. Click Edit Shared Pins to display the Shared Pin Assignments dialog box.
3. Type the name of the pin (as defined on the symbol) in the Pin Name text box.
4. Type the physical pin number in the Pin No. text box.
5. Click Add.
6. Click Save Assignment.
7. Click OK.
8. In the Package Definition dialog box, click OK.

On the symbol for the gate defined above, if there are any shared power pins, ground pins or both, you have to define them as hidden pins.
Specifying Which Pins Can Be Swapped

Pins within a gate that are logically equivalent to one another can be swapped. Pin swapping is usually done during layout to minimize the complexities of circuit routing.

Enabling pin swapping

1. From the Packaging menu, select Edit to display the Package Definition dialog box (see 6-205).
2. Click Edit Pin Swaps to display the Pin Swaps dialog box.
3. In the Pin Names list, select two or more pins that you want to swap.
4. Click Assign.
   The pin numbers appear in the Pin Swaps list separated by commas.
5. Repeat steps 3 and 4 for any other pin number combinations that you want to swap.
6. Click OK.
7. In the Package Definition dialog box, click OK.
Creating Components With Multiple Gate Types

Some components consist of two or more different types of gates (for example, ECL devices). Each type of gate will have a different logical symbol with a unique name, but reference the same package definition. For these types of components, you have to perform several additional steps in defining the package.

Associating more than one symbol with a component

For each symbol:

1. From the Part menu, select Attributes to display the Attributes dialog box.

2. Type a new attribute name **COMPONENT** in the Name text box.

3. Type a value in the Value text box that explicitly specifies the package definition name. Example: For a 10102 package, you could have two symbols: 10102NOR and 10102ORNOR. Both symbols could have the attribute **COMPONENT = 10102**.

4. Click Save Attr.

5. Type a new attribute name **GATETYPE** in the Name text box.
Specifying Part Packaging Information

6 Type a value in the Value text box corresponding to one of the gate types specified in the package definition.

Example:
For the 10102NOR symbol, GATETYPE = 1 (gates A,B,C); for the 10102ORNOR symbol, GATETYPE = 2 (gate D).

7 Click Save Attr.

8 Click OK to exit the dialog box.

9 In the procedure for specifying information for multi-gate components (see Specifying Information for Multi-gate Components on page 6-207), define the different gate types comprising the package.

Example: Type 1 is the NOR gate and type 2 is the ORNOR gate.

10 For each gate type, define the gates and the pin assignments for each gate (see Specifying Information for Multi-gate Components on page 6-207).

The pin assignments define the pin numbers for each gate that correspond to each pin name.

Deleting a Package Definition

Use the Remove function to delete one or more package definitions from the library.

Deleting a package definition

1 From the Packaging menu, select Remove to display the Remove Package Definition dialog box.

2 Type the name of the package to be deleted, or click to select a package from the list.

3 Click Delete to delete the selected item.

4 Click Close.
Configuring Package Types

When you create package definitions and specify package types for a device, you can pick from a list of commonly used package type names or enter one of your own. To add to the list of commonly used package type names that are presented, use the Configure Package Types selection from the Packaging menu. Also use this selection to configure package types into the package classes that are used when you package a design.

When you package a design, you can assign priorities to use when deciding which package type to assign to devices that are available in more than one type. For example, all DIP package types (DIP8, DIP14, and so on) are assigned to the DIP class. You can indicate that you want to use DIP package types whenever possible. Or you might change the priorities to assign SMT package types if possible.

Adding a package type

1. From the Packaging menu, select Configure Package Types to display the Configure Package Types dialog box.

2. In the Package Types text box, type in the new package type name.

3. In the Class list, select one of the existing classes for the new package type. If you need to create a class, do the following:
   a. Click Edit Classes.
b Type in the name of the new class in the Package Class text box.
c Click Add.
d Click OK.
4 Click Add.
5 Click OK.
Configuring Custom Libraries

When you create a library, whether it is a library of symbols or a library of packaging information, the symbols and packaging information are not available for use in the schematic editor until the library is configured. Configuration consists of adding the library file to the list of configured files.

Making a symbol library available in PSpice Schematics

1. From the schematic editor, select Editor Configuration from the Options menu to display the Editor Configuration dialog box (see 3-44).
2. Click Library Settings to display the Library Settings dialog box.
3. Type the name of the new symbol library in the Library Name text box (without the .slb extension).
4. Select the Symbol check box to indicate that the new library is a symbol library. Symbol libraries are searched in the order in which they are listed in the Library Settings dialog box.
5. To add a symbol library at a specific point in the list:
   a. Click the library name above where you want to include the one you are adding to the list.

Note: When you save changes to a library, you will be asked if you want to add the library to the list of configured libraries. Answer yes if you want to make the library available to all schematics.
b Type the name of the one you are adding in the Library Name text box. Be sure the appropriate check boxes are selected to indicate whether you are configuring just the symbol library, or the symbol and package library.

6 Click Add.

7 Click OK.

Note You may need to modify the Library Path (in the upper-right corner of the Editor Configuration dialog box) to include any directory paths that contain library files you added in the previous dialog.

When exiting the Editor Configuration dialog box, PSpice Schematics reloads all of the symbol libraries in the list, making the symbols contained in them immediately usable in the schematic editor.
Example—Creating Symbols from Scratch

You can create custom symbols from scratch in PSpice Schematics. Creating custom symbols includes:

- drawing the graphics
- adding pins
- changing the grid size
- defining attributes
- configuring the new symbol library

To quickly create common symbols, use the Symbol Creation Wizard (see Using the Symbol Wizard on page 6-171), or for examples of creating common symbols by copying existing ones (see Creating a Symbol by Copying Another Symbol on page 6-173), or using AKOs (see Using AKO Symbols on page 6-175).

The following example demonstrates how to create a symbol for a diode bridge rectifier.

Diode Bridge Rectifier

For this example, assume there is a subcircuit definition named BRIDGE stored in a library file called mylib.lib on your local drive. The subcircuit definition would look like the following:

```
.SUBCKT BRIDGE 1 2 3 4
D1 4 1 D1N914
D2 1 3 D1N914
D3 4 2 D1N914
D4 2 3 D1N914
.ENDS
```

The symbol to be created will look very similar to Figure 19.
Opening or Creating a Symbol Library

To open or create a symbol library

1. In the schematic editor, from the File menu, select Edit Library to open the symbol editor.
2. To add this symbol to an existing symbol library:
   a. From the File menu, select Open.
   b. Navigate to your file and open it.
3. If you want to create a new library:
   a. From the File menu, select Save As.
   b. After you type in a name, click Yes to add it to the list of configured libraries.
4. From the Part menu, Select New to open the Definition dialog box.
5. Enter:
   - A description of the device (optional)—it will display when you browse for a symbol in the schematic editor.
   - A name—a symbol name to get the part in PSpice Schematics (in this case it is Bridge).

Note that the file status is `<new>:<new>` (at the top of the window). This means it is a new file (and a new symbol). Keep in mind that `new` also means `undefined`.

Answering yes adds the file to the list of symbol libraries that PSpice Schematics reads in each time it is started.
The type of the part—the part type is most commonly “component,” as it is in this example.

An AKO or alias—use AKO if you want it to inherit the graphics and attributes from another symbol. Use Alias to assign additional names that this symbol can be used for.

**Drawing the Graphics**

After the symbol has a definition, the next step is to draw the graphics. For this example, it is possible to copy the graphics from the regular diode symbol, however, that particular graphic is oriented vertically and horizontally, while this example calls for one that is at a 45-degree angle.

**To draw the graphics**

1. From the Options menu, select Display Options and set the Grid Spacing to 00.02.
   a. If not already enabled, select Stay-on-Grid.
   b. If not already enabled, select Snap-to-Grid.
       Enabling these features will assist in lining up the segments of the symbol.
   c. Click OK.

2. From the Graphics menu, select Draw Polyline to change the cursor to a pencil.

3. Draw the diode that is located in the upper right part of the symbol:
   a. Click once to start drawing.
   b. Make a horizontal line 6 grid dots long. (Do not count the starting grid dot.)
   c. Click once to anchor the end, move the cursor up 6 grid dots, and click to anchor the line midpoint.
   d. Continue drawing and close the triangle by double-clicking at the starting point.
Example — Creating Symbols from Scratch

- Draw a line at a 45-degree angle across the right angle of the symbol already created to denote the cathode.

4 Place three copies of this diode:
   a Drag the mouse to select the area that includes the graphics.
      Release the mouse to turn the lines red. If they do not turn red, reselect the area, or [Ctrl] + click to add them to the selected group.
   b From the Edit menu, select Copy.
   c From the Edit menu, select Paste.
   d Place one copy nearby; another copy will remain attached to the cursor.
   e Before placing the next two copies, rotate the graphics by pressing [Ctrl] + [R].
      There are now four diode symbols: two pointing to the upper right and two pointing to the lower right.

5 From the Options menu, select Display Options and reset the grid to 00.10.
   Verify that Stay-on-Grid and Snap-to-Grid are still enabled.

6 From the Graphics menu, select Draw Box to start the box drawing mode:
   a Click once (approximately) one grid square southeast of the small origin box.
   b Drag to the lower-right corner position.
   c When you have the lower-right corner in position, click to anchor it in place.

7 Select the diode symbols and move them to their approximate locations inside of the box.
Placing Pins

To place pins

1. From the Graphics menu, select Place Pins.

2. To place the pins:
   a. Place the IN+ and IN- pins as shown in Figure 19.
   b. Press $\text{Ctrl} + R$ to rotate the pin that is attached to the cursor.
   c. Place the OUT+ and OUT- pins as shown in Figure 19.

3. Double-click the default name (pin1 through pin 4) of each pin to change their names to the following:
   - IN+
   - IN-
   - OUT+
   - OUT-

4. Single-click the names or numbers to move them to their appropriate position.

   Keep in mind that the ‘X’ on the pin is the point where the wires will connect, and PSpice Schematics will expect to find the connection points on the 00.10 grid

Finishing Touches

1. From the Options menu, select Display Options and set the grid size to 00.01.

2. From the Graphics menu, select Draw Polyline to draw the connecting lines between the diodes in the bridge and also to the tail end of the pins.

   If necessary, select Display Options from the Options menu to turn off Stay-on-Grid. This will enable you to move graphics without being restricted to the grid.

Note: Do not move the pins. If they are not on 10-unit boundaries, you will not be able to connect to them when in PSpice Schematics.
Example — Creating Symbols from Scratch

3. From the Graphics menu, select Draw Text to place the labels D1 through D4 on the diode symbols.

4. To change the size of the text, double-click the text and adjust the size.
   The number is a percentage relative to the usual size.

5. From the Graphics menu, select Box and click once to attach the bounding box to the cursor.
   a. Move the cursor to the lower right so that the bounding box encloses the entire symbol.
   b. Click again to freeze the box; all pin connection points must lay on, or inside of, the boundary box. The boundary box defines the area of the symbol in PSpice Schematics.

6. From the Graphics menu, select Origin and click to attach the origin to the cursor.
   a. Move it into position.
   b. Click again to drop it.

Setting the Attributes

The last step in creating a symbol is to set up the attributes so the symbol can be used for simulation.

1. From the Part menu, select Attributes to display the following attributes in the Attributes dialog box:
   - REFDES
   - PART
   - MODEL
   - TEMPLATE
   a. Click REDES and set its value to: U?
      This is the reference designator that appears in your schematic and in the netlist.
   b. Click Save Attr.

   If you click anywhere within the area of the boundary box in PSpice Schematics, the symbol will be selected.

   The origin is the point the symbol will rotate around when in PSpice Schematics. Usually it is on the hot spot of the top left pin, but it is not required.

   You can also set it to: BRIDGE?
2 Click PART.
   a Set its value to the name that you used in the original definition box.
   b Click Save Attr.

3 Click MODEL.
   a Set its value to the same value as in your model or subcircuit definition.
   b Click Save Attr.

4 Click TEMPLATE.

   The TEMPLATE attribute is the template for generating the netlist entry for this device. The TEMPLATE for this example looks like the following:

   \[ X^{\text{@REFDES}} \text{%IN}+ \text{%IN}- \text{%OUT}+ \text{%OUT}- @\text{MODEL} \]

5 Click Save Attr.

6 Click OK.

7 Make any last changes and select Save from the File menu.

You can now call up the diode bridge symbol for use in a design.

### Parameter Description

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>references a subcircuit definition</td>
</tr>
<tr>
<td>^@REFDES</td>
<td>appends the hierarchical path (if there is one) and the reference designator to the 'X' in the netlist</td>
</tr>
<tr>
<td>%</td>
<td>indicates that the item following will be a pin name</td>
</tr>
<tr>
<td>@MODEL</td>
<td>indicates the value of the MODEL attribute will be placed here</td>
</tr>
</tbody>
</table>

MODEL and TEMPLATE are only required if you are going to simulate.

Notice that the names used match the pin NAME as defined on the pins in the symbol; the ORDER of the pins in the TEMPLATE are listed in the same ORDER as those in the subcircuit.

Looking at the symbol on page one, note that IN+ is the same as node 1 in the subcircuit definition.
Configuring the Models

The diode bridge symbol is now ready for use in PSpice Schematics, but the model library must also be configured if the design is going to be simulated.

1. From the Analysis menu, select Library and Include Files.

2. If the required library is not already in the Library section, click Browse.

3. Locate the library and click Open to put the library with its path in the File Name field.

4. Select either Add Library* or Add Library.

   The '*' causes the file to be added as a global library. A global library will be available to every schematic until it is removed from the list. Local libraries are available only to the active design, but can be added to another, or made global if needed in the future.
Creating and Editing Hierarchical Designs

Overview

This chapter explains the procedures for creating and editing a hierarchical design. Many of the procedures used for creating and editing a hierarchical design are the same as those for creating and editing a design as explained in Chapter 4, Creating and Editing Designs.

This chapter has the following sections that explain the procedures that are unique to hierarchical designs:

Creating and Editing Hierarchical Blocks on page 7-228 describes how to create and edit hierarchical blocks placed on a schematic.

Creating and Editing Hierarchical Symbols on page 7-233 describes how to use the symbol editor to create hierarchical symbols.

Using Interface Ports on page 7-236 describes how to specify connections to lower-level schematics.
Setting Up Multiple Views on page 7-237 describes how to set up and use alternate representations for a hierarchical block or symbol.

Navigating Through Hierarchical Designs on page 7-239 describes how to move between pages in a hierarchical design.

Assigning Instance-Specific Part Values on page 7-241 describes how to assign instance-specific parts values.

Passing Information Between Levels of Hierarchy on page 7-242 describes how to define the parameters of hierarchical blocks and symbols without concern for how deeply their contents are nested.

Example—Creating a Hierarchical Design on page 7-244 provides the step-by-step procedures for creating the top-level schematic with the block symbol representing the lower-level schematic and creating the lower-level schematic.
Hierarchical Design Methods

You can create a hierarchical drawing in either of two ways:

- Create a block and later assign a schematic to the block (top-down method).
- Create a schematic and turn it into a symbol to be used in a higher level design (bottom-up method).

**Top-down method**

By creating one or more blocks and wiring them together, you can establish a functional block diagram. The block diagram can be used as a top-level sketch for your design.

After you have mapped out the block circuitry, you can push into each block and start drawing a new schematic, or assign an existing schematic to the block.

You can also set the view that each schematic will represent (such as a PCB or a transistor).

**Bottom-up method**

If you already have a schematic that you would like to use in larger designs, you can create a hierarchical symbol to represent the schematic. The hierarchical symbol can then be electrically connected in another design.

Hierarchical design is a useful way to structure large projects, especially those starting from a block diagram and those with multiple occurrences of common circuitry. Use the method of design that best fits your design needs for each circuit you create.
Creating and Editing Hierarchical Blocks

A hierarchical block represents a collection of circuitry in the form of one or more lower-level schematics. The block displays on a schematic as a rectangle with a variable number of input and output ports.

You can place one or more instances of a hierarchical block on a schematic. After you place a block, you can stretch it, reshape it and move it. You can create a schematic to be represented by the block or associate an existing schematic with the block.

Wires and buses that end at any of the edges of the block automatically connect to the block. Pins are created where these connections occur. A default pin name appears within the block; this pin name can be changed.

Creating a hierarchical block

1. Click the Draw Block button to change the pointer to a rectangle representing the block.
2. Move the block to the desired location and click to place it.
3. Right-click to stop placing blocks.

The block is assigned a reference designator of HB\(n\) (where \(n\) is a sequential number beginning with 1). You can change the reference designator of the block.
Changing the reference designator of the hierarchical block

1. Double-click the HBn reference designator to display the Edit Reference Designator dialog box.

2. Type the reference designator in the Package Reference Designator text box.

3. Click OK to close the dialog box.

Resizing a hierarchical block

1. Select the block to display its handles.

2. Click one of the handles and drag to resize the block.

Creating a schematic for a hierarchical block

1. Select the block.

2. From the Navigate menu, select Push.

   The block, as placed, is a standard size, orientation and shape. You can stretch and reshape the block.

   To rotate the block, select it and press Ctrl+R. (See Rotating Parts on page 4-86.)

   Shortcut: press F2

   You can also double-click the block to achieve the same results as steps 1 and 2.
3 Type the new schematic name.
4 Click OK.

A new schematic displays and contains interface input and output ports corresponding to the pins connected to the block. The input ports correspond to the pins connected to the left side of the block. The output ports correspond to the pins connected to the right side of the block.

You can move the interface port symbols in the same way that you move other symbols.

You can also associate an existing schematic with a hierarchical block. See Associating an Existing Schematic on page 7-232.

The Implementation frame in this dialog will only display if you are using Design Lab.

Note Interface input and output ports are created automatically only the first time you push into the block. Thereafter, you must manually add any additional interface input and output ports.
Creating and Editing Hierarchical Blocks

Editing a pin name on a hierarchical block

1. Select the pin on the hierarchical block.
2. Click the Edit Attributes button to display the Change Pin dialog box.
3. Type the desired pin name in the Pin Name text box.
4. Click OK.

Deleting a pin on a hierarchical block

1. Select the pin.
2. Press Delete.
Associating an Existing Schematic

Instead of pushing into the block to create a schematic (see 7-229), you can associate an existing schematic with a hierarchical block.

**Associating an existing schematic with a hierarchical block**

1. Select the Draw block button.
2. Place the block and be sure it stays selected.
3. From the Navigate menu, select Push to display the Set Up Block dialog box.

![Image of Set Up Block dialog box]

You can also double-click the block to display the Set Up Block dialog box.

4. In the Filename text box, enter the name of the existing schematic to be associated with this block.
5. Click OK.

When you *associate* an existing schematic with a new block, pins will be automatically created on the block for each interface port on the sub-schematic.
Creating and Editing Hierarchical Symbols

PSpice Schematics uses two basic types of symbols: primitive and hierarchical.

**Primitive symbols** are low level symbols that explicitly contain all of the information required by the netlister. They can be modified by editing their graphics, pins, and attribute lists in the symbol editor.

**Hierarchical symbols** have the same appearance as primitive symbols in PSpice Schematics. They contain one or more levels of schematics inside them while primitive symbols do not. They can also be modified by pushing into them from within the schematic editor or symbol editor and editing the associated schematics.

Creating a Hierarchical Symbol

The Symbolize function automatically creates a symbol to represent a schematic. The symbol editor is then used to modify any portion of the resulting symbol (graphics, pins, and attributes).

When preparing a schematic for symbolization, follow these guidelines:

- Place input and output interface ports (IF_IN, IF_OUT) at the inputs and outputs of the schematic. Interface ports are mapped to I/O pins placed on the left (input) and right (output) of the new symbol.

- Place global ports (GLOBAL or BUBBLE) to bring out global nets or connections as hidden pins. Global ports are mapped to hidden pins placed on the top and bottom of the new symbol. An IPIN(xxx) attribute, with a value that is the name of the net that it is
connected to, is created for each hidden pin. Hidden pins are especially useful for global power and ground on digital parts ($G_{DPWR}, G_{DGND}$).

Symbolizing a schematic

1. Open the schematic.
2. From the File menu, select Symbolize to display the Save As dialog box.
3. Type the name of the symbol.
4. Click OK.
   
   A file selection dialog box prompts for a symbol library to save the symbol in.
5. Select a library.
6. Click OK.

When you symbolize a schematic, the resulting symbol is hierarchical (that is, it will have a schematic associated with it, so you can push into the symbol and view that schematic).

After you have symbolized your schematic, you need to make the symbols in your new symbol library available to PSpice Schematics.

Note: Avoid modifying the symbol libraries that were shipped with your software. Create a new symbol library for the custom symbols you create.
Converting Hierarchical Blocks to Symbols

When you finish editing a hierarchical block, you have the option of turning the block into a symbol. By making the block a symbol, you make it available for use in other schematics.

Converting a block to a symbol

1. Select the block.
2. From the Edit menu, select Convert Block to display the Save As dialog box.
3. Type a name for the symbol.
4. Click OK to display the Open dialog box.
5. Select a library.
6. Click OK.

PSpice Schematics creates a rectangular symbol to represent the block. One pin is placed on the new symbol for each wire or bus that was connected to the block. The width of the block shrinks one unit on each side to accommodate symbol pins without requiring rewiring.

Note: Converting a block to a symbol is a one-way process. After you convert a block into a symbol, you cannot change that symbol back into a block.
Using Interface Ports

When you use a block or symbol to represent an underlying schematic, connections to the underlying schematic are made by means of the pins on the block or symbol. The pins on the block or symbol must correspond to interface ports placed on the underlying schematic, that is, for each pin there must be a corresponding interface port with the same name as the pin.

If a bus is connected to the block or symbol, the pin name must indicate the number of signals, such as, CLK[0:3]. The interface port would have the same name, such as, CLK[0:3].

If you make changes to the pins on a block or symbol, you must make the corresponding changes on any underlying schematics it represents.

<table>
<thead>
<tr>
<th>If you...</th>
<th>You Must...</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a pin</td>
<td>add an interface port with the same name as the pin.</td>
</tr>
<tr>
<td>delete a pin</td>
<td>delete the corresponding interface port.</td>
</tr>
<tr>
<td>change the name of a pin</td>
<td>change the label of the corresponding interface port.</td>
</tr>
</tbody>
</table>

There are three interface port symbols available in "port.slb":

IF_IN

IF_OUT

INTERFACE

You can use the symbol editor to create custom interface ports.
**Setting Up Multiple Views**

A view is an underlying representation of a hierarchical block or symbol. A block can have more than one underlying representation by having multiple views.

For example, you can define a part that has a transistor-level schematic as one view and a behavioral model schematic as another view.

*Note*  
*There are no restrictions on how many views a part can have, or on what the views are.*

Hierarchical symbols have one or more views. Every hierarchical block or symbol always has a default view that is initialized as the first schematic assigned to it. You can change the default view. You can create and associate additional views at any time. You can modify, delete or rename views. Each view is associated with a schematic, and multiple views can point to the same schematic.

**Translators**

To take different views of a design, configure a *translator* to look for separate view attributes. A translator produces an alternate representation for a schematic. For example, the PSpice Schematics netlister is a translator that operates on a schematic to produce a PSpice netlist. A translator typically looks at information carried by the symbols on a schematic and may or may not also use the implicit connectivity.

If you are also using PLSyn for programmable logic synthesis, you may also configure a view to be the name of a DSL file. Refer to the *PLSyn User’s Guide* for more information.
Setting up an associated view for the Translator

1. From the Options menu, select Translators to display the Translators dialog box.

2. Select a Translator from the list or type a name in the Translator text box.

3. Type the name of the view in the View text box.

4. Click Apply.

5. Click OK.
Navigating Through Hierarchical Designs

The Navigate menu has functions that enable you to move between pages, create new pages, delete pages, and copy pages.

You can move within a hierarchical design using functions from the Navigate menu. You can push into a block from the schematic, move up and down in hierarchical levels and identify the hierarchical path of a selected symbol.

Moving down in a hierarchy
1. Select the hierarchical block or symbol.
2. From the Navigate menu, select Push.
   - If the selected item is represented by only one lower-level schematic, the schematic will display for editing.
   - If the selected item represents more than one schematic (that is, has multiple views), you can select the view to be edited in a dialog box that will appear.

Moving up in a hierarchy
1. From the Navigate menu, select Pop.
If you have made any changes to the present level in the hierarchy, you are prompted to save the modifications or to move up to the next higher level without saving changes.

Moving to the top in a hierarchy
1. From the Navigate menu, select Top.
The top-level schematic appears in the active window.
Chapter 7  Creating and Editing Hierarchical Designs

Finding where active schematic fits in a hierarchy

1. From the Navigate menu, select Where to display the Where dialog box.

![Where dialog box]

The dialog box shows where the open schematic fits in the hierarchy of the open design.

2. Click OK.
Assigning Instance-Specific Part Values

The Edit Schematic Instance function enables you to view and edit the instance specific attributes associated with the instance of the block or hierarchical symbol that you pushed into. You can only add, change, or delete attributes when this function is activated. Any changes only apply to this instance of the hierarchical block or symbol.

Editing an instance of the schematic

1. From the Navigate menu, select Push to push into the hierarchical block or symbol.
2. From the Navigate menu, select Edit Schematic Instance.

A check mark appears next to the menu item to show that it has been selected.

Note: Any changes you make effect only this instance of the schematic. To make changes to the schematic itself, use the Edit Schematic Definition function.

Editing the schematic definition

1. From the Navigate menu, select Push to push into the hierarchical block or symbol.
2. From the Navigate menu, select Edit Schematic Definition.

A check mark appears next to the menu item to show that it has been selected.

You can now edit the schematic. Any changes that you make effect all instances of hierarchical blocks and symbols that reference this schematic.

Note: Edit Schematic Instance and Edit Schematic Definition are mutually exclusive functions.
Passing Information Between Levels of Hierarchy

With PSpice Schematics, you can create a lower-level schematic such that different instances of it will have different component values. For instance, a lower-level schematic contains a certain resistor. The hierarchical block or symbol representing the lower-level schematic defines the value of the resistor. The following procedure shows how you can place one instance of a block and define the resistor value to be 10K and another instance and have the resistor value be 20k.

1. In the lower-level schematic, double-click the resistor value to display the Set Attribute Value dialog box (refer to 4-105).
2. In the Value text box enter \{@RESISTORVALUE\}.
3. Click OK.
4. Save the lower-level schematic.
5. Place a block representing the lower-level schematic on the top-level (or higher-level) schematic (see Creating and Editing Hierarchical Blocks on page 7-228).
6. Select the block.
7. From the Edit menu, select Attributes to display the Attribute Editing dialog box (refer to 4-88).
8. Add an attribute called RESISTORVALUE with a value of 10k.
9. Click OK.
10. Place another block representing that same lower-level schematic on the top-level schematic.

When you netlist the top-level schematic, the two instances of the lower-level schematic will have different resistor values. This is due to the way that attributes are evaluated in PSpice Schematics.

- PSpice Schematics first searches for an attribute at the present level of the hierarchy. If the attribute is not
found at that level, PSpice Schematics then searches the parent level. It continues up the hierarchy until it either finds a definition or until it reaches the top of the hierarchy.

- When PSpice Schematics finds an attribute, it evaluates the attribute at the level where it is found. If the attribute value refers to other attributes, those other attributes must exist at the present level or higher in the hierarchy.

For example, hierarchical symbol A defines two attributes: X=@Y and Y=10. Symbol A contains an instance of a symbol B; B contains an expression referring to the attribute X (@X) and defines the value of attribute Y to be 20 (Y=20).

The evaluation of the expression [@X] is:

- X is searched for on the present level.
- There is no X attribute at this level, so the parent environment (symbol A) is searched.
- An attribute named X is found at this level—this attribute is evaluated in the environment supplied by A.
- The first stage of this evaluation delivers the result @Y—this is then processed to yield the result 10.
- The final result is to make the result of the expression in B be {10} (@X=10).
- The definition for Y in the environment supplied by symbol B is not used when evaluating X in A’s environment.
Example—Creating a Hierarchical Design

This example shows you how to create schematics from the top level down. The design consists of a simple schematic with a block representing a CMOS inverter and a lower-level schematic for the inverter.

Follow this example to create the top-level circuit shown in Figure 20 and the inverter schematic shown in Figure 21.

![Top-level Schematic Drawing for CMOS Inverter](image)

Figure 20  Top-level Schematic Drawing for CMOS Inverter

Drawing the Top-Level Schematic

To create the top-level schematic, start by placing a VSRC power supply connected as an input to a block representing a CMOS inverter. Draw the block, place a resistor and two ground symbols, and connect the components.
Placing the voltage source

1. Click the Get New Part button to display the Part Browser dialog box.

2. Enter VSRC in the Part field.

3. Click Place & Close.

4. Move the part symbol to the desired location and click to place the symbol.

5. Right-click to stop placing parts.

Creating the block representing the CMOS inverter

1. Click the Draw Block button to change the pointer to a rectangle.

   The rectangle represents the block to be drawn.

2. Press Ctrl + R to rotate the rectangle.

3. Move the pointer to the desired location and click to place the block symbol.

4. Right-click to stop placing blocks.

5. Double-click the HB1 reference designator to display the Edit Reference Designator dialog box.

Note: One of two Part Browser dialog boxes may appear: the Part Browser Advanced and the Part Browser Basic. The advanced browser contains many features that you don't need to use for this example. If the Part Browser Advanced dialog box appears, click <<Basic to display the Part Browser Basic dialog box.
Enter \texttt{CMOSINV} in the text box. This changes the value of the \texttt{REFDES} attribute from \texttt{HB1} to \texttt{CMOSINV}.

Click OK.

Drawing the output load resistor

1. Click the Get New Part button to display the Part Browser dialog box (see 7-245).
2. Type \texttt{R} in the Part field.
3. Click Place & Close.
4. Press \texttt{Ctrl}+\texttt{R} to rotate the resistor symbol.
5. Move the resistor symbol to the desired location. Click to place the symbol.
6. Right-click to stop placing parts.

Placing the analog ground symbols

1. Click the Get New Part button to display the Part Browser dialog box (see 7-245).
2. Type \texttt{AGND} in the Part field.
3. Click Place & Close.
   
   You can place the two grounds so that they connect to the power source and the load resistor. This negates having to draw wires between the symbols.
4. Move the ground symbol to the desired locations.
   Click to place each symbol.
5. Right-click to stop placing parts.
Wiring the Symbols

Now that you have placed all of the symbols, wire the symbols to look like the schematic shown in Figure 20.

1. Click the Draw Wire button to change the pointer to a pencil.

2. Click the top of V1. Click at the location of the wire vertex (where it turns from the vertical to the horizontal). Click the left side of the CMOS block. The wire is complete when it shows connection on both ends.

3. Repeat step 2 to connect a wire from the right side of the CMOS block to the top of the load resistor.

4. Right-click to stop wire drawing.

Changing the names of the pins on the block

1. Double-click the pin labeled P1 to display the Change Pin dialog box.

2. Type IN in the Pin Name text box.

3. Click OK.

4. Double-click the pin labeled P2 to display the Change Pin dialog box.

5. Type OUT in the Pin Name text box.

6. Click OK.
**Saving your work as a top-level schematic**

1. Click the Save File button.
2. Type tlcmos as the name of the file (the .sch extension is assigned by default).
3. Click OK.

**Drawing the Lower-Level Schematic**

The top-level design is complete. Now you can create the inner schematic of the CMOS inverter. To do so, select the block and use the Push selection from the Navigate menu to push to a lower level. Because you haven’t defined the lower-level yet, you are presented with a Setup Block dialog box to name the new schematic.

![Schematic of CMOS Inverter](image)

*Figure 21 Schematic of CMOS Inverter*
Selecting the block and naming the new schematic

1. Click the CMOSINV block to select it.
2. From the Navigate menu, select Push.
   Because the block is new, the Setup Block dialog box appears.

   ![Setup Block dialog box]

3. Enter the new schematic name, `cmos`.
4. Click OK.
5. Move the interface port symbols in the same way you move other symbols:
   a. Click to select it.
   b. Drag it to the desired location.
   c. Release to complete the move.

Now draw the schematic for the CMOSINV block as shown in Figure 21.

Drawing the two MOSFET devices

1. Click the Get New Part button to display the Part Browser dialog box (see 7-245).
2. Enter `M2N6804` in the Part text box.
3. Click Place & Close.
4. Press `Ctrl`+`R`, `Ctrl`+`R` and `Ctrl`+`F` to rotate the symbol twice and flip it once so that the source and bulk pins appear at the top. (To verify M1, see Figure 21 on page 7-248.)
5. Move the part symbol to the desired location of M1 and click to place the part.

Shortcut: press `F2`

Double-clicking the block gives the same results as steps 1 and 2.

You are presented with a new schematic containing one interface input port and one interface output port. (They represent the block you drew on the top-level schematic.) If you had connected more pins to the block, more interface ports would appear after pushing into the lower-level schematic.
6 Right-click to stop placing parts.

7 Click the Get New Part button to display the Part Browser dialog box (see 7-245).

8 Enter M2N6802 in the Part text box.

9 Click Place & Close.

10 Move the part symbol to the desired location of M2 and click to place the part.

11 Right-click to stop placing parts.

If you want to clean-up your schematic, click each of the MOSFET device names (M2N6804 and M2N6802) and move them slightly so that the label does not overlap on one of the pins.

Drawing the voltage source and specifying the DC voltage attribute

1 Click the Get New Part button to display the Part Browser dialog box (see 7-245).

2 Enter VSRC in the Part text box.

3 Click Place & Close.

4 Move the symbol to the desired location and click to place it.

5 Right-click to stop placing parts.

Drawing the two analog ground symbols

1 Click the Get New Part button to display the Part Browser dialog box (see 7-245).

2 Enter AGND in the Part text box.

3 Click OK.

4 Move the symbol to the desired location and click to place it. Repeat for the second ground symbol.

5 Right-click to stop placing parts.
Drawing the wires

Click the Draw Wire button and draw wires to connect parts and symbols as shown in Figure 21.

Saving the file

Click the Save File button to save the schematic. You are not prompted for a file name because the schematic was named when you pushed into it from the top-level schematic.
Preparing Your Design for Simulation

Overview

This chapter provides guidelines for preparing your schematic for simulation and references further information contained in your PSpice user’s guide.

A design that is targeted for simulation will have:

- parts that there are simulation models available and configured for (Refer to Linking a Symbol to a Model or Subcircuit Definition in your PSpice user’s guide.)
- sources of stimulus to the circuit (Refer to Minimum circuit design requirements tables in the list of tables in your PSpice user’s guide.)

In this chapter you will find the following sections:

Creating Designs for Simulation and Board Layout on page 8-255.

Specifying Simulation Model Libraries on page 8-257.

Editing Simulation Models from PSpice Schematics on page 8-258.
Chapter 8    Preparing Your Design for Simulation

Editing Simulation Models from PSpice Schematics on page 8-258.
Adding and Defining Stimulus on page 8-259.
Starting the Simulator on page 8-266.
Viewing Results on page 8-267.
Creating Designs for Simulation and Board Layout

When creating designs for both simulation and printed circuit board layout, some of the parts you use will be for simulation only (for example, simulation stimulus parts like voltage sources), and some of the parts you use will have simulation models that only model some of the pins of the real device.

Those parts that are to be used for simulation, but not for board layout, will have a SIMULATIONONLY attribute. To see an example of this, double-click a VDC voltage source to bring up the Attribute Editing dialog box.

You can add this (or any) attributes to your own custom symbols.

Specifying Part Attributes

1. In the symbol editor, select Attributes from the Part menu to display the Attribute Editing dialog box.
2. Double-click the Name text box and type SIMULATIONONLY.
3. Click Save Attr.
4. Click OK.

For more information on defining attributes on part symbols, Refer to Defining Part Symbol Attributes in the Creating Symbols chapter of your PSpice user’s guide.
Handling Unmodeled Pins

Parts that have some pins that are not modeled, will appear broken when placed on the schematic. To see an example of this, place an instance of the PM-741 part from the “opamp.slb” symbol library. The OS1 and OS2 pins are not modeled, so only the +, -, V+, V-, and OUT pins are netlisted for simulation.

For the simulator, these pins appear as a large resistor connected to the ground.

Double-click the part to display the Attribute Editing dialog box. Note that the TEMPLATE attribute for the part only calls out the +, -, V+, V-, and OUT pins. The OS1 and OS2 pins are not called out in the TEMPLATE because those two pins are not modeled in the simulation model for the PM-741 part. You can view the simulation model definition for the PM-741 part from PSpice Schematics.

Viewing a simulation model for a part

1. Click the part to select it.
2. From the Edit menu, select Model.
3. Click Edit Instance Model (Text) to display the Schematics Model Editor and view an instance of the simulation model definition.
4. Click Cancel to exit the Model Editor without saving.
Specifying Simulation Model Libraries

Refer to the Creating Models chapter of your PSpice user’s guide for information about creating and configuring simulation model libraries. Each part that you intend to simulate must have a simulation model defined.

Checking if a part has a simulation model defined

Double-click the part on the schematic to display the Attribute Editing dialog box. If a simulation model is available for a part, the part will have:

- a TEMPLATE attribute specifying the PSpice simulation netlisting syntax for the part
- a MODEL attribute specifying the name of the model or subcircuit

The simulation model specified by the MODEL attribute must be contained in a model library that is configured.

Checking if a simulation model library is configured

Select Library and Include Files from the Analysis menu to bring up the Library and Include Files dialog box.

The set of simulation model libraries configured are listed in the Library Files area.

For information on configuring simulation model libraries, refer to Configuring the Library section in the Creating Models chapter in your PSpice user’s guide.
Editing Simulation Models from PSpice Schematics

You can define and edit simulation models directly from PSpice Schematics.

Models can be defined using the Parts utility or the text editor (sometimes called the Model Editor).

The Parts utility is useful for characterizing specific models from data sheet curves. The text editor is useful if model parameters are already defined (for example, models from a vendor) or if the model is not supported by the Parts utility.

Refer to the Using the Parts Utility and Using the Model Editor (Text Editor) sections of the Creating Models chapter in your PSpice user’s guide.
Adding and Defining Stimulus

The Stimulus Editor is a utility that enables you to set up and verify the input waveforms for a transient analysis. You can create and edit voltage sources, current sources, and digital stimuli for your circuit. Menu prompts guide you to provide the necessary parameters, such as the rise time, fall time, and period of an analog repeating pulse, or the complex timing relations with repeating segments of a digital stimulus. Graphical feedback enables you to verify the waveform.

Placing Stimulus Sources

Stimulus sources come from the source.slb symbol library and are one of:

- VSTIM—voltage stimulus source for transient analysis
- ISTIM - current stimulus source for transient analysis
- DIGSTIM - digital stimulus source

You can place any of these sources by typing the name of the source in the Get Recent Part list box on the toolbar. The AC and DC sources are VAC and VDC, and can be placed similarly.

1. Double-click in the Get Recent Part list box and type the name of the source.
2. Press Enter and click to place the source.
3. Right-click to stop placing sources.

Using the Stimulus Editor

For information on using the Stimulus Editor, refer to Stimulus Editor Utility in the Transient Analysis chapter in your PSpice user’s guide.
Setting Up Analyses

Refer to your PSpice user’s guide for information about setting up and running the many different analysis types supported by PSpice A/D.

Creating a Simulation Netlist

Overview

A netlist is the connectivity description of a circuit, showing all of the components, their interconnections, and their values. When you create a simulation netlist from Schematics, that netlist describes the current design.

For Release 9.2, you now have a choice between two types of netlist formats:

- a flat netlist
- a hierarchical netlist

The flat netlist is generated for all levels of hierarchy, starting from the top, regardless of whether you are pushed into any level of the hierarchy. Flat netlists are most commonly used as input to PCB layout tools. The flat simulation netlist format for PSpice contains device entries for all parts on a subcircuit (child) schematic multiple times, once for each instance of the hierarchical part or block used.

The hierarchical netlist preserves the hierarchical information in any subcircuit (child) schematics. It contains a single .SUBCKT definition for each child schematic. The devices in the subcircuit are therefore netlisted only once. Each instance of the hierarchical part or block is then netlisted as an instance of that subcircuit (as an “X” device). The subcircuit name corresponds to the name of the subcircuit (child) schematic.
Hierarchical netlists are especially useful to IC designers who want to perform Layout vs. Schematic (LVS) verification because they are more accurate descriptions of the true circuit.

**Using netlisting templates**

In Schematics, the template property specifies how primitive parts are described in the simulation netlist. A template defines the pin order and which other part property values to include in the netlist. In order to be included in the simulation, a part must have a template property. (The default template is TEMPLATE.) In the process of creating the netlist, buses, connectors, and so on, are resolved.

For Release 9.2, an alternate template option is now provided which allows you to define which netlisting template property to use. This option applies to both flat and hierarchical netlists. With this option, you may specify a particular netlist template for generating netlists that can be used by other simulation tools, for example, or for creating alternate PSpice netlists that contain different part descriptions.

To learn more about using alternate netlist templates, see **Specifying alternate netlist templates**.

**Passing parameters to subcircuits**

Hierarchical netlists have the advantage of allowing parameters to be passed from the top level schematic to any subcircuit schematics. To take advantage of this new feature in Release 9.2, you must use the new SUBPARAM part in the SPECIAL.OLB library.

To learn more about setting up parameterized subcircuits for hierarchical netlists, see **Using SUBPARAM**.
For Release 9.2, markers can now be placed on subcircuit nodes as well. This allows you to perform cross-probing between Schematics and PSpice at the lower level circuits of a hierarchical design.

**Note** If conditional constructs are used, the hierarchical netlist will create a unique subcircuit definition for each instance.

### Creating the netlist

You can generate a flat or hierarchical simulation netlist (.NET) by using the Create Netlist command from the Analysis menu. Or, you can create an LVS netlist (.LVS) by using the Create LVS Netlist from the Tools menu.

During the netlist process, Schematics creates several files with different extensions: the .NET file contains the netlist; the .CIR file contains simulation commands; and the .ALS file contains alias information.

### Creating a flat netlist

**To create a flat netlist**

1. In Schematics, from the Analysis menu, choose Create Netlist.

**Note** By default, the Netlist Format will be set to create a flat netlist. If you have changed the format setting previously in the Netlist Setting dialog box, the last setting you selected (either flat or hierarchical) will be saved with the schematic and continue to apply to that design until you change it again.

### Creating a hierarchical netlist

**To create a hierarchical netlist**

1. From the Options menu, choose Netlist Setting.
   
   The Netlist Setting dialog box appears.

2. Under the Netlist Format frame, click the Hierarchical radio button to enable it.
3 If you want the .PARAM commands to be made global in scope, check the Make .PARAM Commands Global checkbox. If this is disabled, the param symbols will be local to the subcircuit in which they occur.

4 Click OK.

Note To save the current settings and make them become the default settings for use later, click the Save as Default button.

Creating an LVS netlist {bmct NEW.BMP}

To create an LVS netlist

1 From the Tools menu, choose Create LVS Netlist.

Note The LVS netlist is, by definition, a hierarchical netlist. Therefore, it is not necessary to enable the Hierarchical format option in the Netlist Setting dialog box. The LVS netlist will be generated as a hierarchical netlist regardless of the format setting.
Note The LVS netlist is written in general syntax and should be compatible with most LVS tools. Depending on the tool you intend to use, however, you may need to modify the file in particular ways in order for it to be usable with your specific system.

Specifying alternate netlist templates

To specify an alternate netlist template

1. From the Options menu, choose Netlist Setting. The Netlist Setting dialog box appears.
2. Under the Netlist Format frame, click the Hierarchical radio button to enable it.
3. In the Use Template list box, select the name of the template you wish to use.

By default, the netlister will use the PSPICETEMPLATE. Alternate templates in the Use Template list box will be processed in the order in which they appear. The ordering of the templates is therefore important to the netlister and determines what the output will be.
Use the control buttons located directly above the Use Template list box to configure the list of templates. You can:

- add a new template by clicking the New icon or by double-clicking in the dashed box at the beginning of the list.
- delete a template by selecting the name and then clicking the Delete icon.
- edit a template name by selecting the name and then clicking the Edit icon.
- change the order of the listing (move a template up or down in the listing) by selecting the name and clicking the Up or Down arrows.

**Note** Templates are not specific to either a flat or hierarchical netlist. The same template may be used for both types.

**Using SUBPARAM**

You can pass parameters from the top-level schematic to a subcircuit schematic using the SUBPARAM part. This allows you to explicitly define the properties and default values to be used during netlisting and simulation.

To set up parameter passing to a subcircuit using SUBPARAM:

1. Make the subcircuit your active schematic page in the Schematics editor.
2. From the Draw menu, choose the Get New Part command.
   - If the Place Part command is grayed out, select Edit Schematic Definition from the Navigate menu to allow changes to be made to this lower level schematic page.
3. Select the part SUBPARAM from the PSpice library SPECIAL.SLB and place it on the subcircuit.
4 With the SUBPARAM part still selected, from the Edit menu, choose Attributes.

5 In the Attributes dialog box, define the names and default values for the attributes that can be changed on an instance-by-instance basis.

6 In the top-level schematic, use the Attributes dialog box to edit the attributes of the hierarchical part or block that references the subcircuit (child) schematic so they match the attributes you defined in Step 5.

Any part in the subcircuit (child) schematic can reference the attributes in its TEMPLATE. The PSpice subcircuit mechanism supports parameterizing:

- constants specified on device statements
- model parameters
- expressions consisting of constants
- parameters
- functions

### Starting the Simulator

You can start the simulator directly from PSpice Schematics by clicking on the Simulate button on the toolbar, or selecting Simulate from the Analysis menu.

For more information, refer to the Starting Simulation section of the Setting Up Analyses and Starting Simulation chapter in your PSpice user’s guide.
Viewing Results

You can use Probe to view and perform waveform analysis of the simulation results. For more information, refer to the Waveform Analysis chapter of your PSpice user’s guide.

Viewing Bias Point Results

After simulating, you can display bias point information on your schematic so that you can quickly zero in on problem areas of your design. PSpice A/D calculates and saves the bias point voltages and currents. By default, PSpice Schematics reads all of this information and displays voltages for every net in your schematic; currents on pins are not visible, but are available.

Note
For Release 9.2, power markers are now available which allow you to measure the power consumption of a particular device. You can use these markers in the same way you use current and voltage markers. Power markers are annotated with "W".

For more information, refer to the Viewing Results on the Schematic chapter in your PSpice user’s guide.

Viewing Results as You Simulate

You can configure Probe to run automatically when the simulation has finished, or to monitor waveforms as the simulation progresses.

These procedures are outlined in the What You Need to Know to Run Probe section of the Waveform Analysis chapter in your PSpice user’s guide.
Using Markers

You can place markers on your schematic to indicate the points in Probe where you want to see waveforms displayed.

Note  For Release 9.2, markers can now be placed on subcircuit nodes as well. This allows you to perform cross-probing between Schematics and PSpice at the lower level circuits of a hierarchical design.

For more information on markers, refer to the Schematic Markers section of the Waveform Analysis chapter in your PSpice user’s guide.
Configuring Probe Display of Simulation Results

To configure what Probe displays when it is started, select Probe Setup from the Analysis menu. You are given the following choices:

- **Restore Last Probe Session**—This restores the display characteristics from the last session of Probe.
- **Show All Markers**—This displays the waveforms at the points on the schematic that have been marked by markers.
- **Show Selected Markers**—This displays the waveforms only for those points on the schematic where the markers have been selected.
- **None**—This displays a blank Probe window, ready for you to select the traces that you want to add.
Using Design Journal

Overview

This chapter provides introductory information about the Design Journal.

In this chapter you will find the following sections:

- Understanding Design Journal on page 9-272 describes the purpose and different uses of Design Journal.
Understanding Design Journal

Design Journal is a very powerful analysis and tracking tool. With it you can:

- document stages of development
- perform what-if analysis on your current schematic, while preserving the integrity of the original
- compare the results of one or more what-if scenarios to the original schematic output, by simulating in PSpice A/D and viewing the results in Probe
- create a record of modifications (that you may or may not have implemented)
- capture the thought process of a design
- easily revert back to an earlier design stage

These functions are available to you as you create checkpoint schematics (a copy of the current state of the schematic you are working on). Each checkpoint schematic is stored in a separate subdirectory, within the directory of the working schematic. Checkpoint schematics are named Checkpoint.xxx, where xxx is a sequential number starting with 001.

Figure 22 depicts a working schematic and two checkpoint schematics. The first checkpoint schematic is a copy of the working schematic. The second checkpoint schematic represents a progressive stage of development.
Figure 22  A Working Schematic and Two Checkpoint Schematics

When documenting development stages and performing what-if analysis, you can:

- perform all PSpice Schematics, PSpice, and Probe operations on a checkpoint schematic
- create up to 999 checkpoint schematics
- restore a checkpoint schematic to a working schematic status

Restoring a checkpoint schematic removes its checkpoint status and makes it a normal .sch type schematic.

Design Journal Help

For a detailed explanation of how to use Design Journal and how it interacts with Probe, see PSpice Schematics Help.
Overview

This chapter describes how to prepare your design for use with a board layout program and has the following sections:

- Connectors on page 10-277 describes placing connectors to provide the interface between the PCB and the rest of the system. This section also describes how to create connector symbols.

- Packaging the Parts in Your Design on page 10-280 describes the process of collecting individual gates into physical packages and reassigning reference designators and gate names to reflect how they are packaged.

- Generating a Bill of Materials Report on page 10-286 describes how to generate a report listing the quantities of each component type used in the design, along with corresponding reference designators.

- Swapping Pins on page 10-291 describes how to swap pins on a given gate.
Interfacing to Board Layout Products on page 10-292 describes the procedures for using PSpice Schematics with the board layout products from other vendors.
Connectors provide the interface between a PCB and the rest of a system.

The distinction between connectors and ports on a schematic is important and is shown in Table 14. Off-page ports are not physical connectors, so you cannot use an off-page port as a connector or a connector as an off-page port. You may use them together if you want to have both connectivity and a physical part by attaching an off-page port to the pin of the connector.

Table 14  Distinctions Between Connectors and Ports

<table>
<thead>
<tr>
<th>Connectors</th>
<th>Ports</th>
</tr>
</thead>
<tbody>
<tr>
<td>define physical connection points on the PCB</td>
<td>define logical connection points on the schematic</td>
</tr>
<tr>
<td>are not included in layout netlists</td>
<td>are included in layout netlists</td>
</tr>
<tr>
<td>cannot be used to create connectivity on the schematic</td>
<td>are used to create connectivity on the schematic</td>
</tr>
</tbody>
</table>

During simulation, connectors are largely ignored except that you can attach a marker to a connector pin to view waveforms in Probe. You can also connect stimuli to connector pins to simulate the external interface to the circuit.

Placing Connectors

Connectors are added by placing connector symbols on the schematic. You can use the connector symbols shipped with PSpice Schematics (found in the connect.slb symbol library) or you can create your own using the symbol editor. (See Chapter 5, Using the Symbol Editor.)

There are two styles of connector symbols:

- those representing the entire connector
- those representing a single pin of a connector
Chapter 10  Preparing Your Design for Board Layout

Using Connector Symbols that Represent the Entire Connector

These symbols will have as many pins as the physical connector they represent. You can wire signals directly to the pins or connect labeled off-page (or global) ports to each pin. The label indicates the signal name that will be connected to the pin. Any off-page ports in the design with that same signal name will be connected to that connector pin.

Two connector symbols that represent an entire connector are DB25F-B and EDGE40M-B.

Using Connector Symbols that Represent One Pin of a Connector

In cases where a connector has a large number of pins, you may want to use a symbol that represents a single pin of the connector so you can attach connector pins to nets spread over multiple pages.

When an instance of such a connector symbol is placed on the schematic, it is assigned an arbitrary reference designator and gate. The reference designator indicates which physical connector instance the connector pin is part of (P1, for example), and the gate indicates which physical pin (such as, 1 or 2). Therefore, the entire connector is considered a multi-gate package with each gate having a single pin. All connector pin instances with the same reference designator are a part of the same physical connector.

Usually, you would assign the reference designator and gate manually. Otherwise, you could automatically package the pins, however, this will result in an arbitrary grouping of signals which is not usually desired. To change the reference designator, double-click the reference designator on the schematic. To change the pin number (gate), double-click the pin number.

Two connector symbols that represent single pins of a connector are DB25 and EDGE40.
Creating Single-Pin Connector Symbols

When creating a connector pin symbol, you must correctly define the connector package for the layout netlist to be correct. For example, in creating a 62-pin edge connector, instead of creating a single symbol for a 62-pin edge connector with all 62 pins, you can create a symbol of a single connector pin and attach to it `PKGREF` and `GATE` attributes (created and assigned when the symbol is placed). You would then assign the attribute values for each instance of the pin to make the correct pin assignment to the connector. Each pin in the connector is the equivalent of a single gate in a multi-gate package. Therefore, by assigning to each connector pin instance a specific combination of `PKGREF` and `GATE` attribute values, you can define the wiring of the connector in the layout.
Packaging the Parts in Your Design

Symbols used in PSpice Schematics represent either an individual gate of a packaged device, or a complete device. When a symbol representing a single gate is placed on a schematic, it is assigned a unique reference designator (if Auto-Naming is enabled), and by default, is made the first gate in the package. Packaging is the process of collecting these individual gates into physical packages and reassigning reference designators and gate names to reflect how they are packaged.

The packager uses the package definitions for devices that are in the package libraries. Package definitions contain information such as the number of gates, gate names, and pin number assignments. Package definitions are created and maintained using the symbol editor. See Specifying Part Packaging Information on page 6-201 for more information.

The packager assigns reference designators, gates, and package type attributes to parts on the schematic.

- The **PKGREF** attribute is the reference designator for the package.
- The **GATE** attribute contains the gate identifier, if any.
- The **PKGTYPE** attribute contains the name of the physical package (footprint) to be used (such as, DIP14, LCC20).
- The **REFDES** attribute is the reference designator normally displayed on the schematic. It is a combination of the **PKGREF** and **GATE** attributes.
  - For example, if **PKGREF**=U31 and **GATE**=a, the **PKGREF** will be U31a.
  - The **REFDES** attribute cannot be edited directly.
  - To change the **REFDES**, change either the **PKGREF** or the **GATE** attribute. The **REFDES** attribute will be automatically updated to reflect the change.
Pin numbers for devices with package definitions are determined from the package definition rather than from the symbol.

- Pin numbers are dependent on the gate (for multi-gate parts) and package type (for devices with alternative pin assignments based on package type).

  Until both GATE and PKGTYPE attributes are assigned values, no pin numbers are shown.

- For single gate packages with no gate name (for example, blank instead of A) no GATE attribute value is required.

- The pin number visibility and location information from the symbol is used to determine if and where the pin numbers from the package definition are to be shown on the schematic.

- If a device has no package definition, then the pin number information is determined by the symbol definition.

**Assigning Reference Designators Manually**

**Assigning reference designator**

1. Double-click the displayed reference designator to display the Edit Reference Designator dialog box.
2 Type a new value in the Package Reference Designator text box.

3 Click OK.

If you have other parts that you want to automatically package together, use the All Except User-Assigned option when you package the design.

**Automatically packaging at a later time**

1 From the Tools menu, select Package to display the Package dialog box.

2 In the Set Values for area, click the All Except User-Assigned option button.

Any manually assigned reference designator values and gates will be kept.

3 Click OK.
Assigning Reference Designators Automatically

Use the Package selection from the Tools menu to package individual parts into physical packages.

Packaging and assigning reference designators

1. From the Tools menu, select Package to display the Package dialog box (shown on 10-282).
2. In the Function area, click the Package and Assign Reference Designators Only button.
3. In the Set Values for area, click one of the three option buttons to specify which parts will have either reference designator or package information, or both assigned.
   a. Choose All Except User-Assigned to restrict the function to those attributes that you have not manually assigned.
   b. Choose Only Unpackaged to restrict the function to values for reference designator, gate, and package type attributes that have not been assigned.
   c. Choose All to give the function unrestricted access to all parts, overriding user-assigned attribute values.

If you want to change the package class priorities, see the procedure in the following section.

4. If you want to specify the number of the first reference designator to be assigned other than the default value of 1, type a value in the Starting Designator text box.
5. If you want to specify the amount to add to the starting designator between pages of the schematic, type a value in the Page Increment text box.
6. If you want to specify the amount to add to the starting designator between levels of hierarchy, type a value in the Level Increment text box.
7. Click OK.
Chapter 10  Preparing Your Design for Board Layout

Setting Package Class Priorities

Priorities can be set (for the packager) to use in determining which package type to assign when a part is available in more than one type. For example, you could specify that a DIP package type be used. If the part is not available in DIP, then it could assign SMT, and so forth.

This is done by grouping commonly used package types into classes. For example, all sizes of DIP packages (such as, DIP8 and DIP16) belong to the DIP class.

For each device to be assigned a package type, the packager will go through the package classes in the order listed, and assign the first package type defined for that device which belongs to that class. However, if only one package type is defined for the package, it will be used, whether it is in the list or not.

Setting up priorities

1  From the Tools menu, select Package to display the Package dialog box (shown on 10-282).  
2  Click Setup Priorities to display the Setup Package Class Priorities dialog box.

3  If you want to add a package class to the Class Priorities list, select a class from the Package Classes list and click Add.

   The package class is added to the end of the Class Priorities list.

4  If you want to delete a class priority, select a class from the Class Priorities list, then click Delete.

For details on adding package types and classes, see Configuring Package Types on page 6-212.
5 If you want to insert a class into the Class Priorities list, first select a class from the Package Classes list, then select an item in the Class Priorities list and click Insert.

The package class is added to the list before the item selected in the Class Priorities list.

6 Click OK.

7 In the Package dialog box, click OK.
Generating a Bill of Materials Report

A Bill of Materials report lists the quantities of each component type used in the design along with corresponding reference designators. You can also include information such as values for part instance attributes (VALUE and TOLERANCE) and user defined attributes contained in a component description file.

Figure 25 is an example of a Bill of Materials report. The only optional attribute chosen for display is the part instance VALUE attribute.

<table>
<thead>
<tr>
<th>Item</th>
<th>Count</th>
<th>Part Name</th>
<th>ATTRIBUTES</th>
<th>PinDesc</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>M123678</td>
<td>bip14</td>
<td>U1, U2</td>
</tr>
<tr>
<td>2</td>
<td>3</td>
<td>M234567</td>
<td>bip14</td>
<td>U1, U2, U3</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>M34567</td>
<td>bip14</td>
<td>U2, U3</td>
</tr>
<tr>
<td>4</td>
<td>0</td>
<td>M4567</td>
<td>bip20</td>
<td>U4, U5, U6, U7, U8, U9, U10, U11, U12</td>
</tr>
<tr>
<td>5</td>
<td>4</td>
<td>M56789</td>
<td>bip20</td>
<td>U1, U2, U3, U4</td>
</tr>
<tr>
<td>6</td>
<td>4</td>
<td>M67890</td>
<td>bip20</td>
<td>U5, U6, U7, U8, U9, U10, U11, U12</td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>M78901</td>
<td>bip14</td>
<td>U16</td>
</tr>
<tr>
<td>8</td>
<td>1</td>
<td>EDG987</td>
<td>EDG987</td>
<td>F1</td>
</tr>
<tr>
<td>9</td>
<td>1</td>
<td>R123</td>
<td>R123</td>
<td>F1</td>
</tr>
<tr>
<td>10</td>
<td>1</td>
<td>H123</td>
<td>H123</td>
<td>F1</td>
</tr>
</tbody>
</table>

Figure 25  Bill of Materials Report
Generating a Bill of Materials report

1. Select Reports from the File menu to display the Reports dialog box.

2. Click Display.

   The Bill of Materials dialog box appears and you can print, display, or save the report.

Closing the Reports dialog box

1. Click Close.

Printing and Saving the Report

Printing a Bill of Materials report

1. If not already in the Reports dialog box, select Reports from the File menu.

2. In the Reports dialog box, click Print.

Writing the Bill of Materials report to a file

1. If not already in the Reports dialog box, select Reports from the File menu.

2. In the Reports dialog box, click Save As to display a standard Save dialog box.
Customizing the Format of the Report

1. Click Setup to display the Report Setup dialog box.

2. In the Format text box, type the attributes to be displayed in the report according to the following syntax:

   \[ [\text{descriptive text}]@<\text{attribute name}> \]

   where the ‘@’ sign indicates \textit{value} substitution for the named attribute. Specify multiple attributes by using the preceding syntax in a comma-separated list. For example, you could specify that the part instance \textit{VALUE} attribute, and your own user defined attributes, \textit{COST} and \textit{ADDR}, be reported by typing the following into the Format text box:

   \[
   \text{value} = @\text{VALUE}, \text{cost} = @\text{COST}, \text{address} = @\text{ADDR}
   \]

3. In the Component Description File text box, enter the name of the component description file (.cdf) to be used.

4. Choose a Print Output format.

   Choose Text to format the Bill of Materials report in ASCII format with one entry per component type.

5. Click OK.
User Defined Component Information

You can display user-specific component information (such as, costs and in-house part numbers) in the Bill of Materials report. The Bill of Materials report will take a component description file as input.

The component description file (.cdf extension) is a user-created and maintained text file that contains component information such as cost, supplier name and in-house order numbers. To facilitate extraction of this information from an external component database, each file entry must be in comma-separated format, without spaces, as follows:

    <component name>,<footprint name>,
    <manufacturing ID>,<attribute name>,<attribute value>

When you specify more than one user-defined property for a given component type, you must give each entry identical <component name>, <footprint name> and <manufacturing ID> values. For example, two entries for the LM124 component might appear as:

    LM124,DIP14,LM124J-ND,COST,$4.05
    LM124,DIP14,LM124J-ND,SUPPLIER,National

Each PSpice Schematics software installation is shipped with a user.cdf file that you can edit to create a custom component description file.

Resistors and capacitors as a special case

When creating user defined attributes in the component description file, resistors and capacitors are a special case. Because different-valued resistors and capacitors (and other components with a value attribute) do not have unique manufacturing IDs, a VALUE entry must immediately precede the corresponding set of entries containing user-defined properties for a given device.
The COST entries for 10K and 1K resistors would appear in the component description file as follows:

- R,RC05,R1,VALUE,10K
- R,RC05,R1,COST,.05
- R,RC05,R2,VALUE,1K
- R,RC05,R2,COST,.03

**Specifying user-defined component attribute descriptions**

1. From the File menu, select Reports to display the Reports dialog box (shown on 10-287).
2. Click Setup to display the Report Setup dialog box (shown on 10-288).
3. In the Component Description File text box, enter the name of the user defined file that you want to use.
4. Click OK.
5. In the Reports dialog box, click OK.

**Exporting to a Spreadsheet or Database Program**

The report can be created in a database format so you can use the report in a spreadsheet program.

**Specifying the format of the Bill of Materials report**

1. From the File menu, select Reports to display the Reports dialog box (shown on 10-287).
2. Click Setup to display the Report Setup dialog box (shown on 10-288).
3. In the Print Output Format area, click Database. Select Database to format the Bill of Materials report with one attribute name or value pair per entry. This results in multiple entries for component types with multiple attributes.
4. Click OK.
5. In the Reports dialog box, click OK.
Swapping Pins

To swap pins on a given gate, add a SWAP attribute with the value of the pin names of the two pins to be swapped. For example:

\[
\text{SWAP=A B}
\]

will swap pin A with pin B.

Swapping pins

1. From the Edit menu, select Attributes to display the Attribute Editing dialog box.

2. In the Name text box, type SWAP.

3. In the Value text box, type A B.

4. Click Save Attr.

5. Click OK.

Note: A and B must be pin names, not pin numbers.
Interfacing to Board Layout Products

PSpice Schematics creates layout netlists in the formats shown in Table 15.

Table 15  Supported Layout Packages and File Formats

<table>
<thead>
<tr>
<th>Package</th>
<th>Layout Netlist</th>
<th>ECO File</th>
</tr>
</thead>
<tbody>
<tr>
<td>PADS</td>
<td>.pad</td>
<td>.eco</td>
</tr>
<tr>
<td>P-CAD</td>
<td>.alt</td>
<td>(none)</td>
</tr>
<tr>
<td>Protel</td>
<td>.pro</td>
<td>.eco</td>
</tr>
<tr>
<td>Tango</td>
<td>.tan</td>
<td>.eco</td>
</tr>
<tr>
<td>CADSTAR</td>
<td>.cdn</td>
<td>.rin</td>
</tr>
<tr>
<td>SCICARDS</td>
<td>.upl</td>
<td>.sif</td>
</tr>
<tr>
<td>EDIF 2 0 0</td>
<td>.edf</td>
<td>(none)</td>
</tr>
</tbody>
</table>

Selecting a layout format

1. From the Tools menu, select Configure Layout Editor to display the Configure Tools dialog box.

2. From the Layout Netlist list, Select a format. The layout netlist will be created with the name <schematic>.<netlist file name extension>.

3. Click OK.
Creating a Layout Netlist

1. From the Tools menu, select Create Layout Netlist.

Note: If you are using the OrCAD line of products, you will be preparing the netlist as input to OrCAD Layout. Although Schematics does not generate a netlist file (.MNL) that is directly compatible with Layout, you can create a netlist file that Layout will be able to process.

To create a netlist for OrCAD Layout

1. Follow the procedure above to select a layout format, and select the PADS format.
2. From the Tools menu, select Create Layout Netlist.
   The netlist will be created with the name <SCHEMATIC>.PAD.
3. Run OrCAD Layout.
4. In Layout, from the File menu, click Import, then choose PADS PCB as the type of netlist to be imported.
5. In the text box Input PADS ASCII file, browse the directories and select the PADS netlist file you created, <SCHEMATIC>.PAD.
6. In the text box Output Layout MAX file, enter the name of the new Layout netlist file you wish to create.
7. Click OK to start the translation process.
   Layout will then read the netlist file and convert it into the appropriate format that can be imported into the Layout Editor.

For more specific instructions on how to import a netlist file into Layout, see the OrCAD Layout User’s Guide.
Layout Mapping Files

When creating layout netlists, PSpice Schematics uses mapping files. These files let you customize the handling by the layout netlister of part, net, and package type names. Mapping files are text files that you can edit with any text editor. PSpice Schematics is shipped with mapping files containing defaults and sample entries.

Mapping files exist for each of the supported layout formats:

- `<layout format>.xmp`:
  Contains rules for creating entries in the parts list section of the netlist. If the part names used in PSpice Schematics are different than the names used in the layout package, you can specify the substitution to be done.

- `<layout format>.xnt`:
  Contains name mappings for nets. For example, in PSpice Schematics the default power net on some digital parts is named $G_DPWR, while in most layout systems it is +12V.

- `<layout format>.xpk`:
  Contains name mappings for package types. For example, in PSpice Schematics a package type is called TO33, and in the layout editor it is TO-33.
Common Syntax

Each file (.xmp, .xnt and .xpk) consists of a number of lines. Empty lines and those starting with the ‘#’ character are ignored. Otherwise, a line consists of one or more comma-separated identifiers followed by either an AKO specification or a replacement string.

An AKO (A Kind Of) specifier consists of the keyword AKO, followed by an identifier. PSpice Schematics looks up AKO definitions until it finds a definition that is not an AKO, then uses this new definition (circular AKO chains are not allowed).

The replacement string is processed further by PSpice Schematics and then becomes an entry for the part in the Partlist section of the layout netlist.

Examples:

DIODE
2N2220,2N2221,2N2222
1N914,1N915

The first example is a replacement string rule. This says that the string DIODE is to be replaced by the string DIODE,@PART. The second example shows how more than one identifier can reference the same replacement string. The third example shows an AKO specification. In this case, the string 1N914 references the DIODE rule. This is a replacement (that is, not another AKO), so the net result is that PSpice Schematics will replace 1N914 by DIODE,@PART.

A target identifier may end with the ‘*’ character to indicate a match with a pattern containing the same leading characters up to the ‘*’. For example, LCC* matches LCC20, LCC28, etc.

Rules are tested in the order found in the file. A default rule specified anywhere in the file will be used when no matching pattern is found. Rules can be empty (that is, a line may consist of a pattern or patterns, only).
Parts List Mapping (.xmp)

After PSpice Schematics has found a matching rule in the map file for the component or part attribute of a part, it further processes the replacement string. This processing is similar to the processing of the template attribute of a part when a simulation netlist is created. Identifiers in the string prefixed by one of the characters '@', '?', '~', '#', and ` are treated as part attribute names. A simple example would be a string such as @PART—this is replaced by the value of the PART attribute. An error occurs if the PART attribute is not defined.

When the ` (backquote) character precedes a '@', '?', '~', or `# character, it acts as a modifier. It causes the mapped value of an attribute (looked up in the .xpk file) to be used instead of the attribute value itself. For example,

`@PKG

would be replaced by the value of the PKG attribute, mapped by any matching rule in the .xpk file.

Examples

1 Capacitors

We need to be able to provide for a generic capacitor (where the designer has not provided any information beyond the capacitor’s value and possibly a tolerance), and also for a more specialized capacitor (where the designer supplies the exact package type as well as the component value and tolerance).

To support the simple case, a rule of the following form will be required in the .xpk file:

    CAP        CAP,@value?tolerance|,@tolerance |
    C          AKO        CAP

These rules will match a part with a component or part attribute with a value of CAP or C. They will produce entries in the Part list like:
C101     CAP, 10μF
or
C102     CAP, 10μF, 20%

depending on whether or not a TOLERANCE attribute has been specified. The VALUE attribute must be defined; PSpice Schematics will issue a message if a capacitor has no assigned value.

To support the case where the designer wishes to specify a particular capacitor type (for example, CAP\CR08\5G from the PADS library), the designer places an instance of a capacitor and then sets the COMPONENT attribute to CAP\CR08\5G.

The following rule in the .xpk file will support this:

```
CAP\* ?component | @component | | @part | ,
@value?tolerance | , @tolerance |
```

This tells PSpice Schematics to use the value of the COMPONENT attribute if that is set, or else to use the value of the PART attribute. This is followed by the value (required) and tolerance (optional).

Note: The general form of the rule will work for all similar types of capacitors such as CAP\CR20\3G, etc.

2 TTL Devices

In this case, a rule is needed that passes the COMPONENT or PART attribute (such as, 74LS04) through to the Part list, appending a package specifier for chip carrier devices. The .xmp rule will work:

```
74* ?component | @component | | @part | &`pkg_type
```

This outputs the value of COMPONENT or PART, then tests the PKG_TYPE attribute to see if it is defined. If so, its value is applied to the set of rules defined in the .xpk file. The translated value is then output.

Consider handling package types such as DIP14 and DIP16, LCC20, and LCC28. DIP packages and the Partlist item must have no suffix (in other words, a DIP version of a 74LS04 is just a 74LS04). The chip carrier packages must have the suffix -CC.
The following rules in the .xpk file will implement this:

\[
\begin{align*}
\text{DIP}^* & \\
\text{CC}^* & -\text{CC}
\end{align*}
\]

Note that the DIP* rule is empty; it matches package classes such as DIP14, but there is no resulting replacement string.

The LCC* rule matches all strings that start with LCC, so it will match package classes such as LCC20 and LCC28. It appends the string \(-\text{CC}\) to the COMPONENT (or PART) name.

### Back Annotation

During the course of layout generation, a design can undergo changes that make the design information in the PCB layout database inconsistent with that in the schematic database. When this occurs, the schematic must be back annotated with the design changes made during layout to resynchronize the schematic and layout data.

Design changes are usually documented as Engineering Change Orders (ECOs). Design changes from the layout to the schematic are called Backward ECOs because the direction of the change is opposite to the regular flow of design data.

PSpice Schematics supports the following types of backward ECOs:

- changing the reference designator of a part
- swapping two gates
- swapping two pins

If any of the other ECO operations are present, PSpice Schematics logs the warning and displays them as “Unsupported function” messages. You need to make the changes manually for any of the unsupported functions listed in the back annotation log. Back annotation messages are logged in the same manner as other PSpice Schematics errors and warnings.
Using back annotation

1. From the Tools menu, select Back Annotate to display the Back Annotate dialog box.

2. Type the name of the ECO file generated by the layout package in the ECO File Name text box.

3. Select an ECO file format from the ECO File Format list.

4. Click OK.

   In step 2, if you don’t know the file name, click Browse and select a file using the standard open file dialog box.

Note  

*PSpice Schematics does not support back annotation to Orcad Layout.*
Overview

This appendix provides information regarding exporting DXF files.

In this chapter you will find the following sections:

- Exporting DXF Files on page A-302.
- Exporting from the Schematic Editor on page A-303.
- Exporting in the Symbol Editor on page A-304.
Exporting DXF Files

The Export function generates Drawing Interchange Format (DXF) files. These files are also known as AutoCAD Format 2-D files. You can export the entire schematic drawing, a page, a portion of a page, or symbol graphics to a DXF file.
Exporting from the Schematic Editor

1. From the File menu, select Export to display the Export dialog box.

2. Select one of the following options:
   - Click Select All to export all pages of the schematic file.
   - Select one of the entries in the Pages dialog box to export a specific set of pages.
   - Select the Selected Area Only check box to export the currently highlighted selection in the schematic editing area.

3. Click OK to display the Export File Specification dialog box.

4. Specify the export file name and format, and click OK to begin exporting.

Note: The Selected Area Only option is only enabled if an area is selected in the drawing area before the Export menu command is chosen.

To select more than one page, hold down [Shift] while selecting other pages.
Exporting in the Symbol Editor

1. From the File menu, select Export to display the Export dialog box.

2. Select one of the following options:
   - Click Select All to export all symbols in the current symbol library.
   - Select any of the entries in the Symbols dialog box to export a specific set of symbols.
   - Select the Selected Area Only check box to export the currently highlighted selection in the symbol editing area.

3. Click OK to display the Export File Specification dialog box (shown on page A-303).

4. Enter the export file name and format, and click OK to begin exporting.
Library Expansion and Compression Utility

Overview

This Appendix explains the Library and Expansion Compression Utility that can be used with the PSpice Schematics libraries.

In this chapter you will find the following sections:

- Using the Library Utility on page B-306.
- Expanding Library Definitions into Text Files on page B-307.
- Compressing Definition Files into a Library on page B-307.
- Salvaging a Corrupted File on page B-308.
- Reorganizing a Library File on page B-308.
Using the Library Utility

PSpice Schematics includes a library utility (LXCWin) that works with the symbol, package, and footprint libraries. You can use LXCWin to:

- expand a library into definitions and create a list of those definitions (.lst file)
- compress definitions listed in the .lst file into a library
- salvage corrupted library files
- reorganize library files

To activate LXCWin

1. From the Windows Start menu, point to Programs, point to the Orcad program entry, and select LXCWin.
Expanding Library Definitions into Text Files

When you use LXCWin to expand a library, it reads the selected library line by line, and writes each definition of a symbol (.sym), package (.pkg), or footprint (.fpd) in plain ASCII format, to a text file. It also creates a .lst file, detailing the file name and the corresponding definition name.

To expand a library into individual definition files:

1. From the Action frame, select Expand.
2. Click the Process File button.
3. Select a library.

Compressing Definition Files into a Library

When you use LXCWin to compress definitions it reads the .lst file (a file of the same name as the library you selected), and packs each listed file into a selected library, in the order read. Thus, symbol, package, and footprint libraries can be built from files generated by another process.

To compress individual definition files into a library:

1. In the Action frame, select Compress.
2. Click the Process File button.
3. Specify a library.

The individual definition files are automatically removed.
Salvaging a Corrupted File

To salvage a corrupted file or one that has carriage returns and line feeds

1. In the Action frame, select Fix Index.
2. Click the Process File button.
3. Select a library.

Reorganizing a Library File

To reorganize a library file

1. Expand the library.
2. Edit the .lst file with a text editor to add, delete, or rearrange files.
3. Compress the library.

.lst File Format

<table>
<thead>
<tr>
<th>File Name</th>
<th>Definition Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>xxxx.sym</td>
<td>xxxx</td>
</tr>
</tbody>
</table>

Example:

7400.sym 7400
Running LXCWin Using Command Line Options

You can also run LXCWin using command line options.

The options are:

- \( -f \) Fix Index (default)
- \( -x \) Expand
- \( -c \) Compress
- \( -n \) Do not delete definition files
- \(<\text{libnames}>\) One or more library names; the names may include wildcards (*. ?)

Example:
LXCWin *.flb
Overview

This appendix contains information regarding advanced netlisting configuration.

In this chapter you will find the following sections:

- Specifying PSpice Node Name Netlisting Preferences on page C-312.
- Specifying Board Layout Node Name Netlisting Preferences on page C-313.
- Customizing EDIF Netlists on page C-314.
Specifying PSpice Node Name
Netlisting Preferences

By default, the PSpice netlister assigns names such as $N_001$ to nodes that are not explicitly labeled.

You can change the format that the netlister uses to create these names by using a text editor and editing the pspice.ini file in the Windows directory. Add a line to the [SCHEMATICS] section in the form:

\[
\text{nltemplate=prefix}\%[^{minimum\ width}]ld
\]

The default value is:

\[
\text{nltemplate=$N\%04ld}$
\]

The term ld must be in lowercase.

If [minimum width] begins with a zero, leading 0’s are added if the number of characters in the node number is less than the minimum width. For example, N%ld would create node numbers N1, N2, N3 instead of $N_001$, $N_002$, $N_003$. 
Specifying Board Layout Node Name Netlisting Preferences

To change any of these settings, use a text editor and edit the pspice.ini file in the Windows directory.

PCBHIERPATHSEP is the separator character to use when creating hierarchal net names in layout netlisting.

The PCBTEMPLATE item specifies the form that the layout netlister uses for creating node names.

The default value is:

PCBTEMPLATE=NN_%04ld
Customizing EDIF Netlists

You can change the amount each level in the netlist is indented by changing the `EDIFINDENT` item in the [SCHEMATICS] section of the `pspice.ini` initialization file. Use a text editor to edit the `pspice.ini` file in the Windows directory.

`EDIFINDENT` specifies the character to use to indent each level in an EDIF netlist.

The default is:

```
EDIFINDENT="" ""
```
Attribute List

Overview

This appendix is a list of attribute names used by PSpice Schematics and descriptions of each of those attributes. When you use the symbol editor to create a new symbol, the PART, MODEL, REFDES, and TEMPLATE attributes are
provided as a default set. You can provide any other attributes as needed.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>See Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>COMPONENT</td>
<td>The name of the package definition to be used for a part. If the name of the package definition is the same as the part name, then the COMPONENT attribute is not necessary.</td>
<td>2 5</td>
</tr>
<tr>
<td>GATE</td>
<td>The gate within the package that a particular part instance is assigned to. For example, if a part is one of four gates in a package (such as, A, B, C, D), this attribute specifies which gate the part is assigned to. Valid values for the GATE attribute (A, B, C, D in this example) are specified as part of the package definition for the part (given in the appropriate .plb Package Library file). Packages with only one gate do not require a gate name. This terminology applies not only to digital parts, but also to analog parts with multiple gates in a package. When a part is placed, the GATE attribute is assigned the value of the first gate defined for that part, or nothing at all if there is only one gate in the package. The value of the GATE attribute will be reassigned when the schematic is packaged. You can edit the value of the GATE attribute, to manually assign a gate, by selecting Attributes from the Edit menu or double-clicking the REFDES attribute. See REFDES below.</td>
<td>2 4</td>
</tr>
<tr>
<td>GATETYPE</td>
<td>The name of the gate type of a part. If a package contains more than one type of gate (for example, a package that contains an AND gate and a NOR gate), then there will be different symbols to represent each type. Each of these symbols must have a GATETYPE attribute, with a value that is used during packaging to identify the correct pin assignments within the package definition. For multi-part packages, the package definition will contain a set of pin assignments for each gate type. The identifiers used in the package definition for each gate type must match the GATETYPE attributes on the symbols.</td>
<td>2 5</td>
</tr>
</tbody>
</table>
Table 1  Reserved Attributes (continued)

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>See Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>MODEL</td>
<td>The name of the model referenced for simulation. This name must match the name of the .model or .subckt definition of the simulation model as it appears in the Model Library file (.lib). For example, if your design includes a 2N2222 bipolar transistor, with the .model name Q2N2222, then the MODEL attribute on the symbol for that part will be Q2N2222. This MODEL attribute can then be referenced in the TEMPLATE attribute for netlisting: &lt;br&gt; TEMPLATE=Q^@REFDES %c %b %e @MODEL &lt;br&gt; where REFDES=Q1 and MODEL=Q2N2222, could result in a netlist entry of Q1.Q2N2222.</td>
<td>1 3 5</td>
</tr>
<tr>
<td>PART</td>
<td>The name of the part that was retrieved from the Symbol Library and placed. When you use Get New Part, to select and place a part, the PART attribute reflects the name of the part that you selected. The value of this attribute will not change, for instance, when you change the MODEL attribute. You can always see what part you placed by referring to the value of this attribute, which is usually displayed on the schematic for all devices (for breakout devices, the MODEL attribute is the one visible on the schematic). The PART attribute is only changeable in the symbol editor.</td>
<td>1 2 5</td>
</tr>
<tr>
<td>PKGREF</td>
<td>The Package Reference Designator. If there are four gates in a package (such as, A, B, C, and D), then the PKGREF for all four parts would be the same (such as, U1) and the GATE attribute distinguishes them (such as, U1A, U1B, U1C, U1D). The PKGREF is the first component of the REFDES attribute. See REFDES below.</td>
<td>2 4</td>
</tr>
</tbody>
</table>
### Table 1  Reserved Attributes (continued)

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>See Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>PKGTYPE</td>
<td>The physical carrier type to be used for the part. (Examples: DIP14, LCC20, DIP8). If the package definition for the part has only one available package type defined, then the PKGTYPE attribute will be assigned this value. You can manually assign the package type by editing or creating this attribute, or you may have the PKGTYPE attribute assigned during packaging.</td>
<td>2 4</td>
</tr>
<tr>
<td>REFDES</td>
<td>The Reference Designator of a part. The value of the REFDES attribute is a combination of the Package Reference Designator (PKGREF) and the gate (GATE) attributes. For example, if your PKGREF is U1 and your GATE is A, then your REFDES will be U1A (and will appear as such on your schematic). The REFDES cannot be edited directly in the schematic editor. You must edit the PKGREF or the GATE, or both attributes instead. When you double-click the REFDES of a part within the schematic editor, the dialog that appears has two edit controls: one for the Package Reference Designator and one for the Gate.</td>
<td>1 2 3 4</td>
</tr>
<tr>
<td>SIMULATION-ONLY</td>
<td>The REFDES of a part is defined in the symbol editor. The default REFDES is U?. In the schematic editor, the ‘?’ portion of the REFDES is replaced by a number when the part is placed on the schematic, or when you select Annotate from the Tools menu. The number assigned gives each part instance a unique reference designator within a level of hierarchy.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If present, this attribute indicates that the part only has meaning for simulation. There will be a netlist entry for parts with this attribute, but no layout netlist entry. The SIMULATIONONLY attribute identifies parts such as voltage and current sources, breakout devices (found in breakout.slb) and special symbols (found in special.slb).</td>
<td>2 5</td>
</tr>
</tbody>
</table>
### Table 1  Reserved Attributes (continued)

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>See Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>TEMPLATE</td>
<td>The recipe for creating a netlist entry for simulation. The pin names specified in the TEMPLATE must match the pin names on the symbol. The number and order of the pins listed in the TEMPLATE must match those appropriate for the associated .model or .subckt definition referenced for simulation. The TEMPLATE attribute is only changeable in the symbol editor.</td>
<td>1 3 5</td>
</tr>
</tbody>
</table>

**Notes:**

1. These attributes are not changeable within the schematic editor. These are the attributes marked by an asterisk in the Edit Attributes dialog.
2. These attributes pertain to packaging and board layout.
3. These attributes pertain to PSpice.
4. These attributes are automatically provided by PSpice Schematics when a part is placed in the schematic editor.
5. These attributes must be provided by the user when creating or modifying a symbol in the symbol editor.

Symbol Libraries

Overview

This appendix contains the contents of the symbol libraries that are provided with PSpice Schematics.
Using Symbol Libraries

Symbols are stored in symbol libraries. The symbol library files have a .slb extension and contain graphical representations and attributes of parts.

The contents of the symbol libraries provided with PSpice Schematics are listed in Table 2.

Parts from libraries marked with † do not have corresponding simulation models.
### Table 2  Symbol Libraries

<table>
<thead>
<tr>
<th>Symbol Library File Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>7400.slb</td>
<td>7400-series TTL</td>
</tr>
<tr>
<td>74ac.slb</td>
<td>Advanced CMOS</td>
</tr>
<tr>
<td>74act.slb</td>
<td>TTL-compatible, Advanced CMOS</td>
</tr>
<tr>
<td>74als.slb</td>
<td>Advanced low-power Schottky TTL</td>
</tr>
<tr>
<td>74as.slb</td>
<td>Advanced Schottky TTL</td>
</tr>
<tr>
<td>74f.slb</td>
<td>FAST</td>
</tr>
<tr>
<td>74h.slb</td>
<td>High-speed TTL</td>
</tr>
<tr>
<td>74hc.slb</td>
<td>High-speed CMOS</td>
</tr>
<tr>
<td>74hct.slb</td>
<td>TTL-compatible, high-speed CMOS</td>
</tr>
<tr>
<td>74l.slb</td>
<td>Low-power TTL</td>
</tr>
<tr>
<td>74ls.slb</td>
<td>Low-power Schottky TTL</td>
</tr>
<tr>
<td>74s.slb</td>
<td>Schottky TTL</td>
</tr>
<tr>
<td>abm.slb</td>
<td>Behavioral modeling blocks</td>
</tr>
<tr>
<td>adv_lin.slb</td>
<td>Advanced Linear Devices: operational amplifiers</td>
</tr>
<tr>
<td>analog.slb</td>
<td>Passive and semiconductor primitives</td>
</tr>
<tr>
<td>analog_p.slb</td>
<td>Same devices as “analog.slb” with visible pin numbers for R, L, C, R_VAR and C_VAR devices</td>
</tr>
<tr>
<td>anl_misc.slb</td>
<td>Timers, three-phase transformer, relays, CMOS transistor array, variable impedance, variable admittance, time-dependent switches</td>
</tr>
<tr>
<td>anlg.slb†</td>
<td>Multiplexers, DAC, ADC, voltage-to-frequency converters</td>
</tr>
<tr>
<td>anlg1.slb†</td>
<td>DAC, ADC, sample-and-hold amplifiers</td>
</tr>
<tr>
<td>anlg2.slb†</td>
<td>Voltage references, voltage regulators, PWM, DAC, ADC, transceivers</td>
</tr>
<tr>
<td>Symbol Library File Name</td>
<td>Contents</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>anlg_dev.slb</td>
<td>Analog Devices Inc.: operational amplifiers, transistor arrays, buffers, voltage references, analog multipliers, analog switches</td>
</tr>
<tr>
<td>apex.slb</td>
<td>Apex Microtechnology Corporation: operational amplifiers</td>
</tr>
<tr>
<td>atmel.slb†</td>
<td>Atmel Corporation: EEPROM, PROM, SRAM, PLD</td>
</tr>
<tr>
<td>bipolar.slb</td>
<td>Bipolar transistors</td>
</tr>
<tr>
<td>breakout.slb</td>
<td>Parameterized devices for model purposes</td>
</tr>
<tr>
<td>broktree.slb†</td>
<td>Brooktree Corporation: DAC, delay lines, comparators</td>
</tr>
<tr>
<td>burr_brn.slb</td>
<td>Burr-Brown Corporation: operational amplifiers</td>
</tr>
<tr>
<td>cd4000.slb</td>
<td>CD4000 digital devices</td>
</tr>
<tr>
<td>chips.slb†</td>
<td>Chips and Technologies, Inc.: CPU</td>
</tr>
<tr>
<td>cmos.slb†</td>
<td>counters, shift registers, PLL, buffers, modulators, gates, adders, switches, multipliers, display drivers, timers, flip-flops, latches</td>
</tr>
<tr>
<td>comlinr.slb</td>
<td>Comlinear Corporation: operational amplifiers</td>
</tr>
<tr>
<td>connect.slb</td>
<td>Connectors</td>
</tr>
<tr>
<td>dallas.slb†</td>
<td>Dallas Semiconductor: delay lines, SRAM, transceivers, timers, FIFO, microcontrollers</td>
</tr>
<tr>
<td>dataconv.slb†</td>
<td>ADC, DAC</td>
</tr>
<tr>
<td>dig_ecl.slb</td>
<td>Emitter coupled logic devices</td>
</tr>
<tr>
<td>dig_gal.slb</td>
<td>Generic array logic devices</td>
</tr>
<tr>
<td>dig_misc.slb</td>
<td>Miscellaneous digital devices</td>
</tr>
<tr>
<td>Symbol Library File Name</td>
<td>Contents</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>dig_pal.slb</td>
<td>Programmable array logic devices</td>
</tr>
<tr>
<td>dig_prim.slb</td>
<td>Digital primitives for use with PLSyn as well as general simulation purposes</td>
</tr>
<tr>
<td>diode.slb</td>
<td>Diodes, Zener diodes, current regulator diodes, varactors</td>
</tr>
<tr>
<td>e bipolar.slb</td>
<td>European bipolar transistors</td>
</tr>
<tr>
<td>ecl.slb†</td>
<td>Motorola Corp., National Semiconductor Inc.: DRAM, gates, multiplexers, level translators, prescalers, error correction/detection</td>
</tr>
<tr>
<td>ediode.slb</td>
<td>European diodes and rectifiers</td>
</tr>
<tr>
<td>elantec.slb</td>
<td>Elantec Inc.: operational amplifiers, transistor arrays</td>
</tr>
<tr>
<td>epwrBJT.slb</td>
<td>European power bipolar transistors</td>
</tr>
<tr>
<td>exel.slb†</td>
<td>Exel Microelectronics Inc.: EEPROM</td>
</tr>
<tr>
<td>filtsub.slb</td>
<td>Filters</td>
</tr>
<tr>
<td>fujitsu.slb†</td>
<td>Fujitsu Limited: PROM, DRAM, SRAM, EEPROM</td>
</tr>
<tr>
<td>fwbell.slb</td>
<td>F.W. Bell: Hall effect devices</td>
</tr>
<tr>
<td>goldstar.slb†</td>
<td>Goldstar Semiconductor Group: ROM, DRAM, SRAM</td>
</tr>
<tr>
<td>har_dig.slb</td>
<td>Harris Semiconductor Corp.: PROM, microprocessors, VART, interface, transceivers, controllers, SRAM</td>
</tr>
<tr>
<td>harris.slb</td>
<td>Harris Semiconductor Corp.: operational amplifiers, MCT, bridge drivers, transistor arrays, power MOSFET</td>
</tr>
<tr>
<td>hughes.slb†</td>
<td>Hughes Microelectronic Center: display drivers, CPU, SRAM</td>
</tr>
</tbody>
</table>
Table 2  Symbol Libraries (continued)

<table>
<thead>
<tr>
<th>Symbol Library File Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>hyundai.slb†</td>
<td>Hyundai Electronic Inc. Ltd.: PLD, DRAM, SRAM</td>
</tr>
<tr>
<td>intel.slb†</td>
<td>Intel Corp.: EPROM, CPU, math co-processors, microcontrollers, SRAM, network processors</td>
</tr>
<tr>
<td>j bipolar.slb</td>
<td>Japanese bipolar transistors</td>
</tr>
<tr>
<td>jdiode.slb</td>
<td>Japanese diodes, rectifiers, Zener diodes, varactors, Schottky diodes</td>
</tr>
<tr>
<td>j fet.slb</td>
<td>Junction field-effect transistors</td>
</tr>
<tr>
<td>j fet.slb</td>
<td>Japanese junction field-effect transistors</td>
</tr>
<tr>
<td>jopamp.slb</td>
<td>Japanese operational amplifiers</td>
</tr>
<tr>
<td>jpwrbjt.slb</td>
<td>Japanese power bipolar transistors</td>
</tr>
<tr>
<td>jpwrmos.slb</td>
<td>Japanese power MOSFETs</td>
</tr>
<tr>
<td>lin tech.slb</td>
<td>Linear Technology Corporation: operational amplifiers</td>
</tr>
<tr>
<td>magnetic.slb</td>
<td>Magnetic cores, inductor coupling devices</td>
</tr>
<tr>
<td>marker.slb</td>
<td>Probe markers (this file is automatically accessed by PSpice Schematics and should not be included in the list of configured library files)</td>
</tr>
<tr>
<td>mcpwrsys.slb†</td>
<td>Micro Power Systems: ADC, DAC, data acquisition, voltage references</td>
</tr>
<tr>
<td>mcrn dram.slb†</td>
<td>Micron Semiconductor, Inc.: DRAM</td>
</tr>
<tr>
<td>mcrn ram2.slb†</td>
<td>Micron Semiconductor, Inc.: DRAM</td>
</tr>
<tr>
<td>mcrn sram.slb†</td>
<td>Micron Semiconductor, Inc.: SRAM</td>
</tr>
<tr>
<td>memory.slb†</td>
<td>EPROM, PROM, SRAM, PAL, DRAM, EEPROM</td>
</tr>
<tr>
<td>Symbol Library File Name</td>
<td>Contents</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>misc.slb</td>
<td>Timers, CMOS transistor arrays, variable admittance, variable impedance, three-phase transformers, relays, DC motor, time-dependent switches</td>
</tr>
<tr>
<td>mitmem.slb†</td>
<td>Mitsubishi Electric Corporation: EEPROM, PROM, DRAM, SRAM</td>
</tr>
<tr>
<td>mitram.slb†</td>
<td>Mitsubishi Electric Corporation: DRAM, SRAM</td>
</tr>
<tr>
<td>mitrom.slb†</td>
<td>Mitsubishi Electric Corporation: EPROM</td>
</tr>
<tr>
<td>mix_misc.slb</td>
<td>Timers, DC motors, relays</td>
</tr>
<tr>
<td>mosel.slb†</td>
<td>Mosel-Vitolic Inc.: SRAM, FIFO</td>
</tr>
<tr>
<td>moto.slb†</td>
<td>Motorola Corp.: CPU, microcontrollers</td>
</tr>
<tr>
<td>moto7.slb†</td>
<td>Motorola Corp.: SCR, triac</td>
</tr>
<tr>
<td>motoramp.slb</td>
<td>Motorola Corp.: operational amplifiers</td>
</tr>
<tr>
<td>motormos.slb</td>
<td>Motorola Corp.: power MOSFET</td>
</tr>
<tr>
<td>motor_rf.slb</td>
<td>Motorola Corp.: RF bipolar transistors</td>
</tr>
<tr>
<td>nat_semi.slb</td>
<td>National Semiconductor Inc.: operational amplifiers</td>
</tr>
<tr>
<td>nsclnapp.slb†</td>
<td>National Semiconductor Inc.: video sync generators, power drivers, level translators, display drivers, PLL, switches, noise reduction processors, power amplifiers, timers</td>
</tr>
<tr>
<td>nsdram.slb†</td>
<td>National Semiconductor Inc.: error detection/correction, DAC, memory controllers</td>
</tr>
<tr>
<td>nsnetwk.slb†</td>
<td>National Semiconductor Inc.: interface controllers, network interface</td>
</tr>
</tbody>
</table>
### Table 2: Symbol Libraries (continued)

<table>
<thead>
<tr>
<th>Symbol Library File Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>nsucont.slb†</td>
<td>National Semiconductor Inc.: microcontrollers</td>
</tr>
<tr>
<td>oki.slb†</td>
<td>OKI Semiconductor: display drivers, DRAM, EEPROM, EPROM, DRAM, SRAM, microcontrollers, clock, speech synthesis, recorders, CODEC, modems</td>
</tr>
<tr>
<td>opamp.slb</td>
<td>Operational amplifiers, voltage comparators, voltage regulators, voltage references</td>
</tr>
<tr>
<td>opto.slb</td>
<td>Opto couplers</td>
</tr>
<tr>
<td>pansonc.slb†</td>
<td>Panasonic Industrial Group: ROM, DRAM, SRAM, FIFO</td>
</tr>
<tr>
<td>polyfet.slb</td>
<td>PolyFet RF Devices: RF MOSFET</td>
</tr>
<tr>
<td>port.slb</td>
<td>Global ports, off-page ports, interface ports, ground symbols</td>
</tr>
<tr>
<td>pwrbbjt.slb</td>
<td>Power bipolar transistors</td>
</tr>
<tr>
<td>pwrmos.slb</td>
<td>Power MOSFET</td>
</tr>
<tr>
<td>seeq.slb†</td>
<td>Seeq Technology Inc.: data link controllers, Manchester code converters</td>
</tr>
<tr>
<td>sgsthom.slb†</td>
<td>SGS_Thompson Microelectronics: EPROM, SRAM, FIFO, EEPROM</td>
</tr>
<tr>
<td>sipex.slb†</td>
<td>Sipex Corporation: ADC, DAC, voltage references, sample-and-hold amplifiers, data acquisition</td>
</tr>
<tr>
<td>smos.slb†</td>
<td>S-MOS Systems: DC/DC converters, voltage regulators, display drivers, SRAM</td>
</tr>
<tr>
<td>sony.slb†</td>
<td>Sony Corporation: ADC, gates, ALU, multiplexers, SRAM</td>
</tr>
<tr>
<td>source.slb</td>
<td>Voltage and current stimulus devices</td>
</tr>
<tr>
<td>special.slb</td>
<td>Simulation pseudocomponents (IC, NODESET, etc.)</td>
</tr>
</tbody>
</table>
Table 2  Symbol Libraries (continued)

<table>
<thead>
<tr>
<th>Symbol Library File Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>swit_rav.slb</td>
<td>Averaged switched-mode power supply blocks</td>
</tr>
<tr>
<td>swit_reg.slb</td>
<td>Switched-mode regulators</td>
</tr>
<tr>
<td>tex_inst.slb</td>
<td>Texas Instruments Inc.: operational amplifier, voltage comparators</td>
</tr>
<tr>
<td>thyristr.slb</td>
<td>SCR, triac, UJT</td>
</tr>
<tr>
<td>ti1.slb†</td>
<td>Texas Instruments Inc.: line drivers, transceivers, display drivers, ADC, switches</td>
</tr>
<tr>
<td>ti2.slb†</td>
<td>Texas Instruments Inc.: SRAM, EPROM, DRAM, PROM, memory controllers</td>
</tr>
<tr>
<td>tilsi.slb†</td>
<td>Texas Instruments Inc.: FIFO, error detection/correction, multipliers, pipeline registers, flip-flops, bus transceivers, memory controllers</td>
</tr>
<tr>
<td>tline.slb</td>
<td>Transmission lines</td>
</tr>
<tr>
<td>ttl.slb†</td>
<td>Multiplexers, counters, flip-flops, bus transceivers, gates, monostable multivibrators, encoders, FIFO, buffers, adders, decoders</td>
</tr>
<tr>
<td>vlsitec.slb†</td>
<td>VLSI Technology Inc.: ALU, UART, memory controllers, CPU, display drivers</td>
</tr>
<tr>
<td>weitek.slb†</td>
<td>Weitek Corp.: math co-processors</td>
</tr>
<tr>
<td>wsi.slb†</td>
<td>WaferScale Integration Inc.: PROM, EEPROM, CPU, multipliers</td>
</tr>
<tr>
<td>Xc2000p.slb</td>
<td>Xilinx: FPGAs 2000 Family</td>
</tr>
<tr>
<td>Xc 3000p.slb</td>
<td>Xilinx: FPGAs 3000 Family</td>
</tr>
<tr>
<td>Xc4000p.slb</td>
<td>Xilinx: FPGAs 4000 Family</td>
</tr>
<tr>
<td>Xc4000ep.slb</td>
<td>Xilinx: FPGAs 4000e Family</td>
</tr>
<tr>
<td>Xc5200p.slb</td>
<td>Xilinx: FPGAs 5200 Family</td>
</tr>
<tr>
<td>Symbol Library File Name</td>
<td>Contents</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>xicor.slb†</td>
<td>XICOR Inc.: SRAM, EEPROM, potentiometers</td>
</tr>
<tr>
<td>xtal.slb</td>
<td>Quartz crystals</td>
</tr>
<tr>
<td>zilog.slb†</td>
<td>Zilog Inc.: I/O controllers, CPU, counters</td>
</tr>
</tbody>
</table>
Glossary

ABM  Analog behavioral model. A view of a hierarchical schematic used for analysis. See also View.

AKO  “A Kind Of” symbol. Symbols must either contain graphics or refer to an AKO symbol. The AKO defines the symbol in terms of the graphics and pins of another part. Both must exist in the same symbol library file.

alias  An exact electrical equivalent that can be used to reference a symbol.

annotation  A means by which parts are labeled when they are placed, either automatically or manually.

annotation symbols  A symbol with no electrical significance, used to clarify, point out or define items on the schematic.

attribute  Special characteristics (a name and an associated value) contained in a part instance or definition. For example, a MOSFET may contain specific length and width parameters that are represented as attributes on the symbol or part. Attributes may be changed through the schematic editor, the symbol editor, or both.

back annotation  Annotation of a schematic using an ECO file from the selected layout editor.

block  A user defined rectangle placed on a schematic. It is used to represent or hold the place for a collection of circuitry. The block is treated as a black box by PSpice Schematics. PSpice Schematics is aware of the connections going into and out of the block, but ignores the contents of the block until netlisting.
bounding box | A rectangular dotted line containing the graphics for a symbol and all visible pin connection points. In terms of the schematic editor, the position of the bounding box determines whether a point falls on a part when selecting parts, or whether it falls on the pin of a part when checking for electrical connections. Box defines the selection area of the symbol when placed on a schematic.

bundle | A collection of named wires or buses of the same type or purpose.

bus | A collection of homogeneously named signals.

circuit | A configuration of electrically connected components or devices.

connector | A physical device that is used for external connections to a circuit board. A connector has no electrical significance until it is connected on a PCB.

current sensor | Displays the bias point current flow in a given direction.

design | A schematic drawing or set of drawings representing a circuit or PCB.

display map | A portion of the initialization file that specifies which schematic items are turned on and off for display and printing.

ECO | Engineering change order. A design change usually requiring back annotation of the schematic.

ERC | Electrical rules check, a process performed before generating a netlist or running the simulator. The ERC performs a preliminary connectivity check on the schematic. If the schematic is part of a hierarchical design, the check is performed only for the current hierarchical level.

fileset | The set of files required to perform a certain function.

flat schematic | A flat, single-level schematic containing only primitive symbols from the component libraries. A flat schematic can be either single or multiple page.

gate | A subset of a package, and corresponds to a part instance.

global editing | Editing of a symbol, attribute or attribute value, saved in a library, and applied to all designs using that particular symbol.
**global port**
Provides a connection to another global port of the same name anywhere in the schematic.

**gravity**
The property of a drawing object to snap to the nearest grid or pin when being placed on a drawing or moved about a drawing.

**gravity radius**
The distance between the cursor and an object on the schematic in which the object can be selected.

**grid**
A pattern of horizontal and vertical lines that aid in placing objects on a schematic or symbol drawing.

**hidden pins**
Pins that are not connected by wires and buses, but through an attribute that names the net that they belong to.

**hierarchical design**
A design of more than one level wherein a portion of the design (lower-level schematic) is represented by a block or symbol on a higher-level schematic.

**hotspot**
The point at the end of a pin that forms a junction when it intersects with a wire or bus segment.

**instance name**
A unique name for a part instance.

**interface port**
A port providing connectivity to the pins of hierarchical symbols or blocks.

**junction**
A graphical indication that wires, buses, and pins are electrically connected.

**marker**
Notations placed on a schematic to identify locations for observing voltage, current or digital signal levels, or waveform behavior when the circuit is analyzed.

**message**
A character string generated by an application, describing some kind of condition, status or other information, and displayed by the Message Viewer.

**model definition**
An underlying description of the electrical behavior of a part using a set of variable parameters. Used by PSpice.

**pspice.ini file**
The initialization file, usually contained in the Windows directory, containing start-up and configuration information for PSpice and PSpice Schematics.
**Navigation**
The process of moving between pages in a multi-sheet schematic, or between levels in a hierarchical design.

**Net**
A set of electrically connected part pins. A net may be *anonymous* or *named*. An anonymous net might be the junction of two resistors. A named net could be a wire labeled **CLOCK** connecting two digital parts.

**Netlist**
A list providing the circuit definition and connectivity information in simulation netlist format.

**Nodeset**
A symbol containing one or two pins, permitting you to initialize a node voltage for simulation.

**Off-page port**
A port connecting pages of a schematic. Off-page ports may or may not contain a **LABEL** attribute.

**Origin**
The point on a symbol designated for placing a part. When a symbol is rotated on the schematic, it is rotated about this point.

**Package**
A physical device consisting of one or more gates.

**Package library definition**
The use of a mathematical model to represent the physical operation of a circuit design.

**Package type**
An attribute specifying the type of physical package that the actual circuit board will use. For example, DIP14, chip carrier, surface mount.

**Package type class**
An attribute specifying grouping of similar package types. For example, DIP would be the class for all sizes of dip package types (DIP14, for example).

**Page**
One sheet of a multiple-sheet schematic. A page may contain both parts (represented by symbols), port instances, connectors, and annotation symbols. A page may or may not have a title. Each schematic page represents a single page of a circuit design.

**Part**
An electrical component that is represented by a schematic symbol. A part refers to the logical rather than the physical component.

**Part description**
Describes the symbol in terms of its symbol type, such as **2-input NAND**.

**Part instance**
Refers to an occurrence of a symbol in a schematic.
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>part outline</td>
<td>Consists of the symbol for a part (graphics and pins), minus any text.</td>
</tr>
<tr>
<td>pin</td>
<td>Contained in parts, ports and off-page connectors. Parts can contain multiple pins. Each part contains specific pin names associated with the part. Pins may connect to a wire, a bus or another pin.</td>
</tr>
<tr>
<td>pin definition</td>
<td>Provides the pin number, the location of each pin relative to the symbol origin and the electrical attributes of the pin.</td>
</tr>
<tr>
<td>pin name</td>
<td>A name that uniquely identifies the pin on a part.</td>
</tr>
<tr>
<td>pin number</td>
<td>The physical device pin number.</td>
</tr>
<tr>
<td>pin-to-pin spacing</td>
<td>Determines the size of the symbols as they appear on the printed page. The distance between pins is set during the initial installation, but may be changed.</td>
</tr>
<tr>
<td>port</td>
<td>Provides connectivity across schematic pages. A port provides the anchor for a single pin. Ports are chosen from library files, placed, moved, and deleted in the same way as are parts. Ports may have multiple connections. Ports consist of three types: global, interface, and off-page (defined in this Appendix).</td>
</tr>
<tr>
<td>primitive symbol</td>
<td>A symbol that is an individual component for a specific netlister. That is, it is completely specified electrically for the purpose it is required to perform.</td>
</tr>
<tr>
<td>reference designator</td>
<td>An attribute used as a unique name on a given schematic level. For example, a resistor with the reference designator “R5,” would indicate that it is the 5th instance of the resistor (R) on a particular schematic. For package parts, it consists of concatenation of the package’s reference designator followed by the gate name assigned to the part. The reference designator is used as a base for the simulation netlist. Reference designators can be either automatically or manually assigned. Reference designators represent a unique name used to reference a physical device. Parts with the same reference designator are packaged into the same physical device.</td>
</tr>
<tr>
<td>schematic</td>
<td>A drawing consisting of the following components: one or more pages, a set of symbols representing local part definitions, or parts in a library file and text.</td>
</tr>
</tbody>
</table>
**selection area**
When drawing or editing a schematic or symbol, the area identified and enclosed by a region-of-interest (ROI) box for the purpose of performing some operation on the objects within the area.

**setpoint**
A special symbol used to specify initial node voltages during simulation.

**simulation**
The use of a mathematical model to represent the physical operation of a circuit design.

**stimulus**
Symbols placed on a schematic to identify digital and analog voltage and signal sources used during simulation.

**symbol**
Consists of the graphical representation of a logical or physical electronic part on the schematic. A symbol may have one or more associated attributes.

**symbol definition**
Consists of the data from which the netlist is generated. A symbol or part definition consists of the following: the part name and any aliases, its attributes, primitive definition (also called the circuit definition), and pin definitions.

**symbolize**
Creating a symbol to represent a schematic.

**translator**
(1) Another name for a netlister
(2) The process of reading a schematic created by another design program and converting it to a PSpice Schematics file.

**view**
A mechanism for allowing hierarchical symbols to have more than one underlying representation, for example, defining a flip-flop to have a transistor view or a gate view.

**viewpoint**
A special symbol used to display bias point voltages and currents during simulation.

**voltage viewpoint**
Displays the bias point voltage at a pin. Any pin on part or a port may have a viewpoint attached.

**wire**
A graphical indication of a connection between pins, buses and other wires.
Index

A
a kind of, See AKO
ABM, 331
accessing symbols, 188
Add Text dialog box, 127
adding
  annotation graphics, 130
  annotation text, 126
  attributes, 90
  library, 44
  multiple line text, 126
  non-electrical information, 126
  package type, 212
  package type for a component, 204
  page to design, 136
  pins to a symbol, 180
  stimulus, 259
  symbol alias, 200
  text to schematic, 127
  text to symbol, 180
  wire segment, 104
Additional Info dialog box, 76
advanced netlisting configuration items, 311
AKO
  creating, 177
definition of, 331
specifier, 295
symbols, 175
alias
definition of, 331
using, 200
analog behavioral model, See ABM
Analysis Setup button, 36
annotation
  back, 89, 298, 331
  definition of, 331
  page border, 30
  symbols, 30, 134
  title block, 30
annotation graphics
  adding, 130
  importing, 133, 181
  resizing, 131
Annotation Graphics toolbar, 38
annotation symbols
  creating, 134
  definition of, 331
  non-electrical information, 134
annotation text
  adding, 126
App Settings dialog box, 64, 66
arc, drawing, 178
archive, 24
assigning
  annotation, 89
  attribute names, 315
  attribute value, 93
  instance-specific part values, 241
  pin numbers, 208
  pins, 201, 206
  reference designator, 14, 97, 228, 281
attribute
  definition of, 331
  deleting, 90
  editing, 88
  enabling display, 91
  global editing, 93
  intrinsic property, 88
  list, 315
  non-changeable, 89
  selecting, 116
  simulation, 255
  SWAP, 291
  system defined, 89
  text, 158
  value, 30, 88
  view, 237
Attribute Editing dialog box, 88
attribute text
  changing, 158
attribute values
  multiple parts, 93
attributes
  adding, 90
  changing display, 90
  display choices, 91
  part instance display characteristics, 91
Attributes dialog box, 160, 210
auto-fit, 141, 167
automatic panning, 71
automatically
  assigning reference designators, 283
  labeling buses, 108
  labeling wires, 108
auto-naming, 13, 97–98, 108
Auto-Naming dialog box, 13, 97
auto-repeat, 9, 95, 98, 120, 190
Auto-Repeat dialog box, 95
autosave interval, 58
B
Back Annotate dialog box, 299
back annotation, 89, 298
  definition of, 331
base symbol, 175
Bbox, 196
behavioral model, 237
bill-of-materials report
  customizing, 288
  exporting, 290
  generating, 286
  printing, 287
bitmaps
  importing, 133, 181
block
  definition of, 331
  drawing, 35
See also hierarchical block
Block View dialog box, 232
board layout, preparing design for, 275
border style
  changing, 52
  outline, 53
  setting, 50
  zoned, 53
bounding box, 196
  definition of, 332
box, drawing, 178
browse
  attributes, 93
  library, 8, 16, 84
  part, 8, 16, 82
browsing
  symbol libraries, 84
bundle
  definition of, 332
bus
  definition of, 332
  drawing, 12, 35, 106–107
  labeling, 12, 106–108
  orthogonal, 109
  placing, 98
  selecting, 116
  splitting, 107
bus label
  editing, 107
buttons
  Draw Wire, 247
CADSTAR layout format, 292
Change Attribute dialog box, 91, 158
Change Pin dialog box, 160, 192, 231, 247
Change Text dialog box, 161, 181
changing
   a placed pin type, 192
   application settings, 64
   attribute text, 158
   attribute value, 93
   border style, 52
   bounding box size, 196
   custom libraries, 94
   default value, 94
   display characteristics of attributes, 91
   drawing area, 54
   free-standing text, 161
   graphics properties, 131–132
   gravity, 55
   grid, 55
   hierarchical block reference designator, 229
   library search order, 47
   page title, 122
   part values, 14
   pin name text, 160
   pin names on blocks, 247
   pin number text, 160
   pin numbers, 192
   reference designators, 14
   search path, 48
   text characteristics, 158
   text properties, 128–129
   value of attribute, 88
changing properties
   on instance basis, 128, 131
checking
   library configuration, 7
   part has simulation model defined, 257
checklist, simulation, 80
circle, drawing, 179
circuit
   definition of, 332
clipboard
   copying to, 121
   pasting from, 121
closing
   Message Viewer, 76
   schematic editor, 146
   single schematic, 146
symbol editor, 152
color
   configuration, 63
components
   aspects of, 149
   description file, 289
   multi-gate, 207
   multiple gate types, 210
   of design, 29
   with more than one symbol, 210
Configure Tools dialog box, 292
configured package types list, 205
configuring
   application settings, 64
   autosave interval, 58
   colors, 63
   custom libraries, 214
   display, 60
   fonts, 62
   library, 42
   MicroSim Schematics, 41
   msim.ini file, 65
   netlist, 311
   package types, 212
   page settings, 50
   select recent part list size, 67
   simulation library, 257
   symbol libraries, 7, 42
Configuring Package Types
   dialog box, 212
connecting
   inter-page signals, 137
   schematic pages, 30
   wire to a bus, 105
   wires to bus, 12, 107
connections, 31, 106
connectivity
   implicit, 237
   in multi-sheet designs, 136
   orthogonal, 109
   rubberbanding, 111
   rules, 106
connector
   definition of, 332
   placing, 277
   symbol, 279
controlling display, 60
Copy Package Definition dialog box, 203
Copy Page dialog box, 137
Copy Part dialog box, 94, 173
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>copying</td>
<td>138</td>
</tr>
<tr>
<td>between pages</td>
<td></td>
</tr>
<tr>
<td>default</td>
<td></td>
</tr>
<tr>
<td>pin type</td>
<td>180</td>
</tr>
<tr>
<td>pin types</td>
<td>191</td>
</tr>
<tr>
<td>symbol attribute</td>
<td>94</td>
</tr>
<tr>
<td>view</td>
<td>237</td>
</tr>
<tr>
<td>defining</td>
<td></td>
</tr>
<tr>
<td>connector package</td>
<td>279</td>
</tr>
<tr>
<td>gate names</td>
<td></td>
</tr>
<tr>
<td>hidden power and ground pins</td>
<td>194</td>
</tr>
<tr>
<td>number of gates</td>
<td>207</td>
</tr>
<tr>
<td>pin number assignments</td>
<td>208</td>
</tr>
<tr>
<td>pin types</td>
<td>191</td>
</tr>
<tr>
<td>shared power and ground pins</td>
<td>208</td>
</tr>
<tr>
<td>stimulus</td>
<td>259</td>
</tr>
<tr>
<td>definition</td>
<td></td>
</tr>
<tr>
<td>AKO</td>
<td>295</td>
</tr>
<tr>
<td>model</td>
<td>80</td>
</tr>
<tr>
<td>package</td>
<td></td>
</tr>
<tr>
<td>80, 280</td>
<td></td>
</tr>
<tr>
<td>Definition dialog box</td>
<td>200</td>
</tr>
<tr>
<td>Delete Page dialog box</td>
<td>139</td>
</tr>
<tr>
<td>deleting</td>
<td></td>
</tr>
<tr>
<td>attributes</td>
<td>90</td>
</tr>
<tr>
<td>package definition</td>
<td>211</td>
</tr>
<tr>
<td>page</td>
<td>139</td>
</tr>
<tr>
<td>pin on hierarchical block</td>
<td>231</td>
</tr>
<tr>
<td>selected object</td>
<td></td>
</tr>
<tr>
<td>120, 190</td>
<td></td>
</tr>
<tr>
<td>de-selecting</td>
<td></td>
</tr>
<tr>
<td>selected objects</td>
<td>117</td>
</tr>
<tr>
<td>design</td>
<td></td>
</tr>
<tr>
<td>components of</td>
<td>29</td>
</tr>
<tr>
<td>creating</td>
<td></td>
</tr>
<tr>
<td>definition of</td>
<td>332</td>
</tr>
<tr>
<td>editing</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
</tr>
<tr>
<td>hierarchical</td>
<td></td>
</tr>
<tr>
<td>227, 333</td>
<td></td>
</tr>
<tr>
<td>methods</td>
<td>227</td>
</tr>
<tr>
<td>multi-sheet</td>
<td></td>
</tr>
<tr>
<td>136</td>
<td></td>
</tr>
<tr>
<td>packaging parts in</td>
<td></td>
</tr>
<tr>
<td>280</td>
<td></td>
</tr>
<tr>
<td>printing</td>
<td>140</td>
</tr>
<tr>
<td>starting new</td>
<td>6</td>
</tr>
<tr>
<td>Design Manager</td>
<td>19</td>
</tr>
<tr>
<td>dialog boxes</td>
<td></td>
</tr>
<tr>
<td>Add Text</td>
<td>127</td>
</tr>
<tr>
<td>Additional Info</td>
<td>76</td>
</tr>
<tr>
<td>App Settings</td>
<td>64, 66</td>
</tr>
<tr>
<td>Attribute Editing</td>
<td>88</td>
</tr>
<tr>
<td>Attributes</td>
<td>160, 210</td>
</tr>
<tr>
<td>Auto-Naming</td>
<td>13, 97</td>
</tr>
<tr>
<td>Auto-Repeat</td>
<td>95</td>
</tr>
</tbody>
</table>
Index

Back Annotate, 299
Block View, 232
Change Attribute, 91, 158
Change Pin, 160, 192, 231, 247
Change Text, 161, 181
Configure Tools, 292
Configuring Package Types, 212
Copy Package Definition, 203
Copy Page, 137
Copy Part, 94, 173
Create Page, 136
Definition, 200
Delete Page, 139
Display Options, 56–57, 110, 154, 162
Display Preferences, 62
Edit Attributes, 135, 291
Edit Gate Types, 207
Edit Package Definition, 202
Edit Package Types, 205
Edit Reference, 245
Edit Reference Designator, 14, 229, 281
Editor Configuration, 44, 214
Export file specification, 303
Export Parts, 174
Find, 118
Font, 62
Get Package Definition, 204
Global Edit Attributes, 93
Graphics Properties, 183
Import, 174
Import OrCAD File, 303
Library Browser, 8, 84, 115
Library Settings, 44, 214
Package, 282
Package Definition, 202
Page Info, 122
Page Settings, 54
Page Size, 49
Pan & Zoom, 69, 71
Part Browser, 8–9, 16, 82, 245
Pin Assignments, 206
Pin Swaps, 209
Pin Type, 191
Place Text, 180
Print, 140, 167
Remove Package Definition, 211
Replace Part, 100
Report Setup, 288
Reports, 287
Schematics Export, 303
Select Page, 138
Set Attribute Value, 11, 105, 242
Set Up Block, 248
Set Up Block dialog box, 229
Setup Package Class Priorities, 284
Shared Pin Assignments, 208
Symbol Wizard, 172
Symbols Export, 304
Toolbars, 33
Translators, 238
Where, 240
digital stimulus source, 259
disabling
auto-repeat, 96
grid display, 162
snap-to-pin, 57, 110, 163
stay-on-grid, 56, 162
toolbar display, 33, 154
display map
definition of, 332
display options
grid on, 55, 162
grid spacing, 111
rubberbanding, 111
text grid, 165
Display Options dialog box, 56–57, 110, 154, 162
display preferences, 60, 62–63
changing graphics properties, 132
changing text properties, 129
Display Preferences dialog box, 62
displaying
pin names, 193
pin numbers, 193
toolbars, 33
distinction between connectors and ports, 277
dockable toolbars, 33
Draw Arc button, 38, 154, 178
Draw Block button, 35, 228
Draw Bus button, 12, 35, 98
Draw Circle button, 38, 155, 179
Draw Polyline button, 38, 155, 179
Draw Text Box button, 38
Draw Text button, 38, 127, 155, 180
Draw Wire button, 35
Draw Wire button, 11, 99, 247
Drawing
toolbar, 35
Index

drawing
  additional pages, 136
  arc, 178
  area, 54
  block, 35
  box, 178
  bus, 12, 35, 106–107
  circle, 179
  connections, 107
  custom power and ground symbols, 103
  line, 179
  lower-level schematic, 248
  options, 109
  orthogonal wires and buses, 109
  symbol graphics, 178
  text, 38, 127, 180
  text box, 38, 126
  top-level schematic, 244
  wire, 11, 35, 104

DXF files
  exporting, 301

E

ECO, 298
  definition of, 332
  file formats, 292
EDIF 2.0.0, 292
edit attributes, 160
Edit Attributes button, 35, 93, 155, 210, 231
Edit Attributes dialog box, 135, 291
Edit Gate Types dialog box, 207
Edit Package Definition dialog box, 202
Edit Package Types dialog box, 205
Edit Reference Designator dialog box, 14, 229, 281
Edit Reference dialog box, 245
Edit Symbol button, 35, 94, 151
editing
  annotation items, 126
  annotation text, 128
  attribute, 88, 93
  bounding box, 196
  bus label, 107
  design, 2
  existing symbols, 188
  global, 93
  hidden power and ground pins, 194
  hierarchical block, 228
  hierarchical design, 2
  hierarchical symbols, 233
  instance of schematic, 241
  multi-sheet designs, 136
  open package library, 204
  package definition, 204
  package definition, active symbol, 204
  package types, 204
  page title, 122
  part attributes, 88
  part origin, 195
  parts, 85
  pin name on hierarchical block, 231
  pin numbers, 206
  pin types, 191
  schematic definition, 241
  selecting part, 188
  simulation models, 258
  single line text, 129
  symbol, 2
  symbol default attribute, 94
  text within text box, 127
  title block, 122
editor configuration, 214
Editor Configuration dialog box, 44, 214
electrical rules check, See ERC
definition of
  elements of a symbol, 178
existing file
  opening, 79
existing schematic
associating with a hierarchical block, 232
Export file specification dialog box, 303
Export Parts dialog box, 174
exporting
  bill-of-materials report, 290
  DXF Files, 301
  from the schematics editor, 303
  in the Symbol Editor, 304
  symbol, 174
file
  management, 19
  opening, 33
  saving, 33
fileset
  definition of, 332
filling shapes, 183
Find dialog box, 118
finding
  most recently placed part, 81
  part, 80, 118
fitting view to page, 70
flat schematic
  definition of, 332
flipping
  area of drawing, 186
  area of schematic, 87
  elements of a symbol, 185
  part, 86
Font dialog box, 62
fonts
  changing, 62
footprints
  for a component, 150
footprints, See package types
function keys, 39, 157

gate
  definition of, 332
Get New Part button, 82, 155
Get Package Definition dialog box, 204
Get Recent Part list, 81
Global Edit Attributes dialog box, 93
global editing
  definition of, 332
  global editing of attributes, 93
  global library, 7
  global port, 115
    definition of, 333
    labeling, 115
    placing, 114, 233
    symbol, 102, 114
    using, 114
graphical representation, 80
graphics properties
  changing, 131–132
  filling shapes, 183
Graphics Properties dialog box, 183
gravity
  definition of, 333
  settings, 55
  specifying, 57, 111, 164
  with snap-to-pin enabled, 111
gravity radius
  definition of, 333
grid
  definition of, 333
  display options, 55
  enabling or disabling display, 162
  settings, 55
  spacing, 57, 111, 163
  stay on, 56, 162
grid on
  display options, 162

hidden pins, 31
  definition of, 333
  editing, 194
hierarchical block
  converting to symbol, 235
  creating, 228
  creating a schematic for, 229
  editing, 228
  pin names, 231
  reference designator, 228
  resizing, 229
  selecting, 239
hierarchical design
  creating, 2, 244
  definition of, 333
  editing, 2
  methods, 227
Index

navigating through, 239
passing information between levels, 242
hierarchical parts, 29
hierarchical symbol, 233
selecting, 239
horizontal offset, 96
hotspot
definition of, 333

I
Import dialog box, 174
Import OrCAD File dialog box, 303
importing
annotation graphics, 133
bitmaps, 133
graphics, 181
in the schematic editor, 133
in the symbol editor, 181
into Microsoft Word, 121
metafiles, 133
symbol, 174
indicated severity of message, 74
insert picture, 181
Insert Picture button, 38, 133, 181
instance name
definition of, 333
interface
input ports, 230
output ports, 230
port, 236
interface port
definition of, 333
interface ports, 114
symbols, 230
interfacing
to other board layout products, 292

J
joining pins and wires, 31
junction, 31
definition of, 333

K
keyboard, 39, 157

L
label template, 108
labeling
bus, 12, 106–108
global port, 115
ports, 17
wire, 11, 13, 105, 108
layout netlist
creating, 293
file formats, 292
mapping files, 294
libraries
searching for parts, 82
library
browser, 84
configuring, 42
custom, 94
list of, 321
model, 80
name, 215
package, 80
path, 215
removing, 46
simulation model, 257
symbol, 42, 80, 173, 321
Library Browser dialog box, 8, 84, 115
library expansion and compression utility, 305
Library Settings dialog box, 44, 214
line, drawing, 179
loading
symbol libraries, 188
locating
new library, 45
pointer on schematic, 9, 39
source of message, 74

M
main functions of MicroSim Schematics, 2
main window, 32
managing files, 19
mapping files, 294
marker
attaching, 277
definition of, 333
using, 268
Marker Color button, 36
menus, 32, 153
message
  definition of, 333
Message Viewer, 74
  additional information, 76
closing, 76
  severity indicator, 74
  using, 73
metafiles
  importing, 133, 181
mirroring, See flipping
model
  behavioral, 237
definition, 80
  library, 80
  name, 316
  simulation, 256, 322
model definition
  definition of, 333
More Info button, 76
moving
  down in hierarchy, 239
  interface port symbols, 230
  non-electrical information, 135
  object on schematic, 117
  parts, 15
  symbol element, 187
text, 15
to top of hierarchy, 239
  up in hierarchy, 239
  wires, 15
msim.ini file
  configuring, 65
multiple elements
  selecting in symbol editor, 182
multiple line text
  adding, 126
multiple pages
  viewing, 138
multi-sheet designs
  connectivity, 136

N
navigating
  moving down in hierarchy, 239
  moving up in hierarchy, 239
  through hierarchical designs, 239
to top of hierarchy, 239
navigation, 334
nesting
  hierarchical symbols, 233
net
  definition of, 334
netlist
  definition of, 334
  simulation, 266
netlisting
  configuration items, 311
  EDIF, 314
  levels of schematics, 242
  preferences, 313
new attributes
  creating, 88
new file
  opening, 79
New File button, 33, 79, 154
New Symbol button, 155, 172
node names
  netlisting preferences, 313
nodeset
  definition of, 334
non-electrical information
  adding, 126
  annotation symbols, 134

O
off-page port
  definition of, 334
  symbol, 114
  using, 114
offset
  horizontal, 96
  vertical, 96
online Help, 74
Open File button, 33, 79, 154
opening
  existing file, 79
  file, 33
  new file, 79
options
  auto-fit, 141
  auto-naming, 13, 108
  auto-repeat, 9, 95
  configuration, 41
drawing, 109
editor configuration, 7
grid spacing, 163
orthogonality, 109
printig, 140
scaling, 141
specifying gravity, 164
text grid, 165
origin, 195
definition of, 334
orthogonal
connectivity, 109
drawing wires and buses, 109
enabling, 110
with rubberbanding enabled, 112
Outline border style, 53

P
package
definition of, 334
information, 201
library, 80
package class priorities, 284
package definition
active symbol, 204
contents, 280
copying, 203
creating, 202
creating new, 202
deleting, 211
ing, 202
how used, 280
name, 316
open package library, 204
where stored, 80
Package Definition dialog box, 202
Package dialog box, 282
package library
definition of, 334
package type class
definition of, 334
package types
adding, 212
configuring, 212
definition of, 334
editing, 204
list of, 201
multiple, 205
per pin assignment, 205
symbol, 150
packager, 280
packaging, 202
automatically, 282
information, 149
parts in design, 280
reference designators, 283
PADS layout, 292
page
border, 30
changing settings, 50
changing size, 49
connecting, 137
copying, 137
creating new, 136
definition of, 334
deleting, 139
title, 122
title changing, 122
viewing, 138
viewing multiple, 138
Page Info dialog box, 122
Page Settings dialog box, 54
Page Size dialog box, 49
Pan & Zoom dialog box, 69, 71
panning
automatic, 71
new center, 70
part
auto-repeat, 95
copying, 94
definition of, 334
finding, 80, 118
flipping, 86
graphical representation, 29
hierarchical, 29
instance, 90
moving, 15, 117
packaging, 201
placing, 85, 98
primitve, 29
replacing, 100
rotating, 86
searching, 117
selecting, 81, 116–117
part attributes
specifying, 255
part browser, 82
advanced, 82
basic, 82
Part Browser dialog box, 8–9, 16, 82, 245
part description
definition of, 334
part instance
  changing display of attributes, 91
definition of, 334
part origin
  editing, 195
part outline
  definition of, 335
part value, changing, 14
parts
  placing and editing, 85
  stopping placement, 85
passing information between levels of hierarchy, 242
pasting
  between pages, 138
  selected object, 119, 190
P-CAD layout, 292
pin
  adding to a symbol, 180
  assignments, 205
  broken, 256
  definition of, 335
  hidden, 31, 333
  name, 160, 206
  number, 160
  shared power and ground, 208
  snap to, 57, 110, 163
  swapping, 209, 291
  text characteristics, 160
  unmodeled, 80, 256
pin assignment list, 201
Pin Assignments dialog box, 206
pin definition
  definition of, 335
pin names
  changing on the block, 247
definition of, 335
displaying, 193
pin numbers
  assigning, 208
  changing, 192
definition of, 335
determining, 281
displaying, 193
  editing, 206
  specifying physical, 206
pin on hierarchical block
  deleting, 231
Pin Swaps dialog box, 209
Pin Type dialog box, 191
pin types
  available, 191
  changing, 192
defining, 191
  selecting a default, 191
pin-to-pin spacing, 55
definition of, 335
Place Pins button, 155, 180
Place Text dialog box, 180
placing
  bus and part, 98
  connectors, 277
  global ports, 115, 233
  interface ports, 233
  parts, 8, 85
  ports, 16
  power and ground symbols, 17, 102
  previously selected part, 81
  repeating, 95
  resistors, 9
  stimulus sources, 259
  symbol, 85
  voltage source, 245
pointer behavior, 131
popping, 239
port
  definition of, 335
  global, 114, 333
  interface, 230, 236, 333
  labeling, 17
  off-page, 114, 137, 334
  placing, 16
  where used, 30
Ports and connectors
  distinctions between, 277
power and ground symbols, 17, 102
power symbols, custom, 103
prerequisite to drawing schematic, 2
primitive parts, 29
primitive symbol, 233
definition of, 335
Print button, 33, 140
Print dialog box, 140, 167
printing
  bill-of-materials report, 287
design, 140
  options, 140
  schematic, 140
  selected area, 140
  symbol, 167
properties
  changing, 128
Protel layout format, 292
pushing, 239
  into block, 227

R
Redraw button, 34, 39, 153, 155
reference designator
  assigning, 97, 281
  auto-naming, 97
  changing, 14, 229
  definition of, 335
  value, 318
refreshing the screen, 39
Remove Package Definition dialog box, 211
removing
  configured library, 46
  package definition, 211
repeating part placement, 95
Replace Part dialog box, 100
replacing
  multiple parts, 101
  parts, 100
  same name parts, 101
  single part, 100
Report Setup dialog box, 288
Reports dialog box, 287
resistor
  changing default value, 94
resizing
  annotation graphics, 131
  bitmap, 133
  bounding box, 196
  hierarchical block, 229
  imported graphic, 133
  text box, 127–128
  Windows metafile, 133
returning
  to schematic editor, 152
rewiring, 105
rotating
  area of drawing, 185
  area of schematic, 86
  elements of a symbol, 185
  part, 9, 86
rubberbanding
  connectivity, 111
  enabling, 113
  orthogonal
    disabled with rubberbanding enabled, 112
    with orthogonal enabled, 112
  rules of connectivity, 106
S
Save File button, 33, 154, 248
saving
  bill-of-materials report, 287
  file, 33, 248, 251
  schematic, 18
  symbol, 176
  to a library, 176
scale factor setting, 69
scaling, 141
schematic
  associating with hierarchical block, 232
  definition of, 335
  editing definition, 241
  editing instance of, 241
  locating in hierarchy, 240
  symbolizing, 234
  translating, 237
schematic editor
  closing, 146
  exporting, 303
  importing graphics, 133
  returning, 152
  using, 27
Schematics Export dialog box, 303
SCICARDS layout format, 292
search criteria, 118
searching
  for parts, 82, 117
  for schematic in hierarchy, 240
Select Page dialog box, 138
Select Part button, 35, 245
select recent part list size, 67
selecting
  area of schematic, 116
  area of symbol drawing, 182
  area of view, 68
  attribute of object, 116
  auto-repeat, 95
  default pin types, 191
  element of drawing, 182
  fonts, 62
library, 84
multiple elements, 182
multiple objects, 116
objects on schematic, 116
part by description, 83
part by name, 81
part for editing, 188
part from symbol library, 84
parts, 8
selection area
definition of, 336
selection rectangle, 116
Set Attribute Level dialog box, 242
Set Attribute Value dialog box, 11, 105
Set Up Block dialog box, 229, 248
setpoint
definition of, 336
settingautosave interval, 58
border style, 50
default properties, 60
outline border, 50
package class priorities, 284
scale factor, 69
zoned border, 50
zoom parameters, 69
Setup Package Class Priorities dialog box, 284
shapes, filling, 183
Shared Pin Assignments dialog box, 208
shortcutsfunction keys, 39, 157
toolbar buttons, 33
Show/Hide Currents on Selected Part(s) button, 37
Show/Hide Voltage on Selected Net(s) button, 37
Simulationtoolbar, 36
simulationattaching markers, 277
attribute, 255
checklist, 80
definition of, 336
models, 80, 150, 256, 322
parts designated for, 318
Simulation button, 36
simulation libraryconfiguring, 257
simulation modeldefined, 257
editing, 258
library, 257
single line textediting, 129
snap-to-grid
enabling or disabling, 163
snap-to-pin, 57, 110, 163
sourcecurrent stimulus, 259
digital stimulus, 259
voltage stimulus, 259
spacings, pin-to-pin, 55
specifyingmulti-gate component information, 207
par packaging information, 201
part attributes, 255
physical pin numbers, 206
pin types, 191
text grid size, 165
splittingsbus, 107
Standard Schematics toolbar, 33
startingnew design, 6
schematic editor, 79
simulator, 266
symbol editor, 134, 151
symbol editor automatically, 152
starting SchematicsMotif, 6
status bar, 39
stay-on-grid, 56, 162
with snap-to-grid enabled, 110, 163
stimulusadding, 259
defining, 259
definition of, 336
editor, 259
source, 80
swapping pins, 291
symbolaccessing, 188
annotation, 30
as element of a component, 149
base, 175
connector, 279
converting from block, 235
copying, 173
creating, 2, 171
default attribute, 94
definition of, 336
Index

editing, 2, 94, 188
elements of, 178
exporting, 174
global port, 102
hierarchical, 233
library, 42, 80, 173, 321
placing, 85
port, 30
primitive, 233
printing, 167
stopping placement, 85
wiring, 247
symbol aliases, 200
symbol attribute
COMPONENT, 316
GATE, 316
GATETYPE, 316
MODEL, 316
PART, 317
PKGREF, 317
PKGTYPE, 317
REFDES, 318
SIMULATION-ONLY, 318
TEMPLATE, 318
symbol editor
automatically starting, 152
closing, 152
creating annotation symbols, 134
exporting, 304
importing graphics, 181
part attributes, 255
rotating and flipping, 185
selecting an area, 182
shape filling, 183
starting, 151
window, 153
symbol graphics
drawing, 178
symbol libraries, 214
browsing, 84
loading, 188
making available in Schematics, 214
table of, 323
See also library
Symbol Wizard, 171
Symbol Wizard dialog box, 172
symbolize, 233
definition of, 336
symbolizing a schematic, 234
symbols
annotation, 134
Symbols Export dialog box, 304
syntax
bus labeling, 106

T
TangoPro layout format, 292
text
adding to a symbol, 180
attribute, 158
characteristics, 158
drawing, 38
free-standing, 161
grid, 58, 165
moving, 15
text box
drawing, 126
editing text within, 127
resizing, 127
text grid
enabling, 165
text properties
changing, 128
changing in display preferences, 129
changing on instance basis, 128
text wrap, 127–128
title bar, 156
title block
changing attributes, 123
creating, 122
creating a custom, 124
editing, 122
use, 30
toolbar buttons
Analysis Setup, 36
Current Marker, 36
Draw Arc, 38, 154, 178
Draw Block, 35, 228
Draw Box, 38, 154, 178
Draw Bus, 12, 35, 98
Draw Circle, 38, 155, 179
Draw Polyline, 38, 155, 179
Draw Text, 38, 127, 155, 180
Draw Text Box, 38
Draw Wire, 11, 35, 99
Edit Attributes, 35, 93, 155, 210, 231
Edit Symbol, 35, 94, 151
Enable Bias Current Display, 37
Enable Bias Voltage Display, 37
Get New Part, 82, 155
Insert Picture, 38, 133, 181
Marker Color, 36
More Info, 76
New File, 33, 79, 154
New Symbol, 155, 172
Open File, 33, 79, 154
Place Pins, 155, 180
Print, 33, 140
Redraw, 34, 39, 153, 155
Save File, 33, 154, 248
Select Part, 8, 35, 245
Show/Hide Currents on Selected Part(s), 37
Show/Hide Voltage on Selected Net(s), 37
Simulation, 36
Voltage/Level Marker, 36
Zoom Area, 34, 68, 154
Zoom In, 34, 68, 154
Zoom Out, 34, 69, 154
Zoom to Fit Page, 34, 70, 154

toolbars, 154
Annotation Graphics, 38
display of, 33
Drawing, 35
how to dock, 33
Simulation, 36
Standard Schematics, 33

translating
schematic, 237
setting up associated view, 238

translator, 237
definition of, 336
Translators dialog box, 238
tutorial, See examples

U

Undo/Redo, 120
unmodeled pins, 80, 256
user definable
zoom factor, 142
user defined component information, 289
using
AKO symbols, 175
auto-naming, 98
auto-repeat, 98
back annotation, 299
Design Manager, 19
global ports, 114
interface ports, 236
marker, 268
Message Viewer, 73
schematic editor, 27
stimulus editor, 259
symbol in schematic, 194
utilities
library compression, 305
library expansion, 305

V

value
instance-specific part, 241
of attribute, 30
vertical offset, 96

view
associated, 238
behavioral model, 237
definition of, 336
setting up, 238
setting up multiple, 237

viewing
multiple pages, 138
page, 70
particular page, 138
selected area, 68
simulation model, 256
simulation results, 267

viewpoint
definition of, 336
voltage stimulus source, 259
voltage viewpoint
definition of, 336
Voltage/Level Marker button, 36

W

Where dialog box, 240
where to find programs, 64
wildcard characters, 82–83, 118
window
main, 32
symbol editor, 151, 153
wire
definition of, 336
drawing, 11, 35, 104
labeling, 11, 13, 105, 108
Index

moving, 15
orthogonal, 109
rewiring segment, 105
selecting, 116
wire segment
  adding, 104
wiring
  symbols, 247
wizard
  symbol creation, 171
workspaces, 19

Z
zoned border style, 53
Zoom Area button, 34, 68, 154
zoom factor, 142
Zoom In button, 34, 68, 154
Zoom Out button, 34, 69, 154
zoom parameters
  setting, 69
Zoom to Fit Page button, 34, 70, 154